PerpetuumSoft.Reporting.WebViewer.Client Namespace

[image]

SharpShooter Reports.Web
PerpetuumSoft.Reporting.WebViewer.Client Namespace
Send Feedback
Client side classes.

Classes

 | Class | Description
Public class | ClientError | Class represents information about the error occurred on the client.
Public class | CommunicationError | Class represents information about the communication error.
Public class | DClass | Used for processing of an object which was received from a server.
Public class | DocumentManager | Manages loading of documents from a server.
Public class | ErrorBase | Base class represents information about the errors.
Public class | ErrorLocalizeProvider | Returns messages about errors occurred in the client's application.
Public class | ErrorModel | Class represents information about type and information of error.
Public class | ErrorProvider | Class provides error handling
Public class | JsonDataConverter | Processes an object which was received from a server.
Public class | ReportViewer | An object for a report representation, navigation and export.
Public class | ServerError | Class represents information about the error occurred on the server.
Public class | ServiceProvider | Provides generation and sending of queries to service for reports getting.
Public class | Viewport | Class which checks visibility of the container element objects.

Interfaces

 | Interface | Description
Public interface | IReportService | Exposes a method for getting report.

Delegates

 | Delegate | Description
Public delegate | DocumentInfoLoadedCallback | The callback function which is invoked when data about a document were received from a server.
Public delegate | DocumentMapElementClickCallback | The callback function which is invoked when a user clicks an element in bookmarks tree.
Public delegate | DocumentMapInfoCallback | The callback function which is invoked when data about bookmarks tree were received from a server.
Public delegate | ErrorCallback | The callback function which is invoked when an error occurs.
Public delegate | HyperlinkCallback | The callback function which is invoked when a user clicks a hyperlink in a report.
Public delegate | PageCallback | The callback function which is used to inform a user about change of a page number.
Public delegate | PageInfoLoadedCallback | The callback function which is invoked when data about a page were received from a server.
Public delegate | ReportParametersLoadedCallback | The callback function which is invoked when report parameters were received from a server.
Public delegate | ThumbnailsInfoLoadedCallback | The callback function which is invoked when data about thumbnails were received from a server.

Enumerations

 | Enumeration | Description
Public enumeration | DocumentStatus | Defines document's status during a report loading.
Public enumeration | ErrorType | Defines types of errors occurred in a application.


ClientError Class

[image]

SharpShooter Reports.Web
ClientError Class
Members See Also Send Feedback
Class represents information about the error occurred on the client.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ClientError : ErrorBase
Visual Basic
Public Class ClientError _
    Inherits ErrorBase
Visual C++
public ref class ClientError : public ErrorBase

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorBase
PerpetuumSoft.Reporting.WebViewer.Client..::..ClientError

See Also

ClientError Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ClientError Members

[image] [image]

SharpShooter Reports.Web
ClientError Members
ClientError Class Constructors Methods Fields See Also Send Feedback

The ClientError type exposes the following members.

Constructors

 | Name | Description
Public method | ClientError | Initialaze new instanse of PerpetuumSoft.Reporting.WebViewer.Client.ClientError class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformation | Get additional error information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Message | Get or set error message. (Inherited from ErrorBase.)

See Also

ClientError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ClientError Constructor

[image]

SharpShooter Reports.Web
ClientError Constructor
ClientError Class See Also Send Feedback
Initialaze new instanse of PerpetuumSoft.Reporting.WebViewer.Client.ClientError class.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ClientError(
    Exception exception
)
Visual Basic
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
ClientError(
    Exception^ exception
)

Parameters

exception
Type: System..::..Exception
Exception

See Also

ClientError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ClientError Fields

[image] [image]

SharpShooter Reports.Web
ClientError Fields
ClientError Class See Also Send Feedback

The ClientError type exposes the following members.

Fields

 | Name | Description
Public field | Message | Get or set error message. (Inherited from ErrorBase.)

See Also

ClientError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ClientError Methods

[image] [image]

SharpShooter Reports.Web
ClientError Methods
ClientError Class See Also Send Feedback

The ClientError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformation | Get additional error information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetInformation Method

[image]

SharpShooter Reports.Web
ClientError..::..GetInformation Method
ClientError Class See Also Send Feedback
Get additional error information.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Exception GetInformation()
Visual Basic
Public Function GetInformation As Exception
Visual C++
public:
Exception^ GetInformation()

Return Value

The additional error information.

See Also

ClientError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


CommunicationError Class

[image]

SharpShooter Reports.Web
CommunicationError Class
Members See Also Send Feedback
Class represents information about the communication error.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CommunicationError : ErrorBase
Visual Basic
Public Class CommunicationError _
    Inherits ErrorBase
Visual C++
public ref class CommunicationError : public ErrorBase

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorBase
PerpetuumSoft.Reporting.WebViewer.Client..::..CommunicationError

See Also

CommunicationError Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


CommunicationError Members

[image] [image]

SharpShooter Reports.Web
CommunicationError Members
CommunicationError Class Constructors Methods Fields See Also Send Feedback

The CommunicationError type exposes the following members.

Constructors

 | Name | Description
Public method | CommunicationError | Initialaze new instanse of PerpetuumSoft.Reporting.WebViewer.Client.CommunicationError class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetError | Get the error or exception if any.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRequest | Get the request that was invoked.
Public method | GetTextStatus | Get the status of the request.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Message | Get or set error message. (Inherited from ErrorBase.)

See Also

CommunicationError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


CommunicationError Constructor

[image]

SharpShooter Reports.Web
CommunicationError Constructor
CommunicationError Class See Also Send Feedback
Initialaze new instanse of PerpetuumSoft.Reporting.WebViewer.Client.CommunicationError class.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CommunicationError(
    jQueryXmlHttpRequest request,
    string textStatus,
    Exception error
)
Visual Basic
Public Sub New ( _
    request As jQueryXmlHttpRequest, _
    textStatus As String, _
    error As Exception _
)
Visual C++
public:
CommunicationError(
    jQueryXmlHttpRequest^ request,
    String^ textStatus,
    Exception^ error
)

Parameters

request
Type: jQueryXmlHttpRequest
The request that was invoked.
textStatus
Type: System..::..String
The status of the pageInfoRequest.
error
Type: System..::..Exception
The error or exception if any.

See Also

CommunicationError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


CommunicationError Fields

[image] [image]

SharpShooter Reports.Web
CommunicationError Fields
CommunicationError Class See Also Send Feedback

The CommunicationError type exposes the following members.

Fields

 | Name | Description
Public field | Message | Get or set error message. (Inherited from ErrorBase.)

See Also

CommunicationError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


CommunicationError Methods

[image] [image]

SharpShooter Reports.Web
CommunicationError Methods
CommunicationError Class See Also Send Feedback

The CommunicationError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetError | Get the error or exception if any.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRequest | Get the request that was invoked.
Public method | GetTextStatus | Get the status of the request.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommunicationError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetError Method

[image]

SharpShooter Reports.Web
CommunicationError..::..GetError Method
CommunicationError Class See Also Send Feedback
Get the error or exception if any.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Exception GetError()
Visual Basic
Public Function GetError As Exception
Visual C++
public:
Exception^ GetError()

Return Value

The error or exception if any.

See Also

CommunicationError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetRequest Method

[image]

SharpShooter Reports.Web
CommunicationError..::..GetRequest Method
CommunicationError Class See Also Send Feedback
Get the request that was invoked.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public jQueryXmlHttpRequest GetRequest()
Visual Basic
Public Function GetRequest As jQueryXmlHttpRequest
Visual C++
public:
jQueryXmlHttpRequest^ GetRequest()

Return Value

The pageInfoRequest that was invoked.

See Also

CommunicationError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetTextStatus Method

[image]

SharpShooter Reports.Web
CommunicationError..::..GetTextStatus Method
CommunicationError Class See Also Send Feedback
Get the status of the request.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetTextStatus()
Visual Basic
Public Function GetTextStatus As String
Visual C++
public:
String^ GetTextStatus()

Return Value

The status of the request.

See Also

CommunicationError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DClass Class

[image]

SharpShooter Reports.Web
DClass Class
Members See Also Send Feedback
Used for processing of an object which was received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DClass
Visual Basic
Public Class DClass
Visual C++
public ref class DClass

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..DClass

See Also

DClass Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DClass Members

[image] [image]

SharpShooter Reports.Web
DClass Members
DClass Class Constructors Methods See Also Send Feedback

The DClass type exposes the following members.

Constructors

 | Name | Description
Public method | DClass | Initializes a new instance of the DClass class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DClass Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DClass Constructor

[image]

SharpShooter Reports.Web
DClass Constructor
DClass Class See Also Send Feedback
Initializes a new instance of the DClass class

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DClass()
Visual Basic
Public Sub New
Visual C++
public:
DClass()

See Also

DClass Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DClass Methods

[image] [image]

SharpShooter Reports.Web
DClass Methods
DClass Class See Also Send Feedback

The DClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DClass Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentInfoLoadedCallback Delegate

[image]

SharpShooter Reports.Web
DocumentInfoLoadedCallback Delegate
See Also Send Feedback
The callback function which is invoked when data about a document were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void DocumentInfoLoadedCallback(
    List<ElementSizeModel> pages
)
Visual Basic
Public Delegate Sub DocumentInfoLoadedCallback ( _
    pages As List(Of ElementSizeModel) _
)
Visual C++
public delegate void DocumentInfoLoadedCallback(
    List<ElementSizeModel^>^ pages
)

Parameters

pages
Type: System.Collections.Generic..::..List <(Of <(<' ElementSizeModel >)>)>
Report pages list.

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentManager Class

[image]

SharpShooter Reports.Web
DocumentManager Class
Members See Also Send Feedback
Manages loading of documents from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DocumentManager
Visual Basic
Public Class DocumentManager
Visual C++
public ref class DocumentManager

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..DocumentManager

See Also

DocumentManager Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentManager Members

[image] [image]

SharpShooter Reports.Web
DocumentManager Members
DocumentManager Class Constructors Methods Fields See Also Send Feedback

The DocumentManager type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentManager | Creates the PerpetuumSoft.Reporting.WebViewer.Client.DocumentManager class instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportDocument | Perfprms query for export of a document in the specified format. Opens a browser window and redirects a stream from server to this window.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBookmarkInfo | Returns data about a bookmark.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServiceUrl | Gets service Url.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadDocumentInfo | Performs rendering of the report and loads the report metadata.
Public method | LoadDocumentMapInfo | Performs query for bookmarks tree loading.
Public method | LoadPageInfo | Loads a page metadata.
Public method | LoadPageInfoFull | Performs rendering of the report and loads a page metadata.
Public method | LoadReportParameters | Loads a parameters list which used in report.
Public method | LoadThumbnailsInfo | Loads a list of links for thumbnails.
Public method | LoadThumbnailsInfoFull | Performs rendering of the report and loads a list of links for thumbnails.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrintDocument | Performs query for a document printing. Opens a browser window and redirects a stream from server to this window.
Public method | SetPageCacheSize | Sets a page cache size.
Public method | SetServiceUrl | Sets Url for connection to service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentInfoLoadedEvent | Occurs when data about a document were received from a server.
Public field | DocumentMapInfoLoadedEvent | Occurs when data about bookmarks tree were received from a server.
Public field | DocumentTitle | Gets or sets a document title.
Public field | ExportWindowParam | Gets or sets the parameters which uses when executed "window.open" for export document.
Public field | PageDeletedFromCacheEvent | Occurs when a page was removed from cache.
Public field | PageInfoLoadedEvent | Occurs when data about a page were received from a server.
Public field | PrintWindowParam | Gets or sets the parameters which uses when executed "window.open" for print document.
Public field | ReportParametersLoadedEvent | Occurs when report parameters were received from a server.
Public field | Status | Gets or sets the document state.
Public field | ThumbnailsInfoLoadedEvent | Occurs when data about pages thumbnails were received from a server.
Public field | ThumbnailSize | Gets and sets thumbnails sizes.
Public field | ThumbnailsLink | Gets or sets a list of links for loading thumbnails for each page.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentManager Constructor

[image]

SharpShooter Reports.Web
DocumentManager Constructor
DocumentManager Class See Also Send Feedback
Creates the PerpetuumSoft.Reporting.WebViewer.Client.DocumentManager class instance.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentManager(
    ErrorProvider errorProvider
)
Visual Basic
Public Sub New ( _
    errorProvider As ErrorProvider _
)
Visual C++
public:
DocumentManager(
    ErrorProvider^ errorProvider
)

Parameters

errorProvider
Type: PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorProvider
The PerpetuumSoft.Reporting.WebViewer.Client.ErrorProvider class object which provides access to the errors occurred during the component work.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentManager Fields

[image] [image]

SharpShooter Reports.Web
DocumentManager Fields
DocumentManager Class See Also Send Feedback

The DocumentManager type exposes the following members.

Fields

 | Name | Description
Public field | DocumentInfoLoadedEvent | Occurs when data about a document were received from a server.
Public field | DocumentMapInfoLoadedEvent | Occurs when data about bookmarks tree were received from a server.
Public field | DocumentTitle | Gets or sets a document title.
Public field | ExportWindowParam | Gets or sets the parameters which uses when executed "window.open" for export document.
Public field | PageDeletedFromCacheEvent | Occurs when a page was removed from cache.
Public field | PageInfoLoadedEvent | Occurs when data about a page were received from a server.
Public field | PrintWindowParam | Gets or sets the parameters which uses when executed "window.open" for print document.
Public field | ReportParametersLoadedEvent | Occurs when report parameters were received from a server.
Public field | Status | Gets or sets the document state.
Public field | ThumbnailsInfoLoadedEvent | Occurs when data about pages thumbnails were received from a server.
Public field | ThumbnailSize | Gets and sets thumbnails sizes.
Public field | ThumbnailsLink | Gets or sets a list of links for loading thumbnails for each page.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentInfoLoadedEvent Field

[image]

SharpShooter Reports.Web
DocumentManager..::..DocumentInfoLoadedEvent Field
DocumentManager Class See Also Send Feedback
Occurs when data about a document were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentInfoLoadedCallback DocumentInfoLoadedEvent
Visual Basic
Public DocumentInfoLoadedEvent As DocumentInfoLoadedCallback
Visual C++
public:
DocumentInfoLoadedCallback^ DocumentInfoLoadedEvent

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentMapInfoLoadedEvent Field

[image]

SharpShooter Reports.Web
DocumentManager..::..DocumentMapInfoLoadedEvent Field
DocumentManager Class See Also Send Feedback
Occurs when data about bookmarks tree were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentMapInfoCallback DocumentMapInfoLoadedEvent
Visual Basic
Public DocumentMapInfoLoadedEvent As DocumentMapInfoCallback
Visual C++
public:
DocumentMapInfoCallback^ DocumentMapInfoLoadedEvent

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentTitle Field

[image]

SharpShooter Reports.Web
DocumentManager..::..DocumentTitle Field
DocumentManager Class See Also Send Feedback
Gets or sets a document title.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DocumentTitle
Visual Basic
Public DocumentTitle As String
Visual C++
public:
String^ DocumentTitle

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ExportWindowParam Field

[image]

SharpShooter Reports.Web
DocumentManager..::..ExportWindowParam Field
DocumentManager Class See Also Send Feedback
Gets or sets the parameters which uses when executed "window.open" for export document.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExportWindowParam
Visual Basic
Public ExportWindowParam As String
Visual C++
public:
String^ ExportWindowParam

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


PageDeletedFromCacheEvent Field

[image]

SharpShooter Reports.Web
DocumentManager..::..PageDeletedFromCacheEvent Field
DocumentManager Class See Also Send Feedback
Occurs when a page was removed from cache.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageCallback PageDeletedFromCacheEvent
Visual Basic
Public PageDeletedFromCacheEvent As PageCallback
Visual C++
public:
PageCallback^ PageDeletedFromCacheEvent

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


PageInfoLoadedEvent Field

[image]

SharpShooter Reports.Web
DocumentManager..::..PageInfoLoadedEvent Field
DocumentManager Class See Also Send Feedback
Occurs when data about a page were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageInfoLoadedCallback PageInfoLoadedEvent
Visual Basic
Public PageInfoLoadedEvent As PageInfoLoadedCallback
Visual C++
public:
PageInfoLoadedCallback^ PageInfoLoadedEvent

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


PrintWindowParam Field

[image]

SharpShooter Reports.Web
DocumentManager..::..PrintWindowParam Field
DocumentManager Class See Also Send Feedback
Gets or sets the parameters which uses when executed "window.open" for print document.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PrintWindowParam
Visual Basic
Public PrintWindowParam As String
Visual C++
public:
String^ PrintWindowParam

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ReportParametersLoadedEvent Field

[image]

SharpShooter Reports.Web
DocumentManager..::..ReportParametersLoadedEvent Field
DocumentManager Class See Also Send Feedback
Occurs when report parameters were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportParametersLoadedCallback ReportParametersLoadedEvent
Visual Basic
Public ReportParametersLoadedEvent As ReportParametersLoadedCallback
Visual C++
public:
ReportParametersLoadedCallback^ ReportParametersLoadedEvent

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


Status Field

[image]

SharpShooter Reports.Web
DocumentManager..::..Status Field
DocumentManager Class See Also Send Feedback
Gets or sets the document state.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentStatus Status
Visual Basic
Public Status As DocumentStatus
Visual C++
public:
DocumentStatus Status

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ThumbnailsInfoLoadedEvent Field

[image]

SharpShooter Reports.Web
DocumentManager..::..ThumbnailsInfoLoadedEvent Field
DocumentManager Class See Also Send Feedback
Occurs when data about pages thumbnails were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThumbnailsInfoLoadedCallback ThumbnailsInfoLoadedEvent
Visual Basic
Public ThumbnailsInfoLoadedEvent As ThumbnailsInfoLoadedCallback
Visual C++
public:
ThumbnailsInfoLoadedCallback^ ThumbnailsInfoLoadedEvent

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ThumbnailSize Field

[image]

SharpShooter Reports.Web
DocumentManager..::..ThumbnailSize Field
DocumentManager Class See Also Send Feedback
Gets and sets thumbnails sizes.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThumbnailSizeModel ThumbnailSize
Visual Basic
Public ThumbnailSize As ThumbnailSizeModel
Visual C++
public:
ThumbnailSizeModel^ ThumbnailSize

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ThumbnailsLink Field

[image]

SharpShooter Reports.Web
DocumentManager..::..ThumbnailsLink Field
DocumentManager Class See Also Send Feedback
Gets or sets a list of links for loading thumbnails for each page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> ThumbnailsLink
Visual Basic
Public ThumbnailsLink As List(Of String)
Visual C++
public:
List<String^>^ ThumbnailsLink

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentManager Methods

[image] [image]

SharpShooter Reports.Web
DocumentManager Methods
DocumentManager Class See Also Send Feedback

The DocumentManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportDocument | Perfprms query for export of a document in the specified format. Opens a browser window and redirects a stream from server to this window.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBookmarkInfo | Returns data about a bookmark.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServiceUrl | Gets service Url.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadDocumentInfo | Performs rendering of the report and loads the report metadata.
Public method | LoadDocumentMapInfo | Performs query for bookmarks tree loading.
Public method | LoadPageInfo | Loads a page metadata.
Public method | LoadPageInfoFull | Performs rendering of the report and loads a page metadata.
Public method | LoadReportParameters | Loads a parameters list which used in report.
Public method | LoadThumbnailsInfo | Loads a list of links for thumbnails.
Public method | LoadThumbnailsInfoFull | Performs rendering of the report and loads a list of links for thumbnails.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrintDocument | Performs query for a document printing. Opens a browser window and redirects a stream from server to this window.
Public method | SetPageCacheSize | Sets a page cache size.
Public method | SetServiceUrl | Sets Url for connection to service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ExportDocument Method

[image]

SharpShooter Reports.Web
DocumentManager..::..ExportDocument Method
DocumentManager Class See Also Send Feedback
Perfprms query for export of a document in the specified format. Opens a browser window and redirects a stream from server to this window.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ExportDocument(
    string format
)
Visual Basic
Public Sub ExportDocument ( _
    format As String _
)
Visual C++
public:
void ExportDocument(
    String^ format
)

Parameters

format
Type: System..::..String
Document format.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetBookmarkInfo Method

[image]

SharpShooter Reports.Web
DocumentManager..::..GetBookmarkInfo Method
DocumentManager Class See Also Send Feedback
Returns data about a bookmark.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BookmarkInfo GetBookmarkInfo(
    string bookmark
)
Visual Basic
Public Function GetBookmarkInfo ( _
    bookmark As String _
) As BookmarkInfo
Visual C++
public:
BookmarkInfo^ GetBookmarkInfo(
    String^ bookmark
)

Parameters

bookmark
Type: System..::..String
Bookmark name.

Return Value

Data about a bookmark.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetServiceUrl Method

[image]

SharpShooter Reports.Web
DocumentManager..::..GetServiceUrl Method
DocumentManager Class See Also Send Feedback
Gets service Url.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetServiceUrl()
Visual Basic
Public Function GetServiceUrl As String
Visual C++
public:
String^ GetServiceUrl()

Return Value

Service Url.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadDocumentInfo Method

[image]

SharpShooter Reports.Web
DocumentManager..::..LoadDocumentInfo Method
DocumentManager Class See Also Send Feedback
Performs rendering of the report and loads the report metadata.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadDocumentInfo(
    string reportName,
    List<ParameterModel> parameters
)
Visual Basic
Public Sub LoadDocumentInfo ( _
    reportName As String, _
    parameters As List(Of ParameterModel) _
)
Visual C++
public:
void LoadDocumentInfo(
    String^ reportName,
    List<ParameterModel^>^ parameters
)

Parameters

reportName
Type: System..::..String
Report name.
parameters
Type: System.Collections.Generic..::..List <(Of <(<' ParameterModel >)>)>
Report parameters.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadDocumentMapInfo Method

[image]

SharpShooter Reports.Web
DocumentManager..::..LoadDocumentMapInfo Method
DocumentManager Class See Also Send Feedback
Performs query for bookmarks tree loading.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadDocumentMapInfo()
Visual Basic
Public Sub LoadDocumentMapInfo
Visual C++
public:
void LoadDocumentMapInfo()

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadPageInfo Method

[image]

SharpShooter Reports.Web
DocumentManager..::..LoadPageInfo Method
DocumentManager Class See Also Send Feedback
Loads a page metadata.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadPageInfo(
    int pageNumber
)
Visual Basic
Public Sub LoadPageInfo ( _
    pageNumber As Integer _
)
Visual C++
public:
void LoadPageInfo(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
Page number.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadPageInfoFull Method

[image]

SharpShooter Reports.Web
DocumentManager..::..LoadPageInfoFull Method
DocumentManager Class See Also Send Feedback
Performs rendering of the report and loads a page metadata.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadPageInfoFull(
    int pageNumber
)
Visual Basic
Public Sub LoadPageInfoFull ( _
    pageNumber As Integer _
)
Visual C++
public:
void LoadPageInfoFull(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
Page number.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadReportParameters Method

[image]

SharpShooter Reports.Web
DocumentManager..::..LoadReportParameters Method
DocumentManager Class See Also Send Feedback
Loads a parameters list which used in report.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadReportParameters(
    string reportName
)
Visual Basic
Public Sub LoadReportParameters ( _
    reportName As String _
)
Visual C++
public:
void LoadReportParameters(
    String^ reportName
)

Parameters

reportName
Type: System..::..String
Report name.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadThumbnailsInfo Method

[image]

SharpShooter Reports.Web
DocumentManager..::..LoadThumbnailsInfo Method
DocumentManager Class See Also Send Feedback
Loads a list of links for thumbnails.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadThumbnailsInfo()
Visual Basic
Public Sub LoadThumbnailsInfo
Visual C++
public:
void LoadThumbnailsInfo()

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadThumbnailsInfoFull Method

[image]

SharpShooter Reports.Web
DocumentManager..::..LoadThumbnailsInfoFull Method
DocumentManager Class See Also Send Feedback
Performs rendering of the report and loads a list of links for thumbnails.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadThumbnailsInfoFull()
Visual Basic
Public Sub LoadThumbnailsInfoFull
Visual C++
public:
void LoadThumbnailsInfoFull()

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


PrintDocument Method

[image]

SharpShooter Reports.Web
DocumentManager..::..PrintDocument Method
DocumentManager Class See Also Send Feedback
Performs query for a document printing. Opens a browser window and redirects a stream from server to this window.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void PrintDocument()
Visual Basic
Public Sub PrintDocument
Visual C++
public:
void PrintDocument()

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetPageCacheSize Method

[image]

SharpShooter Reports.Web
DocumentManager..::..SetPageCacheSize Method
DocumentManager Class See Also Send Feedback
Sets a page cache size.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetPageCacheSize(
    int pageCountInCache
)
Visual Basic
Public Sub SetPageCacheSize ( _
    pageCountInCache As Integer _
)
Visual C++
public:
void SetPageCacheSize(
    int pageCountInCache
)

Parameters

pageCountInCache
Type: System..::..Int32
Page count which a document manager can storing in the cache.

Remarks

The value must be less than page count in the document and more than '0'. If the value equals zero the cache not used.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetServiceUrl Method

[image]

SharpShooter Reports.Web
DocumentManager..::..SetServiceUrl Method
DocumentManager Class See Also Send Feedback
Sets Url for connection to service.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetServiceUrl(
    string serviceUrl
)
Visual Basic
Public Sub SetServiceUrl ( _
    serviceUrl As String _
)
Visual C++
public:
void SetServiceUrl(
    String^ serviceUrl
)

Parameters

serviceUrl
Type: System..::..String
Service Url.

See Also

DocumentManager Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentMapElementClickCallback Delegate

[image]

SharpShooter Reports.Web
DocumentMapElementClickCallback Delegate
See Also Send Feedback
The callback function which is invoked when a user clicks an element in bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void DocumentMapElementClickCallback(
    string bookmarkName
)
Visual Basic
Public Delegate Sub DocumentMapElementClickCallback ( _
    bookmarkName As String _
)
Visual C++
public delegate void DocumentMapElementClickCallback(
    String^ bookmarkName
)

Parameters

bookmarkName
Type: System..::..String
A name of bookmark to which a user should be navigated.

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentMapInfoCallback Delegate

[image]

SharpShooter Reports.Web
DocumentMapInfoCallback Delegate
See Also Send Feedback
The callback function which is invoked when data about bookmarks tree were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void DocumentMapInfoCallback(
    string documentTree
)
Visual Basic
Public Delegate Sub DocumentMapInfoCallback ( _
    documentTree As String _
)
Visual C++
public delegate void DocumentMapInfoCallback(
    String^ documentTree
)

Parameters

documentTree
Type: System..::..String
Bookmarks tree.

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentStatus Enumeration

[image]

SharpShooter Reports.Web
DocumentStatus Enumeration
See Also Send Feedback
Defines document's status during a report loading.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DocumentStatus
Visual Basic
Public Enumeration DocumentStatus
Visual C++
public enum class DocumentStatus

Members

Member name | Description
Loading |
Loaded |
Error |

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorBase Class

[image]

SharpShooter Reports.Web
ErrorBase Class
Members See Also Send Feedback
Base class represents information about the errors.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ErrorBase
Visual Basic
Public MustInherit Class ErrorBase
Visual C++
public ref class ErrorBase abstract

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorBase
PerpetuumSoft.Reporting.WebViewer.Client..::..ClientError
PerpetuumSoft.Reporting.WebViewer.Client..::..CommunicationError
PerpetuumSoft.Reporting.WebViewer.Client..::..ServerError

See Also

ErrorBase Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorBase Members

[image] [image]

SharpShooter Reports.Web
ErrorBase Members
ErrorBase Class Constructors Methods Fields See Also Send Feedback

The ErrorBase type exposes the following members.

Constructors

 | Name | Description
Protected method | ErrorBase | Initializes a new instance of the ErrorBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Message | Get or set error message.

See Also

ErrorBase Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorBase Constructor

[image]

SharpShooter Reports.Web
ErrorBase Constructor
ErrorBase Class See Also Send Feedback
Initializes a new instance of the ErrorBase class

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ErrorBase()
Visual Basic
Protected Sub New
Visual C++
protected:
ErrorBase()

See Also

ErrorBase Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorBase Fields

[image] [image]

SharpShooter Reports.Web
ErrorBase Fields
ErrorBase Class See Also Send Feedback

The ErrorBase type exposes the following members.

Fields

 | Name | Description
Public field | Message | Get or set error message.

See Also

ErrorBase Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


Message Field

[image]

SharpShooter Reports.Web
ErrorBase..::..Message Field
ErrorBase Class See Also Send Feedback
Get or set error message.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Message
Visual Basic
Public Message As String
Visual C++
public:
String^ Message

See Also

ErrorBase Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorBase Methods

[image] [image]

SharpShooter Reports.Web
ErrorBase Methods
ErrorBase Class See Also Send Feedback

The ErrorBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ErrorBase Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorCallback Delegate

[image]

SharpShooter Reports.Web
ErrorCallback Delegate
See Also Send Feedback
The callback function which is invoked when an error occurs.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void ErrorCallback(
    ErrorModel errorModel
)
Visual Basic
Public Delegate Sub ErrorCallback ( _
    errorModel As ErrorModel _
)
Visual C++
public delegate void ErrorCallback(
    ErrorModel^ errorModel
)

Parameters

errorModel
Type: PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorModel
Data about an error.

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorLocalizeProvider Class

[image]

SharpShooter Reports.Web
ErrorLocalizeProvider Class
Members See Also Send Feedback
Returns messages about errors occurred in the client's application.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class ErrorLocalizeProvider
Visual Basic
Public NotInheritable Class ErrorLocalizeProvider
Visual C++
public ref class ErrorLocalizeProvider abstract sealed

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorLocalizeProvider

See Also

ErrorLocalizeProvider Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorLocalizeProvider Members

[image] [image]

SharpShooter Reports.Web
ErrorLocalizeProvider Members
ErrorLocalizeProvider Class Methods See Also Send Feedback

The ErrorLocalizeProvider type exposes the following members.

Methods

Name | Description
DocumentNotLoadedMessage | Message which informs that document is not loaded.
EmptyDocumentIdMessage | Message which informs that document identifier is empty.
EmptyResponseMessage | A message which informs that server response is empty.
EmptyResultMessage | Message which informs that response result is empty.
IndexOutOfRangeMessage | Message which informs that index is out of range.
ReportNameNotDefinedMessage | Message which informs that report name was not set.
ServiceUrlNotDefinedMessage | Message which informs that service Url was not set.

See Also

ErrorLocalizeProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorLocalizeProvider Methods

[image] [image]

SharpShooter Reports.Web
ErrorLocalizeProvider Methods
ErrorLocalizeProvider Class See Also Send Feedback

The ErrorLocalizeProvider type exposes the following members.

Methods

Name | Description
DocumentNotLoadedMessage | Message which informs that document is not loaded.
EmptyDocumentIdMessage | Message which informs that document identifier is empty.
EmptyResponseMessage | A message which informs that server response is empty.
EmptyResultMessage | Message which informs that response result is empty.
IndexOutOfRangeMessage | Message which informs that index is out of range.
ReportNameNotDefinedMessage | Message which informs that report name was not set.
ServiceUrlNotDefinedMessage | Message which informs that service Url was not set.

See Also

ErrorLocalizeProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentNotLoadedMessage Method

[image]

SharpShooter Reports.Web
ErrorLocalizeProvider..::..DocumentNotLoadedMessage Method
ErrorLocalizeProvider Class See Also Send Feedback
Message which informs that document is not loaded.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string DocumentNotLoadedMessage()
Visual Basic
Public Shared Function DocumentNotLoadedMessage As String
Visual C++
public:
static String^ DocumentNotLoadedMessage()

Return Value

Text of the message.

See Also

ErrorLocalizeProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


EmptyDocumentIdMessage Method

[image]

SharpShooter Reports.Web
ErrorLocalizeProvider..::..EmptyDocumentIdMessage Method
ErrorLocalizeProvider Class See Also Send Feedback
Message which informs that document identifier is empty.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string EmptyDocumentIdMessage()
Visual Basic
Public Shared Function EmptyDocumentIdMessage As String
Visual C++
public:
static String^ EmptyDocumentIdMessage()

Return Value

Text of the message.

See Also

ErrorLocalizeProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


EmptyResponseMessage Method

[image]

SharpShooter Reports.Web
ErrorLocalizeProvider..::..EmptyResponseMessage Method
ErrorLocalizeProvider Class See Also Send Feedback
A message which informs that server response is empty.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string EmptyResponseMessage()
Visual Basic
Public Shared Function EmptyResponseMessage As String
Visual C++
public:
static String^ EmptyResponseMessage()

Return Value

Text of the message.

See Also

ErrorLocalizeProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


EmptyResultMessage Method

[image]

SharpShooter Reports.Web
ErrorLocalizeProvider..::..EmptyResultMessage Method
ErrorLocalizeProvider Class See Also Send Feedback
Message which informs that response result is empty.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string EmptyResultMessage()
Visual Basic
Public Shared Function EmptyResultMessage As String
Visual C++
public:
static String^ EmptyResultMessage()

Return Value

Text of the message.

See Also

ErrorLocalizeProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


IndexOutOfRangeMessage Method

[image]

SharpShooter Reports.Web
ErrorLocalizeProvider..::..IndexOutOfRangeMessage Method
ErrorLocalizeProvider Class See Also Send Feedback
Message which informs that index is out of range.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string IndexOutOfRangeMessage()
Visual Basic
Public Shared Function IndexOutOfRangeMessage As String
Visual C++
public:
static String^ IndexOutOfRangeMessage()

Return Value

Text of the message.

See Also

ErrorLocalizeProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ReportNameNotDefinedMessage Method

[image]

SharpShooter Reports.Web
ErrorLocalizeProvider..::..ReportNameNotDefinedMessage Method
ErrorLocalizeProvider Class See Also Send Feedback
Message which informs that report name was not set.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string ReportNameNotDefinedMessage()
Visual Basic
Public Shared Function ReportNameNotDefinedMessage As String
Visual C++
public:
static String^ ReportNameNotDefinedMessage()

Return Value

Text of the message.

See Also

ErrorLocalizeProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServiceUrlNotDefinedMessage Method

[image]

SharpShooter Reports.Web
ErrorLocalizeProvider..::..ServiceUrlNotDefinedMessage Method
ErrorLocalizeProvider Class See Also Send Feedback
Message which informs that service Url was not set.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string ServiceUrlNotDefinedMessage()
Visual Basic
Public Shared Function ServiceUrlNotDefinedMessage As String
Visual C++
public:
static String^ ServiceUrlNotDefinedMessage()

Return Value

Text of the message.

See Also

ErrorLocalizeProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorModel Class

[image]

SharpShooter Reports.Web
ErrorModel Class
Members See Also Send Feedback
Class represents information about type and information of error.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ErrorModel
Visual Basic
Public Class ErrorModel
Visual C++
public ref class ErrorModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorModel

See Also

ErrorModel Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorModel Members

[image] [image]

SharpShooter Reports.Web
ErrorModel Members
ErrorModel Class Constructors Methods Fields See Also Send Feedback

The ErrorModel type exposes the following members.

Constructors

 | Name | Description
Public method | ErrorModel | Initialize new instanse of PerpetuumSoft.Reporting.WebViewer.Client.ErrorModel class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Error | Get or set error information.
Public field | ErrorType | Get or set error type.

See Also

ErrorModel Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorModel Constructor

[image]

SharpShooter Reports.Web
ErrorModel Constructor
ErrorModel Class See Also Send Feedback
Initialize new instanse of PerpetuumSoft.Reporting.WebViewer.Client.ErrorModel class.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ErrorModel(
    ErrorType errorType,
    ErrorBase error
)
Visual Basic
Public Sub New ( _
    errorType As ErrorType, _
    error As ErrorBase _
)
Visual C++
public:
ErrorModel(
    ErrorType errorType,
    ErrorBase^ error
)

Parameters

errorType
Type: PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorType
The error type.
error
Type: PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorBase
The error information.

See Also

ErrorModel Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorModel Fields

[image] [image]

SharpShooter Reports.Web
ErrorModel Fields
ErrorModel Class See Also Send Feedback

The ErrorModel type exposes the following members.

Fields

 | Name | Description
Public field | Error | Get or set error information.
Public field | ErrorType | Get or set error type.

See Also

ErrorModel Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


Error Field

[image]

SharpShooter Reports.Web
ErrorModel..::..Error Field
ErrorModel Class See Also Send Feedback
Get or set error information.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ErrorBase Error
Visual Basic
Public Error As ErrorBase
Visual C++
public:
ErrorBase^ Error

See Also

ErrorModel Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorType Field

[image]

SharpShooter Reports.Web
ErrorModel..::..ErrorType Field
ErrorModel Class See Also Send Feedback
Get or set error type.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ErrorType ErrorType
Visual Basic
Public ErrorType As ErrorType
Visual C++
public:
ErrorType ErrorType

See Also

ErrorModel Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorModel Methods

[image] [image]

SharpShooter Reports.Web
ErrorModel Methods
ErrorModel Class See Also Send Feedback

The ErrorModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ErrorModel Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorProvider Class

[image]

SharpShooter Reports.Web
ErrorProvider Class
Members See Also Send Feedback
Class provides error handling

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ErrorProvider
Visual Basic
Public Class ErrorProvider
Visual C++
public ref class ErrorProvider

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorProvider

See Also

ErrorProvider Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorProvider Members

[image] [image]

SharpShooter Reports.Web
ErrorProvider Members
ErrorProvider Class Constructors Methods Fields See Also Send Feedback

The ErrorProvider type exposes the following members.

Constructors

 | Name | Description
Public method | ErrorProvider | Initializes a new instance of the ErrorProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseClientError | Raise a error which occurred on the client side.
Public method | RaiseCommunicationError | Raise a error which occurred when communicate with the server.
Public method | RaiseServerError | Raise a error which occurred on the server side.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ErrorEvent | Set callback function to handle errors.

See Also

ErrorProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorProvider Constructor

[image]

SharpShooter Reports.Web
ErrorProvider Constructor
ErrorProvider Class See Also Send Feedback
Initializes a new instance of the ErrorProvider class

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ErrorProvider()
Visual Basic
Public Sub New
Visual C++
public:
ErrorProvider()

See Also

ErrorProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorProvider Fields

[image] [image]

SharpShooter Reports.Web
ErrorProvider Fields
ErrorProvider Class See Also Send Feedback

The ErrorProvider type exposes the following members.

Fields

 | Name | Description
Public field | ErrorEvent | Set callback function to handle errors.

See Also

ErrorProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorEvent Field

[image]

SharpShooter Reports.Web
ErrorProvider..::..ErrorEvent Field
ErrorProvider Class See Also Send Feedback
Set callback function to handle errors.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ErrorCallback ErrorEvent
Visual Basic
Public ErrorEvent As ErrorCallback
Visual C++
public:
ErrorCallback^ ErrorEvent

See Also

ErrorProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorProvider Methods

[image] [image]

SharpShooter Reports.Web
ErrorProvider Methods
ErrorProvider Class See Also Send Feedback

The ErrorProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseClientError | Raise a error which occurred on the client side.
Public method | RaiseCommunicationError | Raise a error which occurred when communicate with the server.
Public method | RaiseServerError | Raise a error which occurred on the server side.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ErrorProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


RaiseClientError Method

[image]

SharpShooter Reports.Web
ErrorProvider..::..RaiseClientError Method
ErrorProvider Class See Also Send Feedback
Raise a error which occurred on the client side.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RaiseClientError(
    Exception e
)
Visual Basic
Public Sub RaiseClientError ( _
    e As Exception _
)
Visual C++
public:
void RaiseClientError(
    Exception^ e
)

Parameters

e
Type: System..::..Exception
An exception.

See Also

ErrorProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


RaiseCommunicationError Method

[image]

SharpShooter Reports.Web
ErrorProvider..::..RaiseCommunicationError Method
ErrorProvider Class See Also Send Feedback
Raise a error which occurred when communicate with the server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RaiseCommunicationError(
    jQueryXmlHttpRequest request,
    string textStatus,
    Exception error
)
Visual Basic
Public Sub RaiseCommunicationError ( _
    request As jQueryXmlHttpRequest, _
    textStatus As String, _
    error As Exception _
)
Visual C++
public:
void RaiseCommunicationError(
    jQueryXmlHttpRequest^ request,
    String^ textStatus,
    Exception^ error
)

Parameters

request
Type: jQueryXmlHttpRequest
The request that was invoked.
textStatus
Type: System..::..String
The status of the pageInfoRequest.
error
Type: System..::..Exception
The error or exception if any.

See Also

ErrorProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


RaiseServerError Method

[image]

SharpShooter Reports.Web
ErrorProvider..::..RaiseServerError Method
ErrorProvider Class See Also Send Feedback
Raise a error which occurred on the server side.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RaiseServerError(
    ErrorInfoModel errorInfoModel
)
Visual Basic
Public Sub RaiseServerError ( _
    errorInfoModel As ErrorInfoModel _
)
Visual C++
public:
void RaiseServerError(
    ErrorInfoModel^ errorInfoModel
)

Parameters

errorInfoModel
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..ErrorInfoModel
The error data ([!:PerpetuumSoft.Reporting.WebViewer.Client.ErrorInfoModel] class).

See Also

ErrorProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorType Enumeration

[image]

SharpShooter Reports.Web
ErrorType Enumeration
See Also Send Feedback
Defines types of errors occurred in a application.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ErrorType
Visual Basic
Public Enumeration ErrorType
Visual C++
public enum class ErrorType

Members

Member name | Description
ClientError |
ServerError |
CommunicationError |

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


HyperlinkCallback Delegate

[image]

SharpShooter Reports.Web
HyperlinkCallback Delegate
See Also Send Feedback
The callback function which is invoked when a user clicks a hyperlink in a report.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void HyperlinkCallback(
    string hyperlink
)
Visual Basic
Public Delegate Sub HyperlinkCallback ( _
    hyperlink As String _
)
Visual C++
public delegate void HyperlinkCallback(
    String^ hyperlink
)

Parameters

hyperlink
Type: System..::..String
Hyperlink Url.

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


IReportService Interface

[image]

SharpShooter Reports.Web
IReportService Interface
Members See Also Send Feedback
Exposes a method for getting report.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IReportService
Visual Basic
Public Interface IReportService
Visual C++
public interface class IReportService

See Also

IReportService Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


IReportService Members

[image] [image]

SharpShooter Reports.Web
IReportService Members
IReportService Interface Methods See Also Send Feedback

The IReportService type exposes the following members.

Methods

 | Name | Description
Public method | LoadDocumentInfo | Returns the report metadata from server.
Public method | LoadDocumentMapInfo | Returns a documents bookmark tree from server.
Public method | LoadDocumentMapInfoFull | Generates the report and returns a documents bookmark tree from server.
Public method | LoadPageInfo | Returns page metadata by report identificator and page number.
Public method | LoadPageInfoFull | Generates the report and returns page metadata by report identificator and page number.
Public method | LoadReportParameters | Returns a parameters list from report.
Public method | LoadThumbnailsInfo | Returns thumbnails links collection.
Public method | LoadThumbnailsInfoFull | Generates the report and returns thumbnails links collection.

See Also

IReportService Interface
PerpetuumSoft.Reporting.WebViewer.Client Namespace


IReportService Methods

[image] [image]

SharpShooter Reports.Web
IReportService Methods
IReportService Interface See Also Send Feedback

The IReportService type exposes the following members.

Methods

 | Name | Description
Public method | LoadDocumentInfo | Returns the report metadata from server.
Public method | LoadDocumentMapInfo | Returns a documents bookmark tree from server.
Public method | LoadDocumentMapInfoFull | Generates the report and returns a documents bookmark tree from server.
Public method | LoadPageInfo | Returns page metadata by report identificator and page number.
Public method | LoadPageInfoFull | Generates the report and returns page metadata by report identificator and page number.
Public method | LoadReportParameters | Returns a parameters list from report.
Public method | LoadThumbnailsInfo | Returns thumbnails links collection.
Public method | LoadThumbnailsInfoFull | Generates the report and returns thumbnails links collection.

See Also

IReportService Interface
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadDocumentInfo Method

[image]

SharpShooter Reports.Web
IReportService..::..LoadDocumentInfo Method
IReportService Interface See Also Send Feedback
Returns the report metadata from server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void LoadDocumentInfo(
    LoadDocumentInfoRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Sub LoadDocumentInfo ( _
    request As LoadDocumentInfoRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
void LoadDocumentInfo(
    LoadDocumentInfoRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
)

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentInfoRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.IReportService.LoadDocumentInfo(PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentInfoRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

See Also

IReportService Interface
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadDocumentMapInfo Method

[image]

SharpShooter Reports.Web
IReportService..::..LoadDocumentMapInfo Method
IReportService Interface See Also Send Feedback
Returns a documents bookmark tree from server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void LoadDocumentMapInfo(
    LoadDocumentMapInfoRequest request,
    AjaxRequestCallback successCallBack,
    AjaxErrorCallback errorCallback
)
Visual Basic
Sub LoadDocumentMapInfo ( _
    request As LoadDocumentMapInfoRequest, _
    successCallBack As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
void LoadDocumentMapInfo(
    LoadDocumentMapInfoRequest^ request,
    AjaxRequestCallback^ successCallBack,
    AjaxErrorCallback^ errorCallback
)

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentMapInfoRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.IReportService.LoadDocumentMapInfo(PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentMapInfoRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallBack
Type: AjaxRequestCallback

[Missing <param name="successCallBack"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.IReportService.LoadDocumentMapInfo(PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentMapInfoRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

See Also

IReportService Interface
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadDocumentMapInfoFull Method

[image]

SharpShooter Reports.Web
IReportService..::..LoadDocumentMapInfoFull Method
IReportService Interface See Also Send Feedback
Generates the report and returns a documents bookmark tree from server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void LoadDocumentMapInfoFull(
    LoadDocumentMapInfoFullRequest request,
    AjaxRequestCallback successCallBack,
    AjaxErrorCallback errorCallback
)
Visual Basic
Sub LoadDocumentMapInfoFull ( _
    request As LoadDocumentMapInfoFullRequest, _
    successCallBack As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
void LoadDocumentMapInfoFull(
    LoadDocumentMapInfoFullRequest^ request,
    AjaxRequestCallback^ successCallBack,
    AjaxErrorCallback^ errorCallback
)

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentMapInfoFullRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.IReportService.LoadDocumentMapInfoFull(PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentMapInfoFullRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallBack
Type: AjaxRequestCallback

[Missing <param name="successCallBack"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.IReportService.LoadDocumentMapInfoFull(PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentMapInfoFullRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

See Also

IReportService Interface
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadPageInfo Method

[image]

SharpShooter Reports.Web
IReportService..::..LoadPageInfo Method
IReportService Interface See Also Send Feedback
Returns page metadata by report identificator and page number.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void LoadPageInfo(
    LoadPageInfoRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Sub LoadPageInfo ( _
    request As LoadPageInfoRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
void LoadPageInfo(
    LoadPageInfoRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
)

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadPageInfoRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.IReportService.LoadPageInfo(PerpetuumSoft.Reporting.WebViewer.Model.LoadPageInfoRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

See Also

IReportService Interface
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadPageInfoFull Method

[image]

SharpShooter Reports.Web
IReportService..::..LoadPageInfoFull Method
IReportService Interface See Also Send Feedback
Generates the report and returns page metadata by report identificator and page number.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void LoadPageInfoFull(
    LoadPageInfoFullRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Sub LoadPageInfoFull ( _
    request As LoadPageInfoFullRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
void LoadPageInfoFull(
    LoadPageInfoFullRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
)

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadPageInfoFullRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.IReportService.LoadPageInfoFull(PerpetuumSoft.Reporting.WebViewer.Model.LoadPageInfoFullRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

See Also

IReportService Interface
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadReportParameters Method

[image]

SharpShooter Reports.Web
IReportService..::..LoadReportParameters Method
IReportService Interface See Also Send Feedback
Returns a parameters list from report.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void LoadReportParameters(
    LoadReportParametersRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Sub LoadReportParameters ( _
    request As LoadReportParametersRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
void LoadReportParameters(
    LoadReportParametersRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
)

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadReportParametersRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.IReportService.LoadReportParameters(PerpetuumSoft.Reporting.WebViewer.Model.LoadReportParametersRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

See Also

IReportService Interface
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadThumbnailsInfo Method

[image]

SharpShooter Reports.Web
IReportService..::..LoadThumbnailsInfo Method
IReportService Interface See Also Send Feedback
Returns thumbnails links collection.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void LoadThumbnailsInfo(
    LoadThumbnailsInfoRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Sub LoadThumbnailsInfo ( _
    request As LoadThumbnailsInfoRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
void LoadThumbnailsInfo(
    LoadThumbnailsInfoRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
)

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadThumbnailsInfoRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.IReportService.LoadThumbnailsInfo(PerpetuumSoft.Reporting.WebViewer.Model.LoadThumbnailsInfoRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

See Also

IReportService Interface
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadThumbnailsInfoFull Method

[image]

SharpShooter Reports.Web
IReportService..::..LoadThumbnailsInfoFull Method
IReportService Interface See Also Send Feedback
Generates the report and returns thumbnails links collection.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void LoadThumbnailsInfoFull(
    LoadThumbnailsInfoFullRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Sub LoadThumbnailsInfoFull ( _
    request As LoadThumbnailsInfoFullRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
void LoadThumbnailsInfoFull(
    LoadThumbnailsInfoFullRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
)

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadThumbnailsInfoFullRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.IReportService.LoadThumbnailsInfoFull(PerpetuumSoft.Reporting.WebViewer.Model.LoadThumbnailsInfoFullRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

See Also

IReportService Interface
PerpetuumSoft.Reporting.WebViewer.Client Namespace


JsonDataConverter Class

[image]

SharpShooter Reports.Web
JsonDataConverter Class
Members See Also Send Feedback
Processes an object which was received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class JsonDataConverter
Visual Basic
Public NotInheritable Class JsonDataConverter
Visual C++
public ref class JsonDataConverter abstract sealed

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..JsonDataConverter

See Also

JsonDataConverter Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


JsonDataConverter Members

[image] [image]

SharpShooter Reports.Web
JsonDataConverter Members
JsonDataConverter Class Methods See Also Send Feedback

The JsonDataConverter type exposes the following members.

Methods

Name | Description
GetData | Processes an object which was received from a server. Deletes additional information and returns an object identical to the object which was received from a server.

See Also

JsonDataConverter Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


JsonDataConverter Methods

[image] [image]

SharpShooter Reports.Web
JsonDataConverter Methods
JsonDataConverter Class See Also Send Feedback

The JsonDataConverter type exposes the following members.

Methods

Name | Description
GetData | Processes an object which was received from a server. Deletes additional information and returns an object identical to the object which was received from a server.

See Also

JsonDataConverter Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetData Method

[image]

SharpShooter Reports.Web
JsonDataConverter..::..GetData Method
JsonDataConverter Class See Also Send Feedback
Processes an object which was received from a server. Deletes additional information and returns an object identical to the object which was received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Object GetData(
    Object dataObject
)
Visual Basic
Public Shared Function GetData ( _
    dataObject As Object _
) As Object
Visual C++
public:
static Object^ GetData(
    Object^ dataObject
)

Parameters

dataObject
Type: System..::..Object
A data object which was received from a server.

Return Value

Processed object.

See Also

JsonDataConverter Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


PageCallback Delegate

[image]

SharpShooter Reports.Web
PageCallback Delegate
See Also Send Feedback
The callback function which is used to inform a user about change of a page number.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void PageCallback(
    int pageNumber
)
Visual Basic
Public Delegate Sub PageCallback ( _
    pageNumber As Integer _
)
Visual C++
public delegate void PageCallback(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
Page number.

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


PageInfoLoadedCallback Delegate

[image]

SharpShooter Reports.Web
PageInfoLoadedCallback Delegate
See Also Send Feedback
The callback function which is invoked when data about a page were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void PageInfoLoadedCallback(
    int pageNumber,
    string pageContent
)
Visual Basic
Public Delegate Sub PageInfoLoadedCallback ( _
    pageNumber As Integer, _
    pageContent As String _
)
Visual C++
public delegate void PageInfoLoadedCallback(
    int pageNumber,
    String^ pageContent
)

Parameters

pageNumber
Type: System..::..Int32
Page number.
pageContent
Type: System..::..String
Page content.

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


ReportParametersLoadedCallback Delegate

[image]

SharpShooter Reports.Web
ReportParametersLoadedCallback Delegate
See Also Send Feedback
The callback function which is invoked when report parameters were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void ReportParametersLoadedCallback(
    List<ParameterModel> parameters
)
Visual Basic
Public Delegate Sub ReportParametersLoadedCallback ( _
    parameters As List(Of ParameterModel) _
)
Visual C++
public delegate void ReportParametersLoadedCallback(
    List<ParameterModel^>^ parameters
)

Parameters

parameters
Type: System.Collections.Generic..::..List <(Of <(<' ParameterModel >)>)>
Report parameters.

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


ReportViewer Class

[image]

SharpShooter Reports.Web
ReportViewer Class
Members See Also Send Feedback
An object for a report representation, navigation and export.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ReportViewer
Visual Basic
Public Class ReportViewer
Visual C++
public ref class ReportViewer

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..ReportViewer

See Also

ReportViewer Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ReportViewer Members

[image] [image]

SharpShooter Reports.Web
ReportViewer Members
ReportViewer Class Constructors Methods Fields See Also Send Feedback

The ReportViewer type exposes the following members.

Constructors

 | Name | Description
Public method | ReportViewer | Creates the PerpetuumSoft.Reporting.WebViewer.Client.ReportViewer class instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportTo | Performs query for document export into specified by a user format. Opens a browser window and redirects a stream from server to this window.
Public method | ExportToExcel | Performs query for document export into the Excel format. Opens a browser window and redirects a stream from server to this window.
Public method | ExportToHtml | Performs query for document export into the HTML format. Opens a browser window and redirects a stream from server to this window.
Public method | ExportToPdf | Performs query for document export into the Pdf format. Opens a browser window and redirects a stream from server to this window.
Public method | ExportToRtf | Performs query for document export into the RTF format. Opens a browser window and redirects a stream from server to this window.
Public method | ExportToXps | Performs query for document export into the Xps format. Opens a browser window and redirects a stream from server to this window.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FirstPage | Navigates to the first page.
Public method | GetCurrentPage | Gets a number of a current page.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServiceUrl | Gets a service Url.
Public method | GetThumbnailSize | Gets a thumbnail size.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GoToBookmark | Navigates to the element with "bookmark" name.
Public method | IsFirstPage | Checks if the current page is the first one.
Public method | IsLastPage | Checks if the current page is the last one.
Public method | LastPage | Navigates to the last page.
Public method | LoadDocumentMapInfo | Performs query for loading of bookmarks tree.
Public method | LoadReportParameters | Performs query to server for parameters loading.
Public method | LoadThumbnails | Performs query for data about pages thumbnails from a server.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextPage | Navigates to the next page.
Public method | PrevPage | Navigates to the previous page.
Public method | Print | Performs query for receiving of a document from server in the Html format for printing.
Public method | RenderDocument | Performs query to server for a document rendering and loading of document data onto the client.
Public method | SetCurrentPage | Sets a current page with number equal to "pageNumber" and displays the page.
Public method | SetDocumentLoadingElement | Sets web page element which will displayed during a document loading.
Public method | SetDocumentMapControl | Sets web page element which will be used for display of bookmarks tree.
Public method | SetHyperlinkClickHandler | Sets a handler for hyperlink click event.
Public method | SetInvisibleThumbnailCacheSize | Sets the number of thumbnails, which will be loaded before and after the visible thumbnails.
Public method | SetPageCacheSize | Sets size of pages cache.
Public method | SetPageLoadingElement | Sets web page element which will displayed during a document page loading.
Public method | SetPageView | Sets view model for reports pages display.
Public method | SetServiceUrl | Sets a service Url.
Public method | SetThumbnailsControl | Sets web page element which will be used for display of pages thumbnails.
Public method | SetThumbnailSize | Sets a thumbnail size.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | CurrentPageChangedEvent | Occurs when current page was changed.
Public field | DocumentInfoLoadedEvent | Occurs when data about a document were received form a server.
Public field | DocumentMapElementClickEvent | Occurs when the element in bookmarks tree was clicked.
Public field | DocumentMapLoadedEvent | Occurs when data about bookmarks tree were received from a server.
Public field | ErrorEvent | Event raise when an error occurs.
Public field | PageInfoLoadedEvent | Occurs when data about a page were received from a server.
Public field | Parameters | Gets or sets a parameters list.
Public field | ReportName | Gets or sets a report name.
Public field | ReportParametersLoadedEvent | Occurs when report parameters were received from a server.
Public field | ThumbnailClickEvent | Occurs when a thumbnail was clicked.
Public field | ThumbnailsInfoLoadedEvent | Occurs when data about thumbnails were received from a server.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ReportViewer Constructor

[image]

SharpShooter Reports.Web
ReportViewer Constructor
ReportViewer Class See Also Send Feedback
Creates the PerpetuumSoft.Reporting.WebViewer.Client.ReportViewer class instance.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportViewer(
    string selector
)
Visual Basic
Public Sub New ( _
    selector As String _
)
Visual C++
public:
ReportViewer(
    String^ selector
)

Parameters

selector
Type: System..::..String
A selector used to get an element which will be used for a report display.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ReportViewer Fields

[image] [image]

SharpShooter Reports.Web
ReportViewer Fields
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Fields

 | Name | Description
Public field | CurrentPageChangedEvent | Occurs when current page was changed.
Public field | DocumentInfoLoadedEvent | Occurs when data about a document were received form a server.
Public field | DocumentMapElementClickEvent | Occurs when the element in bookmarks tree was clicked.
Public field | DocumentMapLoadedEvent | Occurs when data about bookmarks tree were received from a server.
Public field | ErrorEvent | Event raise when an error occurs.
Public field | PageInfoLoadedEvent | Occurs when data about a page were received from a server.
Public field | Parameters | Gets or sets a parameters list.
Public field | ReportName | Gets or sets a report name.
Public field | ReportParametersLoadedEvent | Occurs when report parameters were received from a server.
Public field | ThumbnailClickEvent | Occurs when a thumbnail was clicked.
Public field | ThumbnailsInfoLoadedEvent | Occurs when data about thumbnails were received from a server.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


CurrentPageChangedEvent Field

[image]

SharpShooter Reports.Web
ReportViewer..::..CurrentPageChangedEvent Field
ReportViewer Class See Also Send Feedback
Occurs when current page was changed.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageCallback CurrentPageChangedEvent
Visual Basic
Public CurrentPageChangedEvent As PageCallback
Visual C++
public:
PageCallback^ CurrentPageChangedEvent

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentInfoLoadedEvent Field

[image]

SharpShooter Reports.Web
ReportViewer..::..DocumentInfoLoadedEvent Field
ReportViewer Class See Also Send Feedback
Occurs when data about a document were received form a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentInfoLoadedCallback DocumentInfoLoadedEvent
Visual Basic
Public DocumentInfoLoadedEvent As DocumentInfoLoadedCallback
Visual C++
public:
DocumentInfoLoadedCallback^ DocumentInfoLoadedEvent

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentMapElementClickEvent Field

[image]

SharpShooter Reports.Web
ReportViewer..::..DocumentMapElementClickEvent Field
ReportViewer Class See Also Send Feedback
Occurs when the element in bookmarks tree was clicked.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentMapElementClickCallback DocumentMapElementClickEvent
Visual Basic
Public DocumentMapElementClickEvent As DocumentMapElementClickCallback
Visual C++
public:
DocumentMapElementClickCallback^ DocumentMapElementClickEvent

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


DocumentMapLoadedEvent Field

[image]

SharpShooter Reports.Web
ReportViewer..::..DocumentMapLoadedEvent Field
ReportViewer Class See Also Send Feedback
Occurs when data about bookmarks tree were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentMapInfoCallback DocumentMapLoadedEvent
Visual Basic
Public DocumentMapLoadedEvent As DocumentMapInfoCallback
Visual C++
public:
DocumentMapInfoCallback^ DocumentMapLoadedEvent

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ErrorEvent Field

[image]

SharpShooter Reports.Web
ReportViewer..::..ErrorEvent Field
ReportViewer Class See Also Send Feedback
Event raise when an error occurs.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ErrorCallback ErrorEvent
Visual Basic
Public ErrorEvent As ErrorCallback
Visual C++
public:
ErrorCallback^ ErrorEvent

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


PageInfoLoadedEvent Field

[image]

SharpShooter Reports.Web
ReportViewer..::..PageInfoLoadedEvent Field
ReportViewer Class See Also Send Feedback
Occurs when data about a page were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageInfoLoadedCallback PageInfoLoadedEvent
Visual Basic
Public PageInfoLoadedEvent As PageInfoLoadedCallback
Visual C++
public:
PageInfoLoadedCallback^ PageInfoLoadedEvent

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


Parameters Field

[image]

SharpShooter Reports.Web
ReportViewer..::..Parameters Field
ReportViewer Class See Also Send Feedback
Gets or sets a parameters list.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<ParameterModel> Parameters
Visual Basic
Public Parameters As List(Of ParameterModel)
Visual C++
public:
List<ParameterModel^>^ Parameters

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ReportName Field

[image]

SharpShooter Reports.Web
ReportViewer..::..ReportName Field
ReportViewer Class See Also Send Feedback
Gets or sets a report name.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ReportName
Visual Basic
Public ReportName As String
Visual C++
public:
String^ ReportName

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ReportParametersLoadedEvent Field

[image]

SharpShooter Reports.Web
ReportViewer..::..ReportParametersLoadedEvent Field
ReportViewer Class See Also Send Feedback
Occurs when report parameters were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportParametersLoadedCallback ReportParametersLoadedEvent
Visual Basic
Public ReportParametersLoadedEvent As ReportParametersLoadedCallback
Visual C++
public:
ReportParametersLoadedCallback^ ReportParametersLoadedEvent

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ThumbnailClickEvent Field

[image]

SharpShooter Reports.Web
ReportViewer..::..ThumbnailClickEvent Field
ReportViewer Class See Also Send Feedback
Occurs when a thumbnail was clicked.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageCallback ThumbnailClickEvent
Visual Basic
Public ThumbnailClickEvent As PageCallback
Visual C++
public:
PageCallback^ ThumbnailClickEvent

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ThumbnailsInfoLoadedEvent Field

[image]

SharpShooter Reports.Web
ReportViewer..::..ThumbnailsInfoLoadedEvent Field
ReportViewer Class See Also Send Feedback
Occurs when data about thumbnails were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThumbnailsInfoLoadedCallback ThumbnailsInfoLoadedEvent
Visual Basic
Public ThumbnailsInfoLoadedEvent As ThumbnailsInfoLoadedCallback
Visual C++
public:
ThumbnailsInfoLoadedCallback^ ThumbnailsInfoLoadedEvent

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ReportViewer Methods

[image] [image]

SharpShooter Reports.Web
ReportViewer Methods
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportTo | Performs query for document export into specified by a user format. Opens a browser window and redirects a stream from server to this window.
Public method | ExportToExcel | Performs query for document export into the Excel format. Opens a browser window and redirects a stream from server to this window.
Public method | ExportToHtml | Performs query for document export into the HTML format. Opens a browser window and redirects a stream from server to this window.
Public method | ExportToPdf | Performs query for document export into the Pdf format. Opens a browser window and redirects a stream from server to this window.
Public method | ExportToRtf | Performs query for document export into the RTF format. Opens a browser window and redirects a stream from server to this window.
Public method | ExportToXps | Performs query for document export into the Xps format. Opens a browser window and redirects a stream from server to this window.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FirstPage | Navigates to the first page.
Public method | GetCurrentPage | Gets a number of a current page.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServiceUrl | Gets a service Url.
Public method | GetThumbnailSize | Gets a thumbnail size.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GoToBookmark | Navigates to the element with "bookmark" name.
Public method | IsFirstPage | Checks if the current page is the first one.
Public method | IsLastPage | Checks if the current page is the last one.
Public method | LastPage | Navigates to the last page.
Public method | LoadDocumentMapInfo | Performs query for loading of bookmarks tree.
Public method | LoadReportParameters | Performs query to server for parameters loading.
Public method | LoadThumbnails | Performs query for data about pages thumbnails from a server.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextPage | Navigates to the next page.
Public method | PrevPage | Navigates to the previous page.
Public method | Print | Performs query for receiving of a document from server in the Html format for printing.
Public method | RenderDocument | Performs query to server for a document rendering and loading of document data onto the client.
Public method | SetCurrentPage | Sets a current page with number equal to "pageNumber" and displays the page.
Public method | SetDocumentLoadingElement | Sets web page element which will displayed during a document loading.
Public method | SetDocumentMapControl | Sets web page element which will be used for display of bookmarks tree.
Public method | SetHyperlinkClickHandler | Sets a handler for hyperlink click event.
Public method | SetInvisibleThumbnailCacheSize | Sets the number of thumbnails, which will be loaded before and after the visible thumbnails.
Public method | SetPageCacheSize | Sets size of pages cache.
Public method | SetPageLoadingElement | Sets web page element which will displayed during a document page loading.
Public method | SetPageView | Sets view model for reports pages display.
Public method | SetServiceUrl | Sets a service Url.
Public method | SetThumbnailsControl | Sets web page element which will be used for display of pages thumbnails.
Public method | SetThumbnailSize | Sets a thumbnail size.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ExportTo Method

[image]

SharpShooter Reports.Web
ReportViewer..::..ExportTo Method
ReportViewer Class See Also Send Feedback
Performs query for document export into specified by a user format. Opens a browser window and redirects a stream from server to this window.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ExportTo(
    string format
)
Visual Basic
Public Sub ExportTo ( _
    format As String _
)
Visual C++
public:
void ExportTo(
    String^ format
)

Parameters

format
Type: System..::..String
A format which export should be performed into.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ExportToExcel Method

[image]

SharpShooter Reports.Web
ReportViewer..::..ExportToExcel Method
ReportViewer Class See Also Send Feedback
Performs query for document export into the Excel format. Opens a browser window and redirects a stream from server to this window.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ExportToExcel()
Visual Basic
Public Sub ExportToExcel
Visual C++
public:
void ExportToExcel()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ExportToHtml Method

[image]

SharpShooter Reports.Web
ReportViewer..::..ExportToHtml Method
ReportViewer Class See Also Send Feedback
Performs query for document export into the HTML format. Opens a browser window and redirects a stream from server to this window.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ExportToHtml()
Visual Basic
Public Sub ExportToHtml
Visual C++
public:
void ExportToHtml()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ExportToPdf Method

[image]

SharpShooter Reports.Web
ReportViewer..::..ExportToPdf Method
ReportViewer Class See Also Send Feedback
Performs query for document export into the Pdf format. Opens a browser window and redirects a stream from server to this window.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ExportToPdf()
Visual Basic
Public Sub ExportToPdf
Visual C++
public:
void ExportToPdf()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ExportToRtf Method

[image]

SharpShooter Reports.Web
ReportViewer..::..ExportToRtf Method
ReportViewer Class See Also Send Feedback
Performs query for document export into the RTF format. Opens a browser window and redirects a stream from server to this window.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ExportToRtf()
Visual Basic
Public Sub ExportToRtf
Visual C++
public:
void ExportToRtf()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ExportToXps Method

[image]

SharpShooter Reports.Web
ReportViewer..::..ExportToXps Method
ReportViewer Class See Also Send Feedback
Performs query for document export into the Xps format. Opens a browser window and redirects a stream from server to this window.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ExportToXps()
Visual Basic
Public Sub ExportToXps
Visual C++
public:
void ExportToXps()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


FirstPage Method

[image]

SharpShooter Reports.Web
ReportViewer..::..FirstPage Method
ReportViewer Class See Also Send Feedback
Navigates to the first page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void FirstPage()
Visual Basic
Public Sub FirstPage
Visual C++
public:
void FirstPage()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetCurrentPage Method

[image]

SharpShooter Reports.Web
ReportViewer..::..GetCurrentPage Method
ReportViewer Class See Also Send Feedback
Gets a number of a current page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int GetCurrentPage()
Visual Basic
Public Function GetCurrentPage As Integer
Visual C++
public:
int GetCurrentPage()

Return Value

Page number.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetServiceUrl Method

[image]

SharpShooter Reports.Web
ReportViewer..::..GetServiceUrl Method
ReportViewer Class See Also Send Feedback
Gets a service Url.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetServiceUrl()
Visual Basic
Public Function GetServiceUrl As String
Visual C++
public:
String^ GetServiceUrl()

Return Value

[Missing <returns> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ReportViewer.GetServiceUrl"]

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetThumbnailSize Method

[image]

SharpShooter Reports.Web
ReportViewer..::..GetThumbnailSize Method
ReportViewer Class See Also Send Feedback
Gets a thumbnail size.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThumbnailSizeModel GetThumbnailSize()
Visual Basic
Public Function GetThumbnailSize As ThumbnailSizeModel
Visual C++
public:
ThumbnailSizeModel^ GetThumbnailSize()

Return Value

ThumbnailSizeModel class.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GoToBookmark Method

[image]

SharpShooter Reports.Web
ReportViewer..::..GoToBookmark Method
ReportViewer Class See Also Send Feedback
Navigates to the element with "bookmark" name.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void GoToBookmark(
    string bookmark
)
Visual Basic
Public Sub GoToBookmark ( _
    bookmark As String _
)
Visual C++
public:
void GoToBookmark(
    String^ bookmark
)

Parameters

bookmark
Type: System..::..String
Bookmark name.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


IsFirstPage Method

[image]

SharpShooter Reports.Web
ReportViewer..::..IsFirstPage Method
ReportViewer Class See Also Send Feedback
Checks if the current page is the first one.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsFirstPage()
Visual Basic
Public Function IsFirstPage As Boolean
Visual C++
public:
bool IsFirstPage()

Return Value

True - if the current page is the first one. False - if the current page is not the first one.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


IsLastPage Method

[image]

SharpShooter Reports.Web
ReportViewer..::..IsLastPage Method
ReportViewer Class See Also Send Feedback
Checks if the current page is the last one.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsLastPage()
Visual Basic
Public Function IsLastPage As Boolean
Visual C++
public:
bool IsLastPage()

Return Value

True - if the current page is the last one. False - if the current page is not the last one.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LastPage Method

[image]

SharpShooter Reports.Web
ReportViewer..::..LastPage Method
ReportViewer Class See Also Send Feedback
Navigates to the last page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LastPage()
Visual Basic
Public Sub LastPage
Visual C++
public:
void LastPage()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadDocumentMapInfo Method

[image]

SharpShooter Reports.Web
ReportViewer..::..LoadDocumentMapInfo Method
ReportViewer Class See Also Send Feedback
Performs query for loading of bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadDocumentMapInfo()
Visual Basic
Public Sub LoadDocumentMapInfo
Visual C++
public:
void LoadDocumentMapInfo()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadReportParameters Method

[image]

SharpShooter Reports.Web
ReportViewer..::..LoadReportParameters Method
ReportViewer Class See Also Send Feedback
Performs query to server for parameters loading.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadReportParameters()
Visual Basic
Public Sub LoadReportParameters
Visual C++
public:
void LoadReportParameters()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadThumbnails Method

[image]

SharpShooter Reports.Web
ReportViewer..::..LoadThumbnails Method
ReportViewer Class See Also Send Feedback
Performs query for data about pages thumbnails from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadThumbnails()
Visual Basic
Public Sub LoadThumbnails
Visual C++
public:
void LoadThumbnails()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


NextPage Method

[image]

SharpShooter Reports.Web
ReportViewer..::..NextPage Method
ReportViewer Class See Also Send Feedback
Navigates to the next page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void NextPage()
Visual Basic
Public Sub NextPage
Visual C++
public:
void NextPage()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


PrevPage Method

[image]

SharpShooter Reports.Web
ReportViewer..::..PrevPage Method
ReportViewer Class See Also Send Feedback
Navigates to the previous page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void PrevPage()
Visual Basic
Public Sub PrevPage
Visual C++
public:
void PrevPage()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


Print Method

[image]

SharpShooter Reports.Web
ReportViewer..::..Print Method
ReportViewer Class See Also Send Feedback
Performs query for receiving of a document from server in the Html format for printing.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Print()
Visual Basic
Public Sub Print
Visual C++
public:
void Print()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


RenderDocument Method

[image]

SharpShooter Reports.Web
ReportViewer..::..RenderDocument Method
ReportViewer Class See Also Send Feedback
Performs query to server for a document rendering and loading of document data onto the client.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RenderDocument()
Visual Basic
Public Sub RenderDocument
Visual C++
public:
void RenderDocument()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetCurrentPage Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetCurrentPage Method
ReportViewer Class See Also Send Feedback
Sets a current page with number equal to "pageNumber" and displays the page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetCurrentPage(
    int pageNumber
)
Visual Basic
Public Sub SetCurrentPage ( _
    pageNumber As Integer _
)
Visual C++
public:
void SetCurrentPage(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
Current page number.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetDocumentLoadingElement Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetDocumentLoadingElement Method
ReportViewer Class See Also Send Feedback
Sets web page element which will displayed during a document loading.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDocumentLoadingElement(
    Element indicatorElement
)
Visual Basic
Public Sub SetDocumentLoadingElement ( _
    indicatorElement As Element _
)
Visual C++
public:
void SetDocumentLoadingElement(
    Element^ indicatorElement
)

Parameters

indicatorElement
Type: Element
An element which displays a document loading.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetDocumentMapControl Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetDocumentMapControl Method
ReportViewer Class See Also Send Feedback
Sets web page element which will be used for display of bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDocumentMapControl(
    string selector
)
Visual Basic
Public Sub SetDocumentMapControl ( _
    selector As String _
)
Visual C++
public:
void SetDocumentMapControl(
    String^ selector
)

Parameters

selector
Type: System..::..String
An element which will be used for output of bookmarks tree.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetHyperlinkClickHandler Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetHyperlinkClickHandler Method
ReportViewer Class See Also Send Feedback
Sets a handler for hyperlink click event.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetHyperlinkClickHandler(
    HyperlinkCallback hyperlinkCallback
)
Visual Basic
Public Sub SetHyperlinkClickHandler ( _
    hyperlinkCallback As HyperlinkCallback _
)
Visual C++
public:
void SetHyperlinkClickHandler(
    HyperlinkCallback^ hyperlinkCallback
)

Parameters

hyperlinkCallback
Type: PerpetuumSoft.Reporting.WebViewer.Client..::..HyperlinkCallback
Hyperlink click event handler.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetInvisibleThumbnailCacheSize Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetInvisibleThumbnailCacheSize Method
ReportViewer Class See Also Send Feedback
Sets the number of thumbnails, which will be loaded before and after the visible thumbnails.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetInvisibleThumbnailCacheSize(
    int invisibleCacheSize
)
Visual Basic
Public Sub SetInvisibleThumbnailCacheSize ( _
    invisibleCacheSize As Integer _
)
Visual C++
public:
void SetInvisibleThumbnailCacheSize(
    int invisibleCacheSize
)

Parameters

invisibleCacheSize
Type: System..::..Int32
Number of cached thumbnail.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetPageCacheSize Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetPageCacheSize Method
ReportViewer Class See Also Send Feedback
Sets size of pages cache.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetPageCacheSize(
    int pageCountInCache
)
Visual Basic
Public Sub SetPageCacheSize ( _
    pageCountInCache As Integer _
)
Visual C++
public:
void SetPageCacheSize(
    int pageCountInCache
)

Parameters

pageCountInCache
Type: System..::..Int32
A number of pages which will be stored in cache.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetPageLoadingElement Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetPageLoadingElement Method
ReportViewer Class See Also Send Feedback
Sets web page element which will displayed during a document page loading.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetPageLoadingElement(
    Element indicatorElement
)
Visual Basic
Public Sub SetPageLoadingElement ( _
    indicatorElement As Element _
)
Visual C++
public:
void SetPageLoadingElement(
    Element^ indicatorElement
)

Parameters

indicatorElement
Type: Element
An element which displays a page content loading.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetPageView Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetPageView Method
ReportViewer Class See Also Send Feedback
Sets view model for reports pages display.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetPageView(
    PageViewBase viewModel
)
Visual Basic
Public Sub SetPageView ( _
    viewModel As PageViewBase _
)
Visual C++
public:
void SetPageView(
    PageViewBase^ viewModel
)

Parameters

viewModel
Type: PerpetuumSoft.Reporting.WebViewer.Client.View..::..PageViewBase
Pages view model.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetServiceUrl Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetServiceUrl Method
ReportViewer Class See Also Send Feedback
Sets a service Url.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetServiceUrl(
    string serviceUrl
)
Visual Basic
Public Sub SetServiceUrl ( _
    serviceUrl As String _
)
Visual C++
public:
void SetServiceUrl(
    String^ serviceUrl
)

Parameters

serviceUrl
Type: System..::..String

[Missing <param name="serviceUrl"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ReportViewer.SetServiceUrl(System.String)"]

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetThumbnailsControl Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetThumbnailsControl Method
ReportViewer Class See Also Send Feedback
Sets web page element which will be used for display of pages thumbnails.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetThumbnailsControl(
    string selector
)
Visual Basic
Public Sub SetThumbnailsControl ( _
    selector As String _
)
Visual C++
public:
void SetThumbnailsControl(
    String^ selector
)

Parameters

selector
Type: System..::..String
An element which will be used for output of pages thumbnails.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetThumbnailSize Method

[image]

SharpShooter Reports.Web
ReportViewer..::..SetThumbnailSize Method
ReportViewer Class See Also Send Feedback
Sets a thumbnail size.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetThumbnailSize(
    int width,
    int height
)
Visual Basic
Public Sub SetThumbnailSize ( _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
void SetThumbnailSize(
    int width,
    int height
)

Parameters

width
Type: System..::..Int32
The horizontal component of this PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailSizeModel class.
height
Type: System..::..Int32
the vertical component of this PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailSizeModel class.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServerError Class

[image]

SharpShooter Reports.Web
ServerError Class
Members See Also Send Feedback
Class represents information about the error occurred on the server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ServerError : ErrorBase
Visual Basic
Public Class ServerError _
    Inherits ErrorBase
Visual C++
public ref class ServerError : public ErrorBase

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorBase
PerpetuumSoft.Reporting.WebViewer.Client..::..ServerError

See Also

ServerError Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServerError Members

[image] [image]

SharpShooter Reports.Web
ServerError Members
ServerError Class Constructors Methods Fields See Also Send Feedback

The ServerError type exposes the following members.

Constructors

 | Name | Description
Public method | ServerError | Initialaze new instanse of PerpetuumSoft.Reporting.WebViewer.Client.ServerError class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformation | Get more error information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Message | Get or set error message. (Inherited from ErrorBase.)

See Also

ServerError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServerError Constructor

[image]

SharpShooter Reports.Web
ServerError Constructor
ServerError Class See Also Send Feedback
Initialaze new instanse of PerpetuumSoft.Reporting.WebViewer.Client.ServerError class.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ServerError(
    ErrorInfoModel error
)
Visual Basic
Public Sub New ( _
    error As ErrorInfoModel _
)
Visual C++
public:
ServerError(
    ErrorInfoModel^ error
)

Parameters

error
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..ErrorInfoModel
The server error.

See Also

ServerError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServerError Fields

[image] [image]

SharpShooter Reports.Web
ServerError Fields
ServerError Class See Also Send Feedback

The ServerError type exposes the following members.

Fields

 | Name | Description
Public field | Message | Get or set error message. (Inherited from ErrorBase.)

See Also

ServerError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServerError Methods

[image] [image]

SharpShooter Reports.Web
ServerError Methods
ServerError Class See Also Send Feedback

The ServerError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformation | Get more error information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServerError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


GetInformation Method

[image]

SharpShooter Reports.Web
ServerError..::..GetInformation Method
ServerError Class See Also Send Feedback
Get more error information.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetInformation()
Visual Basic
Public Function GetInformation As String
Visual C++
public:
String^ GetInformation()

Return Value

The error information.

See Also

ServerError Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServiceProvider Class

[image]

SharpShooter Reports.Web
ServiceProvider Class
Members See Also Send Feedback
Provides generation and sending of queries to service for reports getting.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ServiceProvider : IReportService
Visual Basic
Public Class ServiceProvider _
    Implements IReportService
Visual C++
public ref class ServiceProvider : IReportService

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..ServiceProvider

See Also

ServiceProvider Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServiceProvider Members

[image] [image]

SharpShooter Reports.Web
ServiceProvider Members
ServiceProvider Class Constructors Methods Fields See Also Send Feedback

The ServiceProvider type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceProvider | Creates the PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider class instance.

Methods

 | Name | Description
Public method | AbortRequests | Abort all pending requests
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadDocumentInfo | Returns the report metadata from server.
Public method | LoadDocumentMapInfo | Returns a document bookmark tree from server.
Public method | LoadDocumentMapInfoFull | Generates the report and returns a documents bookmark tree from server.
Public method | LoadPageInfo | Returns page metadata by report identificator and page number.
Public method | LoadPageInfoFull | Generates the report and returns page metadata by report identificator and page number.
Public method | LoadReportParameters | Returns a parameters list from report.
Public method | LoadThumbnailsInfo | Returns thumbnails links collection.
Public method | LoadThumbnailsInfoFull | Generates the report and returns thumbnails links collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetRequestOption | Extends the configuration options for connect to service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ServiceUrl | Gets or sets a service url.

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServiceProvider Constructor

[image]

SharpShooter Reports.Web
ServiceProvider Constructor
ServiceProvider Class See Also Send Feedback
Creates the PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider class instance.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ServiceProvider(
    ErrorProvider errorProvider
)
Visual Basic
Public Sub New ( _
    errorProvider As ErrorProvider _
)
Visual C++
public:
ServiceProvider(
    ErrorProvider^ errorProvider
)

Parameters

errorProvider
Type: PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorProvider
The PerpetuumSoft.Reporting.WebViewer.Client.ErrorProvider class object which provides access to the errors occurred during the component work.

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServiceProvider Fields

[image] [image]

SharpShooter Reports.Web
ServiceProvider Fields
ServiceProvider Class See Also Send Feedback

The ServiceProvider type exposes the following members.

Fields

 | Name | Description
Public field | ServiceUrl | Gets or sets a service url.

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServiceUrl Field

[image]

SharpShooter Reports.Web
ServiceProvider..::..ServiceUrl Field
ServiceProvider Class See Also Send Feedback
Gets or sets a service url.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ServiceUrl
Visual Basic
Public ServiceUrl As String
Visual C++
public:
String^ ServiceUrl

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ServiceProvider Methods

[image] [image]

SharpShooter Reports.Web
ServiceProvider Methods
ServiceProvider Class See Also Send Feedback

The ServiceProvider type exposes the following members.

Methods

 | Name | Description
Public method | AbortRequests | Abort all pending requests
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadDocumentInfo | Returns the report metadata from server.
Public method | LoadDocumentMapInfo | Returns a document bookmark tree from server.
Public method | LoadDocumentMapInfoFull | Generates the report and returns a documents bookmark tree from server.
Public method | LoadPageInfo | Returns page metadata by report identificator and page number.
Public method | LoadPageInfoFull | Generates the report and returns page metadata by report identificator and page number.
Public method | LoadReportParameters | Returns a parameters list from report.
Public method | LoadThumbnailsInfo | Returns thumbnails links collection.
Public method | LoadThumbnailsInfoFull | Generates the report and returns thumbnails links collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetRequestOption | Extends the configuration options for connect to service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


AbortRequests Method

[image]

SharpShooter Reports.Web
ServiceProvider..::..AbortRequests Method
ServiceProvider Class See Also Send Feedback
Abort all pending requests

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AbortRequests()
Visual Basic
Public Sub AbortRequests
Visual C++
public:
void AbortRequests()

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadDocumentInfo Method

[image]

SharpShooter Reports.Web
ServiceProvider..::..LoadDocumentInfo Method
ServiceProvider Class See Also Send Feedback
Returns the report metadata from server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadDocumentInfo(
    LoadDocumentInfoRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Public Sub LoadDocumentInfo ( _
    request As LoadDocumentInfoRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
public:
virtual void LoadDocumentInfo(
    LoadDocumentInfoRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
) sealed

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentInfoRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider.LoadDocumentInfo(PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentInfoRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

Implements

IReportService..::..LoadDocumentInfo(LoadDocumentInfoRequest, AjaxRequestCallback, AjaxErrorCallback)

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadDocumentMapInfo Method

[image]

SharpShooter Reports.Web
ServiceProvider..::..LoadDocumentMapInfo Method
ServiceProvider Class See Also Send Feedback
Returns a document bookmark tree from server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadDocumentMapInfo(
    LoadDocumentMapInfoRequest request,
    AjaxRequestCallback successCallBack,
    AjaxErrorCallback errorCallback
)
Visual Basic
Public Sub LoadDocumentMapInfo ( _
    request As LoadDocumentMapInfoRequest, _
    successCallBack As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
public:
virtual void LoadDocumentMapInfo(
    LoadDocumentMapInfoRequest^ request,
    AjaxRequestCallback^ successCallBack,
    AjaxErrorCallback^ errorCallback
) sealed

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentMapInfoRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider.LoadDocumentMapInfo(PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentMapInfoRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallBack
Type: AjaxRequestCallback

[Missing <param name="successCallBack"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider.LoadDocumentMapInfo(PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentMapInfoRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

Implements

IReportService..::..LoadDocumentMapInfo(LoadDocumentMapInfoRequest, AjaxRequestCallback, AjaxErrorCallback)

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadDocumentMapInfoFull Method

[image]

SharpShooter Reports.Web
ServiceProvider..::..LoadDocumentMapInfoFull Method
ServiceProvider Class See Also Send Feedback
Generates the report and returns a documents bookmark tree from server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadDocumentMapInfoFull(
    LoadDocumentMapInfoFullRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Public Sub LoadDocumentMapInfoFull ( _
    request As LoadDocumentMapInfoFullRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
public:
virtual void LoadDocumentMapInfoFull(
    LoadDocumentMapInfoFullRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
) sealed

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentMapInfoFullRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider.LoadDocumentMapInfoFull(PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentMapInfoFullRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

Implements

IReportService..::..LoadDocumentMapInfoFull(LoadDocumentMapInfoFullRequest, AjaxRequestCallback, AjaxErrorCallback)

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadPageInfo Method

[image]

SharpShooter Reports.Web
ServiceProvider..::..LoadPageInfo Method
ServiceProvider Class See Also Send Feedback
Returns page metadata by report identificator and page number.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadPageInfo(
    LoadPageInfoRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Public Sub LoadPageInfo ( _
    request As LoadPageInfoRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
public:
virtual void LoadPageInfo(
    LoadPageInfoRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
) sealed

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadPageInfoRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider.LoadPageInfo(PerpetuumSoft.Reporting.WebViewer.Model.LoadPageInfoRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

Implements

IReportService..::..LoadPageInfo(LoadPageInfoRequest, AjaxRequestCallback, AjaxErrorCallback)

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadPageInfoFull Method

[image]

SharpShooter Reports.Web
ServiceProvider..::..LoadPageInfoFull Method
ServiceProvider Class See Also Send Feedback
Generates the report and returns page metadata by report identificator and page number.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadPageInfoFull(
    LoadPageInfoFullRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Public Sub LoadPageInfoFull ( _
    request As LoadPageInfoFullRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
public:
virtual void LoadPageInfoFull(
    LoadPageInfoFullRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
) sealed

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadPageInfoFullRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider.LoadPageInfoFull(PerpetuumSoft.Reporting.WebViewer.Model.LoadPageInfoFullRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

Implements

IReportService..::..LoadPageInfoFull(LoadPageInfoFullRequest, AjaxRequestCallback, AjaxErrorCallback)

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadReportParameters Method

[image]

SharpShooter Reports.Web
ServiceProvider..::..LoadReportParameters Method
ServiceProvider Class See Also Send Feedback
Returns a parameters list from report.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadReportParameters(
    LoadReportParametersRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Public Sub LoadReportParameters ( _
    request As LoadReportParametersRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
public:
virtual void LoadReportParameters(
    LoadReportParametersRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
) sealed

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadReportParametersRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider.LoadReportParameters(PerpetuumSoft.Reporting.WebViewer.Model.LoadReportParametersRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

Implements

IReportService..::..LoadReportParameters(LoadReportParametersRequest, AjaxRequestCallback, AjaxErrorCallback)

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadThumbnailsInfo Method

[image]

SharpShooter Reports.Web
ServiceProvider..::..LoadThumbnailsInfo Method
ServiceProvider Class See Also Send Feedback
Returns thumbnails links collection.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadThumbnailsInfo(
    LoadThumbnailsInfoRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Public Sub LoadThumbnailsInfo ( _
    request As LoadThumbnailsInfoRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
public:
virtual void LoadThumbnailsInfo(
    LoadThumbnailsInfoRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
) sealed

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadThumbnailsInfoRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider.LoadThumbnailsInfo(PerpetuumSoft.Reporting.WebViewer.Model.LoadThumbnailsInfoRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

Implements

IReportService..::..LoadThumbnailsInfo(LoadThumbnailsInfoRequest, AjaxRequestCallback, AjaxErrorCallback)

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


LoadThumbnailsInfoFull Method

[image]

SharpShooter Reports.Web
ServiceProvider..::..LoadThumbnailsInfoFull Method
ServiceProvider Class See Also Send Feedback
Generates the report and returns thumbnails links collection.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadThumbnailsInfoFull(
    LoadThumbnailsInfoFullRequest request,
    AjaxRequestCallback successCallback,
    AjaxErrorCallback errorCallback
)
Visual Basic
Public Sub LoadThumbnailsInfoFull ( _
    request As LoadThumbnailsInfoFullRequest, _
    successCallback As AjaxRequestCallback, _
    errorCallback As AjaxErrorCallback _
)
Visual C++
public:
virtual void LoadThumbnailsInfoFull(
    LoadThumbnailsInfoFullRequest^ request,
    AjaxRequestCallback^ successCallback,
    AjaxErrorCallback^ errorCallback
) sealed

Parameters

request
Type: PerpetuumSoft.Reporting.WebViewer.Model..::..LoadThumbnailsInfoFullRequest

[Missing <param name="request"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.ServiceProvider.LoadThumbnailsInfoFull(PerpetuumSoft.Reporting.WebViewer.Model.LoadThumbnailsInfoFullRequest,jQueryApi.AjaxRequestCallback,jQueryApi.AjaxErrorCallback)"]

successCallback
Type: AjaxRequestCallback
A callback to be invoked for a success Ajax request.
errorCallback
Type: AjaxErrorCallback
A callback to be invoked for a failed Ajax request.

Implements

IReportService..::..LoadThumbnailsInfoFull(LoadThumbnailsInfoFullRequest, AjaxRequestCallback, AjaxErrorCallback)

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


SetRequestOption Method

[image]

SharpShooter Reports.Web
ServiceProvider..::..SetRequestOption Method
ServiceProvider Class See Also Send Feedback
Extends the configuration options for connect to service.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetRequestOption(
    jQueryAjaxOptions option
)
Visual Basic
Public Sub SetRequestOption ( _
    option As jQueryAjaxOptions _
)
Visual C++
public:
void SetRequestOption(
    jQueryAjaxOptions^ option
)

Parameters

option
Type: jQueryAjaxOptions
The configuration options.

See Also

ServiceProvider Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


ThumbnailsInfoLoadedCallback Delegate

[image]

SharpShooter Reports.Web
ThumbnailsInfoLoadedCallback Delegate
See Also Send Feedback
The callback function which is invoked when data about thumbnails were received from a server.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void ThumbnailsInfoLoadedCallback(
    List<string> thumbnailsLink
)
Visual Basic
Public Delegate Sub ThumbnailsInfoLoadedCallback ( _
    thumbnailsLink As List(Of String) _
)
Visual C++
public delegate void ThumbnailsInfoLoadedCallback(
    List<String^>^ thumbnailsLink
)

Parameters

thumbnailsLink
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
A list of link for thumbnails loading from a server.

See Also

PerpetuumSoft.Reporting.WebViewer.Client Namespace


Viewport Class

[image]

SharpShooter Reports.Web
Viewport Class
Members See Also Send Feedback
Class which checks visibility of the container element objects.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class Viewport
Visual Basic
Public NotInheritable Class Viewport
Visual C++
public ref class Viewport abstract sealed

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client..::..Viewport

See Also

Viewport Members
PerpetuumSoft.Reporting.WebViewer.Client Namespace


Viewport Members

[image] [image]

SharpShooter Reports.Web
Viewport Members
Viewport Class Methods See Also Send Feedback

The Viewport type exposes the following members.

Methods

Name | Description
FullView | Defines if the whole element is in the container element area.
InViewport | Defines if an element is in the container element area.

See Also

Viewport Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


Viewport Methods

[image] [image]

SharpShooter Reports.Web
Viewport Methods
Viewport Class See Also Send Feedback

The Viewport type exposes the following members.

Methods

Name | Description
FullView | Defines if the whole element is in the container element area.
InViewport | Defines if an element is in the container element area.

See Also

Viewport Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


FullView Method

[image]

SharpShooter Reports.Web
Viewport..::..FullView Method
Viewport Class See Also Send Feedback
Defines if the whole element is in the container element area.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool FullView(
    Element element,
    Element viewport
)
Visual Basic
Public Shared Function FullView ( _
    element As Element, _
    viewport As Element _
) As Boolean
Visual C++
public:
static bool FullView(
    Element^ element,
    Element^ viewport
)

Parameters

element
Type: Element
Element.
viewport
Type: Element
Container.

Return Value

True if the whole element is in the container element area. False if the whole element is not in the container element area.

See Also

Viewport Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


InViewport Method

[image]

SharpShooter Reports.Web
Viewport..::..InViewport Method
Viewport Class See Also Send Feedback
Defines if an element is in the container element area.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool InViewport(
    Element element,
    Element viewport
)
Visual Basic
Public Shared Function InViewport ( _
    element As Element, _
    viewport As Element _
) As Boolean
Visual C++
public:
static bool InViewport(
    Element^ element,
    Element^ viewport
)

Parameters

element
Type: Element
Element.
viewport
Type: Element
Container.

Return Value

True if an element is in the container element area. False if an element is not in the container element area.

See Also

Viewport Class
PerpetuumSoft.Reporting.WebViewer.Client Namespace


PerpetuumSoft.Reporting.WebViewer.Client.View Namespace

[image]

SharpShooter Reports.Web
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace
Send Feedback
Contains classes which are responsible for display

Classes

 | Class | Description
Public class | DocumentMapjQueryObject | Creates bookmarks tree.
Public class | DocumentMapView | Manages creation and display of bookmarks tree.
Public class | jQueryTreeViewOption | Defines properties needed for display of bookmarks tree.
Public class | LoadingIndicator | Used for creation of throbber.
Public class | PageView | The class which controls report pages display.
Public class | PageViewBase | Abstract basic class of pages display.
Public class | ThumbnailsView | Manages creation and display of thumbnails.
Public class | ViewManager | The class which manages the display of pages.


DocumentMapjQueryObject Class

[image]

SharpShooter Reports.Web
DocumentMapjQueryObject Class
Members See Also Send Feedback
Creates bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public sealed class DocumentMapjQueryObject : jQueryObject
Visual Basic
Public NotInheritable Class DocumentMapjQueryObject _
    Inherits jQueryObject
Visual C++
public ref class DocumentMapjQueryObject sealed : public jQueryObject

Inheritance Hierarchy

System..::..Object
jQueryObject
PerpetuumSoft.Reporting.WebViewer.Client.View..::..DocumentMapjQueryObject

See Also

DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DocumentMapjQueryObject Members

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject Members
DocumentMapjQueryObject Class Constructors Methods Properties See Also Send Feedback

The DocumentMapjQueryObject type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentMapjQueryObject | Initializes a new instance of the DocumentMapjQueryObject class

Methods

 | Name | Description
Public method | Add(Element) | (Inherited from jQueryObject.)
Public method | Add(array<Element>[]()[][]) | (Inherited from jQueryObject.)
Public method | Add(String) | (Inherited from jQueryObject.)
Public method | Add(String, DocumentInstance) | (Inherited from jQueryObject.)
Public method | Add(String, Element) | (Inherited from jQueryObject.)
Public method | AddClass(String) | (Inherited from jQueryObject.)
Public method | AddClass(StringFunction) | (Inherited from jQueryObject.)
Public method | AddClass(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | AddHtml | (Inherited from jQueryObject.)
Public method | After(String) | (Inherited from jQueryObject.)
Public method | After(jQueryObject) | (Inherited from jQueryObject.)
Public method | After(StringFunction) | (Inherited from jQueryObject.)
Public method | AjaxComplete | (Inherited from jQueryObject.)
Public method | AjaxError | (Inherited from jQueryObject.)
Public method | AjaxSend | (Inherited from jQueryObject.)
Public method | AjaxStart | (Inherited from jQueryObject.)
Public method | AjaxStop | (Inherited from jQueryObject.)
Public method | AjaxSuccess | (Inherited from jQueryObject.)
Public method | AndSelf | (Inherited from jQueryObject.)
Public method | Animate(Dictionary) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Int32) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, EffectDuration) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Dictionary) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Int32, EffectEasing) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, EffectDuration, EffectEasing) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Append(String) | (Inherited from jQueryObject.)
Public method | Append(Element) | (Inherited from jQueryObject.)
Public method | Append(jQueryObject) | (Inherited from jQueryObject.)
Public method | Append(StringFunction) | (Inherited from jQueryObject.)
Public method | Append(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | AppendTo(Element) | (Inherited from jQueryObject.)
Public method | AppendTo(String) | (Inherited from jQueryObject.)
Public method | AppendTo(jQueryObject) | (Inherited from jQueryObject.)
Public method | Attribute(Dictionary) | (Inherited from jQueryObject.)
Public method | Attribute(StringFunction) | (Inherited from jQueryObject.)
Public method | Attribute(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | Attribute(String, String) | (Inherited from jQueryObject.)
Public method | Before(String) | (Inherited from jQueryObject.)
Public method | Before(Element) | (Inherited from jQueryObject.)
Public method | Before(jQueryObject) | (Inherited from jQueryObject.)
Public method | Before(StringFunction) | (Inherited from jQueryObject.)
Public method | Bind(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Bind(String, Boolean) | (Inherited from jQueryObject.)
Public method | Bind(String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Blur()()()() | (Inherited from jQueryObject.)
Public method | Blur(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Blur(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Change()()()() | (Inherited from jQueryObject.)
Public method | Change(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Change(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Children()()()() | (Inherited from jQueryObject.)
Public method | Children(String) | (Inherited from jQueryObject.)
Public method | Click()()()() | (Inherited from jQueryObject.)
Public method | Click(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Click(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Clone()()()() | (Inherited from jQueryObject.)
Public method | Clone(Boolean) | (Inherited from jQueryObject.)
Public method | Clone(Boolean, Boolean) | (Inherited from jQueryObject.)
Public method | Closest(Element) | (Inherited from jQueryObject.)
Public method | Closest(jQueryObject) | (Inherited from jQueryObject.)
Public method | Closest(String) | (Inherited from jQueryObject.)
Public method | Closest(String, Element) | (Inherited from jQueryObject.)
Public method | Contents | (Inherited from jQueryObject.)
Public method | CSS(Dictionary) | (Inherited from jQueryObject.)
Public method | CSS(String, String) | (Inherited from jQueryObject.)
Public method | CSS(String, StringFunction) | (Inherited from jQueryObject.)
Public method | CSS(String, StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | Data(Dictionary) | (Inherited from jQueryObject.)
Public method | Data(String, Object) | (Inherited from jQueryObject.)
Public method | Delegate(String, String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Delegate(String, String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Detach()()()() | (Inherited from jQueryObject.)
Public method | Detach(String) | (Inherited from jQueryObject.)
Public method | Die()()()() | (Inherited from jQueryObject.)
Public method | Die(String) | (Inherited from jQueryObject.)
Public method | Die(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | DoubleClick()()()() | (Inherited from jQueryObject.)
Public method | DoubleClick(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | DoubleClick(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Each(ElementIterationCallback) | (Inherited from jQueryObject.)
Public method | Each(ElementInterruptibleIterationCallback) | (Inherited from jQueryObject.)
Public method | Empty | (Inherited from jQueryObject.)
Public method | End | (Inherited from jQueryObject.)
Public method | Eq | (Inherited from jQueryObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Error()()()() | (Inherited from jQueryObject.)
Public method | Error(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Error(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FadeIn()()()() | (Inherited from jQueryObject.)
Public method | FadeIn(Int32) | (Inherited from jQueryObject.)
Public method | FadeIn(EffectDuration) | (Inherited from jQueryObject.)
Public method | FadeIn(Int32, Action) | (Inherited from jQueryObject.)
Public method | FadeIn(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | FadeIn(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeIn(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeOut()()()() | (Inherited from jQueryObject.)
Public method | FadeOut(Int32) | (Inherited from jQueryObject.)
Public method | FadeOut(EffectDuration) | (Inherited from jQueryObject.)
Public method | FadeOut(Int32, Action) | (Inherited from jQueryObject.)
Public method | FadeOut(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | FadeOut(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeOut(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(Int32, Double) | (Inherited from jQueryObject.)
Public method | FadeTo(EffectDuration, Double) | (Inherited from jQueryObject.)
Public method | FadeTo(Int32, Double, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(EffectDuration, Double, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(Int32, Double, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(EffectDuration, Double, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeToggle()()()() | (Inherited from jQueryObject.)
Public method | FadeToggle(Int32) | (Inherited from jQueryObject.)
Public method | FadeToggle(EffectDuration) | (Inherited from jQueryObject.)
Public method | FadeToggle(Int32, Action) | (Inherited from jQueryObject.)
Public method | FadeToggle(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | FadeToggle(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Filter(String) | (Inherited from jQueryObject.)
Public method | Filter(ElementFilterCallback) | (Inherited from jQueryObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Element) | (Inherited from jQueryObject.)
Public method | Find(jQueryObject) | (Inherited from jQueryObject.)
Public method | Find(String) | (Inherited from jQueryObject.)
Public method | First | (Inherited from jQueryObject.)
Public method | Focus()()()() | (Inherited from jQueryObject.)
Public method | Focus(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Focus(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FocusIn(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FocusIn(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FocusOut(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FocusOut(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | GetAttribute | (Inherited from jQueryObject.)
Public method | GetCSS | (Inherited from jQueryObject.)
Public method | GetData | (Inherited from jQueryObject.)
Public method | GetDataValue | (Inherited from jQueryObject.)
Public method | GetElement | (Inherited from jQueryObject.)
Public method | GetElements | (Inherited from jQueryObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeight | (Inherited from jQueryObject.)
Public method | GetHtml | (Inherited from jQueryObject.)
Public method | GetInnerHeight | (Inherited from jQueryObject.)
Public method | GetInnerWidth | (Inherited from jQueryObject.)
Public method | GetItem | (Inherited from jQueryObject.)
Public method | GetItems | (Inherited from jQueryObject.)
Public method | GetOffset | (Inherited from jQueryObject.)
Public method | GetOuterHeight()()()() | (Inherited from jQueryObject.)
Public method | GetOuterHeight(Boolean) | (Inherited from jQueryObject.)
Public method | GetOuterWidth()()()() | (Inherited from jQueryObject.)
Public method | GetOuterWidth(Boolean) | (Inherited from jQueryObject.)
Public method | GetProperty | (Inherited from jQueryObject.)
Public method | GetScrollLeft | (Inherited from jQueryObject.)
Public method | GetScrollTop | (Inherited from jQueryObject.)
Public method | GetText | (Inherited from jQueryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Inherited from jQueryObject.)
Public method | GetWidth | (Inherited from jQueryObject.)
Public method | Has(String) | (Inherited from jQueryObject.)
Public method | Has(Element) | (Inherited from jQueryObject.)
Public method | HasClass | (Inherited from jQueryObject.)
Public method | Height(Int32) | (Inherited from jQueryObject.)
Public method | Height(String) | (Inherited from jQueryObject.)
Public method | Hide()()()() | (Inherited from jQueryObject.)
Public method | Hide(Int32) | (Inherited from jQueryObject.)
Public method | Hide(EffectDuration) | (Inherited from jQueryObject.)
Public method | Hide(Int32, Action) | (Inherited from jQueryObject.)
Public method | Hide(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | Hide(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Hide(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Html(String) | (Inherited from jQueryObject.)
Public method | Html(jQueryObject) | (Inherited from jQueryObject.)
Public method | Html(StringFunction) | (Inherited from jQueryObject.)
Public method | Html(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | Index()()()() | (Inherited from jQueryObject.)
Public method | Index(Element) | (Inherited from jQueryObject.)
Public method | Index(String) | (Inherited from jQueryObject.)
Public method | InsertAfter(Element) | (Inherited from jQueryObject.)
Public method | InsertAfter(String) | (Inherited from jQueryObject.)
Public method | InsertAfter(jQueryObject) | (Inherited from jQueryObject.)
Public method | InsertBefore(Element) | (Inherited from jQueryObject.)
Public method | InsertBefore(String) | (Inherited from jQueryObject.)
Public method | InsertBefore(jQueryObject) | (Inherited from jQueryObject.)
Public method | Is(BooleanFunction) | (Inherited from jQueryObject.)
Public method | Is(Element) | (Inherited from jQueryObject.)
Public method | Is(jQueryObject) | (Inherited from jQueryObject.)
Public method | Is(String) | (Inherited from jQueryObject.)
Public method | Keydown()()()() | (Inherited from jQueryObject.)
Public method | Keydown(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keydown(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keypress()()()() | (Inherited from jQueryObject.)
Public method | Keypress(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keypress(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keyup()()()() | (Inherited from jQueryObject.)
Public method | Keyup(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keyup(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Last | (Inherited from jQueryObject.)
Public method | Live(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Live(String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Load(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Load(String) | (Inherited from jQueryObject.)
Public method | Load(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Load(String, Object) | (Inherited from jQueryObject.)
Public method | Load(String, Object, AjaxCallback<(Of <<'(Object>)>>)) | (Inherited from jQueryObject.)
Public method | Load(String, Object, AjaxRequestCallback<(Of <<'(Object>)>>)) | (Inherited from jQueryObject.)
Public method | Map | (Inherited from jQueryObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseDown(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseDown(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseEnter(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseEnter(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseLeave(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseLeave(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseMove(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseMove(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseOut(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseOut(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseOver(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseOver(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseUp(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseUp(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Next()()()() | (Inherited from jQueryObject.)
Public method | Next(String) | (Inherited from jQueryObject.)
Public method | NextAll()()()() | (Inherited from jQueryObject.)
Public method | NextAll(String) | (Inherited from jQueryObject.)
Public method | NextUntil | (Inherited from jQueryObject.)
Public method | Not(Element) | (Inherited from jQueryObject.)
Public method | Not(array<Element>[]()[][]) | (Inherited from jQueryObject.)
Public method | Not(String) | (Inherited from jQueryObject.)
Public method | Not(ElementFilterCallback) | (Inherited from jQueryObject.)
Public method | Offset(jQueryPosition) | (Inherited from jQueryObject.)
Public method | Offset(PositionFunction) | (Inherited from jQueryObject.)
Public method | Offset(PositionReplaceFunction) | (Inherited from jQueryObject.)
Public method | OffsetParent | (Inherited from jQueryObject.)
Public method | One(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | One(String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Parent()()()() | (Inherited from jQueryObject.)
Public method | Parent(String) | (Inherited from jQueryObject.)
Public method | Parents()()()() | (Inherited from jQueryObject.)
Public method | Parents(String) | (Inherited from jQueryObject.)
Public method | ParentsUntil | (Inherited from jQueryObject.)
Public method | Plugin``1 | (Inherited from jQueryObject.)
Public method | Position | (Inherited from jQueryObject.)
Public method | Prepend(String) | (Inherited from jQueryObject.)
Public method | Prepend(Element) | (Inherited from jQueryObject.)
Public method | Prepend(array<Element>[]()[][]) | (Inherited from jQueryObject.)
Public method | Prepend(jQueryObject) | (Inherited from jQueryObject.)
Public method | Prepend(StringFunction) | (Inherited from jQueryObject.)
Public method | Prepend(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | PrependTo(String) | (Inherited from jQueryObject.)
Public method | PrependTo(Element) | (Inherited from jQueryObject.)
Public method | PrependTo(jQueryObject) | (Inherited from jQueryObject.)
Public method | Prev()()()() | (Inherited from jQueryObject.)
Public method | Prev(String) | (Inherited from jQueryObject.)
Public method | PrevAll()()()() | (Inherited from jQueryObject.)
Public method | PrevAll(String) | (Inherited from jQueryObject.)
Public method | PrevUntil | (Inherited from jQueryObject.)
Public method | Promise()()()() | (Inherited from jQueryObject.)
Public method | Promise(String) | (Inherited from jQueryObject.)
Public method | Promise(String, Object) | (Inherited from jQueryObject.)
Public method | Property | (Inherited from jQueryObject.)
Public method | Remove()()()() | (Inherited from jQueryObject.)
Public method | Remove(String) | (Inherited from jQueryObject.)
Public method | RemoveAttr | (Inherited from jQueryObject.)
Public method | RemoveClass()()()() | (Inherited from jQueryObject.)
Public method | RemoveClass(String) | (Inherited from jQueryObject.)
Public method | RemoveClass(StringFunction) | (Inherited from jQueryObject.)
Public method | RemoveClass(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | RemoveData()()()() | (Inherited from jQueryObject.)
Public method | RemoveData(String) | (Inherited from jQueryObject.)
Public method | RemoveProperty | (Inherited from jQueryObject.)
Public method | ReplaceAll | (Inherited from jQueryObject.)
Public method | ReplaceWith(String) | (Inherited from jQueryObject.)
Public method | ReplaceWith(Element) | (Inherited from jQueryObject.)
Public method | ReplaceWith(jQueryObject) | (Inherited from jQueryObject.)
Public method | ReplaceWith(StringFunction) | (Inherited from jQueryObject.)
Public method | Resize(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Resize(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Scroll(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Scroll(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | ScrollLeft | (Inherited from jQueryObject.)
Public method | ScrollTop | (Inherited from jQueryObject.)
Public method | Select()()()() | (Inherited from jQueryObject.)
Public method | Select(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Select(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Serialize | (Inherited from jQueryObject.)
Public method | SerializeArray | (Inherited from jQueryObject.)
Public method | Show()()()() | (Inherited from jQueryObject.)
Public method | Show(Int32) | (Inherited from jQueryObject.)
Public method | Show(EffectDuration) | (Inherited from jQueryObject.)
Public method | Show(Int32, Action) | (Inherited from jQueryObject.)
Public method | Show(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | Show(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Show(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Siblings()()()() | (Inherited from jQueryObject.)
Public method | Siblings(String) | (Inherited from jQueryObject.)
Public method | Size | (Inherited from jQueryObject.)
Public method | Slice(Int32) | (Inherited from jQueryObject.)
Public method | Slice(Int32, Int32) | (Inherited from jQueryObject.)
Public method | SlideDown()()()() | (Inherited from jQueryObject.)
Public method | SlideDown(Int32) | (Inherited from jQueryObject.)
Public method | SlideDown(EffectDuration) | (Inherited from jQueryObject.)
Public method | SlideDown(Int32, Action) | (Inherited from jQueryObject.)
Public method | SlideDown(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | SlideDown(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | SlideDown(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | SlideToggle()()()() | (Inherited from jQueryObject.)
Public method | SlideToggle(Int32) | (Inherited from jQueryObject.)
Public method | SlideToggle(EffectDuration) | (Inherited from jQueryObject.)
Public method | SlideToggle(Int32, Action) | (Inherited from jQueryObject.)
Public method | SlideToggle(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | SlideToggle(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | SlideUp()()()() | (Inherited from jQueryObject.)
Public method | SlideUp(Int32) | (Inherited from jQueryObject.)
Public method | SlideUp(EffectDuration) | (Inherited from jQueryObject.)
Public method | SlideUp(Int32, Action) | (Inherited from jQueryObject.)
Public method | SlideUp(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | SlideUp(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | SlideUp(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Stop()()()() | (Inherited from jQueryObject.)
Public method | Stop(Boolean) | (Inherited from jQueryObject.)
Public method | Stop(Boolean, Boolean) | (Inherited from jQueryObject.)
Public method | Submit()()()() | (Inherited from jQueryObject.)
Public method | Submit(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Submit(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | SwitchClass(String, Boolean) | (Inherited from jQueryObject.)
Public method | SwitchClass(StringFunction, Boolean) | (Inherited from jQueryObject.)
Public method | SwitchClass(StringReplaceFunction, Boolean) | (Inherited from jQueryObject.)
Public method | Text(String) | (Inherited from jQueryObject.)
Public method | Text(StringFunction) | (Inherited from jQueryObject.)
Public method | Text(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | ToArray | (Inherited from jQueryObject.)
Public method | Toggle()()()() | (Inherited from jQueryObject.)
Public method | Toggle(Boolean) | (Inherited from jQueryObject.)
Public method | Toggle(Int32) | (Inherited from jQueryObject.)
Public method | Toggle(EffectDuration) | (Inherited from jQueryObject.)
Public method | Toggle(Int32, Action) | (Inherited from jQueryObject.)
Public method | Toggle(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | Toggle(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Toggle(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | ToggleClass(String) | (Inherited from jQueryObject.)
Public method | ToggleClass(StringFunction) | (Inherited from jQueryObject.)
Public method | ToggleClass(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | treeview | Initializes bookmarks tree.
Public method | Trigger(String) | (Inherited from jQueryObject.)
Public method | Trigger(String, array<Object>[]()[][]) | (Inherited from jQueryObject.)
Public method | TriggerHandler(String) | (Inherited from jQueryObject.)
Public method | TriggerHandler(String, array<Object>[]()[][]) | (Inherited from jQueryObject.)
Public method | Unbind(String) | (Inherited from jQueryObject.)
Public method | Unbind(jQueryEvent) | (Inherited from jQueryObject.)
Public method | Unbind(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Unbind(String, Boolean) | (Inherited from jQueryObject.)
Public method | Undelegate(String) | (Inherited from jQueryObject.)
Public method | Undelegate(String, String) | (Inherited from jQueryObject.)
Public method | Undelegate(String, String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Unload(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Unload(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Unwrap | (Inherited from jQueryObject.)
Public method | Value(String) | (Inherited from jQueryObject.)
Public method | Value(StringFunction) | (Inherited from jQueryObject.)
Public method | Value(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | Width(Int32) | (Inherited from jQueryObject.)
Public method | Width(String) | (Inherited from jQueryObject.)
Public method | Wrap(String) | (Inherited from jQueryObject.)
Public method | Wrap(Element) | (Inherited from jQueryObject.)
Public method | Wrap(jQueryObject) | (Inherited from jQueryObject.)
Public method | Wrap(StringFunction) | (Inherited from jQueryObject.)
Public method | WrapAll(String) | (Inherited from jQueryObject.)
Public method | WrapAll(Element) | (Inherited from jQueryObject.)
Public method | WrapAll(jQueryObject) | (Inherited from jQueryObject.)
Public method | WrapInner(String) | (Inherited from jQueryObject.)
Public method | WrapInner(Element) | (Inherited from jQueryObject.)
Public method | WrapInner(jQueryObject) | (Inherited from jQueryObject.)
Public method | WrapInner(StringFunction) | (Inherited from jQueryObject.)

Properties

 | Name | Description
Public property | Context | (Inherited from jQueryObject.)
Public property | Item | (Inherited from jQueryObject.)
Public property | Length | (Inherited from jQueryObject.)
Public property | Selector | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DocumentMapjQueryObject Constructor

[image]

SharpShooter Reports.Web
DocumentMapjQueryObject Constructor
DocumentMapjQueryObject Class See Also Send Feedback
Initializes a new instance of the DocumentMapjQueryObject class

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentMapjQueryObject()
Visual Basic
Public Sub New
Visual C++
public:
DocumentMapjQueryObject()

See Also

DocumentMapjQueryObject Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DocumentMapjQueryObject Methods

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject Methods
DocumentMapjQueryObject Class See Also Send Feedback

The DocumentMapjQueryObject type exposes the following members.

Methods

 | Name | Description
Public method | Add(Element) | (Inherited from jQueryObject.)
Public method | Add(array<Element>[]()[][]) | (Inherited from jQueryObject.)
Public method | Add(String) | (Inherited from jQueryObject.)
Public method | Add(String, DocumentInstance) | (Inherited from jQueryObject.)
Public method | Add(String, Element) | (Inherited from jQueryObject.)
Public method | AddClass(String) | (Inherited from jQueryObject.)
Public method | AddClass(StringFunction) | (Inherited from jQueryObject.)
Public method | AddClass(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | AddHtml | (Inherited from jQueryObject.)
Public method | After(String) | (Inherited from jQueryObject.)
Public method | After(jQueryObject) | (Inherited from jQueryObject.)
Public method | After(StringFunction) | (Inherited from jQueryObject.)
Public method | AjaxComplete | (Inherited from jQueryObject.)
Public method | AjaxError | (Inherited from jQueryObject.)
Public method | AjaxSend | (Inherited from jQueryObject.)
Public method | AjaxStart | (Inherited from jQueryObject.)
Public method | AjaxStop | (Inherited from jQueryObject.)
Public method | AjaxSuccess | (Inherited from jQueryObject.)
Public method | AndSelf | (Inherited from jQueryObject.)
Public method | Animate(Dictionary) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Int32) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, EffectDuration) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Dictionary) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Int32, EffectEasing) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, EffectDuration, EffectEasing) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Append(String) | (Inherited from jQueryObject.)
Public method | Append(Element) | (Inherited from jQueryObject.)
Public method | Append(jQueryObject) | (Inherited from jQueryObject.)
Public method | Append(StringFunction) | (Inherited from jQueryObject.)
Public method | Append(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | AppendTo(Element) | (Inherited from jQueryObject.)
Public method | AppendTo(String) | (Inherited from jQueryObject.)
Public method | AppendTo(jQueryObject) | (Inherited from jQueryObject.)
Public method | Attribute(Dictionary) | (Inherited from jQueryObject.)
Public method | Attribute(StringFunction) | (Inherited from jQueryObject.)
Public method | Attribute(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | Attribute(String, String) | (Inherited from jQueryObject.)
Public method | Before(String) | (Inherited from jQueryObject.)
Public method | Before(Element) | (Inherited from jQueryObject.)
Public method | Before(jQueryObject) | (Inherited from jQueryObject.)
Public method | Before(StringFunction) | (Inherited from jQueryObject.)
Public method | Bind(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Bind(String, Boolean) | (Inherited from jQueryObject.)
Public method | Bind(String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Blur()()()() | (Inherited from jQueryObject.)
Public method | Blur(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Blur(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Change()()()() | (Inherited from jQueryObject.)
Public method | Change(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Change(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Children()()()() | (Inherited from jQueryObject.)
Public method | Children(String) | (Inherited from jQueryObject.)
Public method | Click()()()() | (Inherited from jQueryObject.)
Public method | Click(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Click(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Clone()()()() | (Inherited from jQueryObject.)
Public method | Clone(Boolean) | (Inherited from jQueryObject.)
Public method | Clone(Boolean, Boolean) | (Inherited from jQueryObject.)
Public method | Closest(Element) | (Inherited from jQueryObject.)
Public method | Closest(jQueryObject) | (Inherited from jQueryObject.)
Public method | Closest(String) | (Inherited from jQueryObject.)
Public method | Closest(String, Element) | (Inherited from jQueryObject.)
Public method | Contents | (Inherited from jQueryObject.)
Public method | CSS(Dictionary) | (Inherited from jQueryObject.)
Public method | CSS(String, String) | (Inherited from jQueryObject.)
Public method | CSS(String, StringFunction) | (Inherited from jQueryObject.)
Public method | CSS(String, StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | Data(Dictionary) | (Inherited from jQueryObject.)
Public method | Data(String, Object) | (Inherited from jQueryObject.)
Public method | Delegate(String, String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Delegate(String, String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Detach()()()() | (Inherited from jQueryObject.)
Public method | Detach(String) | (Inherited from jQueryObject.)
Public method | Die()()()() | (Inherited from jQueryObject.)
Public method | Die(String) | (Inherited from jQueryObject.)
Public method | Die(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | DoubleClick()()()() | (Inherited from jQueryObject.)
Public method | DoubleClick(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | DoubleClick(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Each(ElementIterationCallback) | (Inherited from jQueryObject.)
Public method | Each(ElementInterruptibleIterationCallback) | (Inherited from jQueryObject.)
Public method | Empty | (Inherited from jQueryObject.)
Public method | End | (Inherited from jQueryObject.)
Public method | Eq | (Inherited from jQueryObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Error()()()() | (Inherited from jQueryObject.)
Public method | Error(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Error(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FadeIn()()()() | (Inherited from jQueryObject.)
Public method | FadeIn(Int32) | (Inherited from jQueryObject.)
Public method | FadeIn(EffectDuration) | (Inherited from jQueryObject.)
Public method | FadeIn(Int32, Action) | (Inherited from jQueryObject.)
Public method | FadeIn(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | FadeIn(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeIn(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeOut()()()() | (Inherited from jQueryObject.)
Public method | FadeOut(Int32) | (Inherited from jQueryObject.)
Public method | FadeOut(EffectDuration) | (Inherited from jQueryObject.)
Public method | FadeOut(Int32, Action) | (Inherited from jQueryObject.)
Public method | FadeOut(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | FadeOut(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeOut(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(Int32, Double) | (Inherited from jQueryObject.)
Public method | FadeTo(EffectDuration, Double) | (Inherited from jQueryObject.)
Public method | FadeTo(Int32, Double, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(EffectDuration, Double, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(Int32, Double, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(EffectDuration, Double, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeToggle()()()() | (Inherited from jQueryObject.)
Public method | FadeToggle(Int32) | (Inherited from jQueryObject.)
Public method | FadeToggle(EffectDuration) | (Inherited from jQueryObject.)
Public method | FadeToggle(Int32, Action) | (Inherited from jQueryObject.)
Public method | FadeToggle(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | FadeToggle(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Filter(String) | (Inherited from jQueryObject.)
Public method | Filter(ElementFilterCallback) | (Inherited from jQueryObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Element) | (Inherited from jQueryObject.)
Public method | Find(jQueryObject) | (Inherited from jQueryObject.)
Public method | Find(String) | (Inherited from jQueryObject.)
Public method | First | (Inherited from jQueryObject.)
Public method | Focus()()()() | (Inherited from jQueryObject.)
Public method | Focus(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Focus(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FocusIn(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FocusIn(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FocusOut(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FocusOut(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | GetAttribute | (Inherited from jQueryObject.)
Public method | GetCSS | (Inherited from jQueryObject.)
Public method | GetData | (Inherited from jQueryObject.)
Public method | GetDataValue | (Inherited from jQueryObject.)
Public method | GetElement | (Inherited from jQueryObject.)
Public method | GetElements | (Inherited from jQueryObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeight | (Inherited from jQueryObject.)
Public method | GetHtml | (Inherited from jQueryObject.)
Public method | GetInnerHeight | (Inherited from jQueryObject.)
Public method | GetInnerWidth | (Inherited from jQueryObject.)
Public method | GetItem | (Inherited from jQueryObject.)
Public method | GetItems | (Inherited from jQueryObject.)
Public method | GetOffset | (Inherited from jQueryObject.)
Public method | GetOuterHeight()()()() | (Inherited from jQueryObject.)
Public method | GetOuterHeight(Boolean) | (Inherited from jQueryObject.)
Public method | GetOuterWidth()()()() | (Inherited from jQueryObject.)
Public method | GetOuterWidth(Boolean) | (Inherited from jQueryObject.)
Public method | GetProperty | (Inherited from jQueryObject.)
Public method | GetScrollLeft | (Inherited from jQueryObject.)
Public method | GetScrollTop | (Inherited from jQueryObject.)
Public method | GetText | (Inherited from jQueryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Inherited from jQueryObject.)
Public method | GetWidth | (Inherited from jQueryObject.)
Public method | Has(String) | (Inherited from jQueryObject.)
Public method | Has(Element) | (Inherited from jQueryObject.)
Public method | HasClass | (Inherited from jQueryObject.)
Public method | Height(Int32) | (Inherited from jQueryObject.)
Public method | Height(String) | (Inherited from jQueryObject.)
Public method | Hide()()()() | (Inherited from jQueryObject.)
Public method | Hide(Int32) | (Inherited from jQueryObject.)
Public method | Hide(EffectDuration) | (Inherited from jQueryObject.)
Public method | Hide(Int32, Action) | (Inherited from jQueryObject.)
Public method | Hide(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | Hide(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Hide(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Html(String) | (Inherited from jQueryObject.)
Public method | Html(jQueryObject) | (Inherited from jQueryObject.)
Public method | Html(StringFunction) | (Inherited from jQueryObject.)
Public method | Html(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | Index()()()() | (Inherited from jQueryObject.)
Public method | Index(Element) | (Inherited from jQueryObject.)
Public method | Index(String) | (Inherited from jQueryObject.)
Public method | InsertAfter(Element) | (Inherited from jQueryObject.)
Public method | InsertAfter(String) | (Inherited from jQueryObject.)
Public method | InsertAfter(jQueryObject) | (Inherited from jQueryObject.)
Public method | InsertBefore(Element) | (Inherited from jQueryObject.)
Public method | InsertBefore(String) | (Inherited from jQueryObject.)
Public method | InsertBefore(jQueryObject) | (Inherited from jQueryObject.)
Public method | Is(BooleanFunction) | (Inherited from jQueryObject.)
Public method | Is(Element) | (Inherited from jQueryObject.)
Public method | Is(jQueryObject) | (Inherited from jQueryObject.)
Public method | Is(String) | (Inherited from jQueryObject.)
Public method | Keydown()()()() | (Inherited from jQueryObject.)
Public method | Keydown(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keydown(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keypress()()()() | (Inherited from jQueryObject.)
Public method | Keypress(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keypress(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keyup()()()() | (Inherited from jQueryObject.)
Public method | Keyup(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keyup(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Last | (Inherited from jQueryObject.)
Public method | Live(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Live(String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Load(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Load(String) | (Inherited from jQueryObject.)
Public method | Load(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Load(String, Object) | (Inherited from jQueryObject.)
Public method | Load(String, Object, AjaxCallback<(Of <<'(Object>)>>)) | (Inherited from jQueryObject.)
Public method | Load(String, Object, AjaxRequestCallback<(Of <<'(Object>)>>)) | (Inherited from jQueryObject.)
Public method | Map | (Inherited from jQueryObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseDown(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseDown(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseEnter(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseEnter(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseLeave(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseLeave(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseMove(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseMove(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseOut(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseOut(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseOver(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseOver(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseUp(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseUp(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Next()()()() | (Inherited from jQueryObject.)
Public method | Next(String) | (Inherited from jQueryObject.)
Public method | NextAll()()()() | (Inherited from jQueryObject.)
Public method | NextAll(String) | (Inherited from jQueryObject.)
Public method | NextUntil | (Inherited from jQueryObject.)
Public method | Not(Element) | (Inherited from jQueryObject.)
Public method | Not(array<Element>[]()[][]) | (Inherited from jQueryObject.)
Public method | Not(String) | (Inherited from jQueryObject.)
Public method | Not(ElementFilterCallback) | (Inherited from jQueryObject.)
Public method | Offset(jQueryPosition) | (Inherited from jQueryObject.)
Public method | Offset(PositionFunction) | (Inherited from jQueryObject.)
Public method | Offset(PositionReplaceFunction) | (Inherited from jQueryObject.)
Public method | OffsetParent | (Inherited from jQueryObject.)
Public method | One(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | One(String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Parent()()()() | (Inherited from jQueryObject.)
Public method | Parent(String) | (Inherited from jQueryObject.)
Public method | Parents()()()() | (Inherited from jQueryObject.)
Public method | Parents(String) | (Inherited from jQueryObject.)
Public method | ParentsUntil | (Inherited from jQueryObject.)
Public method | Plugin``1 | (Inherited from jQueryObject.)
Public method | Position | (Inherited from jQueryObject.)
Public method | Prepend(String) | (Inherited from jQueryObject.)
Public method | Prepend(Element) | (Inherited from jQueryObject.)
Public method | Prepend(array<Element>[]()[][]) | (Inherited from jQueryObject.)
Public method | Prepend(jQueryObject) | (Inherited from jQueryObject.)
Public method | Prepend(StringFunction) | (Inherited from jQueryObject.)
Public method | Prepend(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | PrependTo(String) | (Inherited from jQueryObject.)
Public method | PrependTo(Element) | (Inherited from jQueryObject.)
Public method | PrependTo(jQueryObject) | (Inherited from jQueryObject.)
Public method | Prev()()()() | (Inherited from jQueryObject.)
Public method | Prev(String) | (Inherited from jQueryObject.)
Public method | PrevAll()()()() | (Inherited from jQueryObject.)
Public method | PrevAll(String) | (Inherited from jQueryObject.)
Public method | PrevUntil | (Inherited from jQueryObject.)
Public method | Promise()()()() | (Inherited from jQueryObject.)
Public method | Promise(String) | (Inherited from jQueryObject.)
Public method | Promise(String, Object) | (Inherited from jQueryObject.)
Public method | Property | (Inherited from jQueryObject.)
Public method | Remove()()()() | (Inherited from jQueryObject.)
Public method | Remove(String) | (Inherited from jQueryObject.)
Public method | RemoveAttr | (Inherited from jQueryObject.)
Public method | RemoveClass()()()() | (Inherited from jQueryObject.)
Public method | RemoveClass(String) | (Inherited from jQueryObject.)
Public method | RemoveClass(StringFunction) | (Inherited from jQueryObject.)
Public method | RemoveClass(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | RemoveData()()()() | (Inherited from jQueryObject.)
Public method | RemoveData(String) | (Inherited from jQueryObject.)
Public method | RemoveProperty | (Inherited from jQueryObject.)
Public method | ReplaceAll | (Inherited from jQueryObject.)
Public method | ReplaceWith(String) | (Inherited from jQueryObject.)
Public method | ReplaceWith(Element) | (Inherited from jQueryObject.)
Public method | ReplaceWith(jQueryObject) | (Inherited from jQueryObject.)
Public method | ReplaceWith(StringFunction) | (Inherited from jQueryObject.)
Public method | Resize(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Resize(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Scroll(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Scroll(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | ScrollLeft | (Inherited from jQueryObject.)
Public method | ScrollTop | (Inherited from jQueryObject.)
Public method | Select()()()() | (Inherited from jQueryObject.)
Public method | Select(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Select(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Serialize | (Inherited from jQueryObject.)
Public method | SerializeArray | (Inherited from jQueryObject.)
Public method | Show()()()() | (Inherited from jQueryObject.)
Public method | Show(Int32) | (Inherited from jQueryObject.)
Public method | Show(EffectDuration) | (Inherited from jQueryObject.)
Public method | Show(Int32, Action) | (Inherited from jQueryObject.)
Public method | Show(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | Show(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Show(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Siblings()()()() | (Inherited from jQueryObject.)
Public method | Siblings(String) | (Inherited from jQueryObject.)
Public method | Size | (Inherited from jQueryObject.)
Public method | Slice(Int32) | (Inherited from jQueryObject.)
Public method | Slice(Int32, Int32) | (Inherited from jQueryObject.)
Public method | SlideDown()()()() | (Inherited from jQueryObject.)
Public method | SlideDown(Int32) | (Inherited from jQueryObject.)
Public method | SlideDown(EffectDuration) | (Inherited from jQueryObject.)
Public method | SlideDown(Int32, Action) | (Inherited from jQueryObject.)
Public method | SlideDown(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | SlideDown(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | SlideDown(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | SlideToggle()()()() | (Inherited from jQueryObject.)
Public method | SlideToggle(Int32) | (Inherited from jQueryObject.)
Public method | SlideToggle(EffectDuration) | (Inherited from jQueryObject.)
Public method | SlideToggle(Int32, Action) | (Inherited from jQueryObject.)
Public method | SlideToggle(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | SlideToggle(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | SlideUp()()()() | (Inherited from jQueryObject.)
Public method | SlideUp(Int32) | (Inherited from jQueryObject.)
Public method | SlideUp(EffectDuration) | (Inherited from jQueryObject.)
Public method | SlideUp(Int32, Action) | (Inherited from jQueryObject.)
Public method | SlideUp(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | SlideUp(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | SlideUp(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Stop()()()() | (Inherited from jQueryObject.)
Public method | Stop(Boolean) | (Inherited from jQueryObject.)
Public method | Stop(Boolean, Boolean) | (Inherited from jQueryObject.)
Public method | Submit()()()() | (Inherited from jQueryObject.)
Public method | Submit(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Submit(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | SwitchClass(String, Boolean) | (Inherited from jQueryObject.)
Public method | SwitchClass(StringFunction, Boolean) | (Inherited from jQueryObject.)
Public method | SwitchClass(StringReplaceFunction, Boolean) | (Inherited from jQueryObject.)
Public method | Text(String) | (Inherited from jQueryObject.)
Public method | Text(StringFunction) | (Inherited from jQueryObject.)
Public method | Text(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | ToArray | (Inherited from jQueryObject.)
Public method | Toggle()()()() | (Inherited from jQueryObject.)
Public method | Toggle(Boolean) | (Inherited from jQueryObject.)
Public method | Toggle(Int32) | (Inherited from jQueryObject.)
Public method | Toggle(EffectDuration) | (Inherited from jQueryObject.)
Public method | Toggle(Int32, Action) | (Inherited from jQueryObject.)
Public method | Toggle(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | Toggle(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Toggle(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | ToggleClass(String) | (Inherited from jQueryObject.)
Public method | ToggleClass(StringFunction) | (Inherited from jQueryObject.)
Public method | ToggleClass(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | treeview | Initializes bookmarks tree.
Public method | Trigger(String) | (Inherited from jQueryObject.)
Public method | Trigger(String, array<Object>[]()[][]) | (Inherited from jQueryObject.)
Public method | TriggerHandler(String) | (Inherited from jQueryObject.)
Public method | TriggerHandler(String, array<Object>[]()[][]) | (Inherited from jQueryObject.)
Public method | Unbind(String) | (Inherited from jQueryObject.)
Public method | Unbind(jQueryEvent) | (Inherited from jQueryObject.)
Public method | Unbind(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Unbind(String, Boolean) | (Inherited from jQueryObject.)
Public method | Undelegate(String) | (Inherited from jQueryObject.)
Public method | Undelegate(String, String) | (Inherited from jQueryObject.)
Public method | Undelegate(String, String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Unload(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Unload(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Unwrap | (Inherited from jQueryObject.)
Public method | Value(String) | (Inherited from jQueryObject.)
Public method | Value(StringFunction) | (Inherited from jQueryObject.)
Public method | Value(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | Width(Int32) | (Inherited from jQueryObject.)
Public method | Width(String) | (Inherited from jQueryObject.)
Public method | Wrap(String) | (Inherited from jQueryObject.)
Public method | Wrap(Element) | (Inherited from jQueryObject.)
Public method | Wrap(jQueryObject) | (Inherited from jQueryObject.)
Public method | Wrap(StringFunction) | (Inherited from jQueryObject.)
Public method | WrapAll(String) | (Inherited from jQueryObject.)
Public method | WrapAll(Element) | (Inherited from jQueryObject.)
Public method | WrapAll(jQueryObject) | (Inherited from jQueryObject.)
Public method | WrapInner(String) | (Inherited from jQueryObject.)
Public method | WrapInner(Element) | (Inherited from jQueryObject.)
Public method | WrapInner(jQueryObject) | (Inherited from jQueryObject.)
Public method | WrapInner(StringFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Add Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Add Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Element) | (Inherited from jQueryObject.)
Public method | Add(array<Element>[]()[][]) | (Inherited from jQueryObject.)
Public method | Add(String) | (Inherited from jQueryObject.)
Public method | Add(String, DocumentInstance) | (Inherited from jQueryObject.)
Public method | Add(String, Element) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


AddClass Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..AddClass Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddClass(String) | (Inherited from jQueryObject.)
Public method | AddClass(StringFunction) | (Inherited from jQueryObject.)
Public method | AddClass(StringReplaceFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


After Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..After Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | After(String) | (Inherited from jQueryObject.)
Public method | After(jQueryObject) | (Inherited from jQueryObject.)
Public method | After(StringFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Animate Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Animate Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Animate(Dictionary) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Int32) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, EffectDuration) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Dictionary) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Int32, EffectEasing) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, EffectDuration, EffectEasing) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Animate(Dictionary, EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Append Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Append Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Append(String) | (Inherited from jQueryObject.)
Public method | Append(Element) | (Inherited from jQueryObject.)
Public method | Append(jQueryObject) | (Inherited from jQueryObject.)
Public method | Append(StringFunction) | (Inherited from jQueryObject.)
Public method | Append(StringReplaceFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


AppendTo Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..AppendTo Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AppendTo(Element) | (Inherited from jQueryObject.)
Public method | AppendTo(String) | (Inherited from jQueryObject.)
Public method | AppendTo(jQueryObject) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Attribute Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Attribute Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Attribute(Dictionary) | (Inherited from jQueryObject.)
Public method | Attribute(StringFunction) | (Inherited from jQueryObject.)
Public method | Attribute(StringReplaceFunction) | (Inherited from jQueryObject.)
Public method | Attribute(String, String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Before Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Before Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Before(String) | (Inherited from jQueryObject.)
Public method | Before(Element) | (Inherited from jQueryObject.)
Public method | Before(jQueryObject) | (Inherited from jQueryObject.)
Public method | Before(StringFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Bind Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Bind Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Bind(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Bind(String, Boolean) | (Inherited from jQueryObject.)
Public method | Bind(String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Blur Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Blur Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Blur()()()() | (Inherited from jQueryObject.)
Public method | Blur(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Blur(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Change Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Change Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Change()()()() | (Inherited from jQueryObject.)
Public method | Change(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Change(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Children Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Children Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Children()()()() | (Inherited from jQueryObject.)
Public method | Children(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Click Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Click Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | (Inherited from jQueryObject.)
Public method | Click(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Click(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Clone Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Clone Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | (Inherited from jQueryObject.)
Public method | Clone(Boolean) | (Inherited from jQueryObject.)
Public method | Clone(Boolean, Boolean) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Closest Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Closest Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Closest(Element) | (Inherited from jQueryObject.)
Public method | Closest(jQueryObject) | (Inherited from jQueryObject.)
Public method | Closest(String) | (Inherited from jQueryObject.)
Public method | Closest(String, Element) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


CSS Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..CSS Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CSS(Dictionary) | (Inherited from jQueryObject.)
Public method | CSS(String, String) | (Inherited from jQueryObject.)
Public method | CSS(String, StringFunction) | (Inherited from jQueryObject.)
Public method | CSS(String, StringReplaceFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Data Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Data Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Data(Dictionary) | (Inherited from jQueryObject.)
Public method | Data(String, Object) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Delegate Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Delegate Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Delegate(String, String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Delegate(String, String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Detach Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Detach Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Detach()()()() | (Inherited from jQueryObject.)
Public method | Detach(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Die Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Die Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Die()()()() | (Inherited from jQueryObject.)
Public method | Die(String) | (Inherited from jQueryObject.)
Public method | Die(String, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DoubleClick Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..DoubleClick Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DoubleClick()()()() | (Inherited from jQueryObject.)
Public method | DoubleClick(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | DoubleClick(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Each Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Each Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Each(ElementIterationCallback) | (Inherited from jQueryObject.)
Public method | Each(ElementInterruptibleIterationCallback) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Error Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Error Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Error()()()() | (Inherited from jQueryObject.)
Public method | Error(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Error(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


FadeIn Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..FadeIn Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FadeIn()()()() | (Inherited from jQueryObject.)
Public method | FadeIn(Int32) | (Inherited from jQueryObject.)
Public method | FadeIn(EffectDuration) | (Inherited from jQueryObject.)
Public method | FadeIn(Int32, Action) | (Inherited from jQueryObject.)
Public method | FadeIn(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | FadeIn(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeIn(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


FadeOut Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..FadeOut Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FadeOut()()()() | (Inherited from jQueryObject.)
Public method | FadeOut(Int32) | (Inherited from jQueryObject.)
Public method | FadeOut(EffectDuration) | (Inherited from jQueryObject.)
Public method | FadeOut(Int32, Action) | (Inherited from jQueryObject.)
Public method | FadeOut(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | FadeOut(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeOut(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


FadeTo Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..FadeTo Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FadeTo(Int32, Double) | (Inherited from jQueryObject.)
Public method | FadeTo(EffectDuration, Double) | (Inherited from jQueryObject.)
Public method | FadeTo(Int32, Double, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(EffectDuration, Double, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(Int32, Double, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | FadeTo(EffectDuration, Double, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


FadeToggle Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..FadeToggle Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FadeToggle()()()() | (Inherited from jQueryObject.)
Public method | FadeToggle(Int32) | (Inherited from jQueryObject.)
Public method | FadeToggle(EffectDuration) | (Inherited from jQueryObject.)
Public method | FadeToggle(Int32, Action) | (Inherited from jQueryObject.)
Public method | FadeToggle(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | FadeToggle(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Filter Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Filter Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Filter(String) | (Inherited from jQueryObject.)
Public method | Filter(ElementFilterCallback) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Find Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Find Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Find(Element) | (Inherited from jQueryObject.)
Public method | Find(jQueryObject) | (Inherited from jQueryObject.)
Public method | Find(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Focus Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Focus Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Focus()()()() | (Inherited from jQueryObject.)
Public method | Focus(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Focus(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


FocusIn Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..FocusIn Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FocusIn(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FocusIn(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


FocusOut Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..FocusOut Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FocusOut(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | FocusOut(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


GetOuterHeight Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..GetOuterHeight Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetOuterHeight()()()() | (Inherited from jQueryObject.)
Public method | GetOuterHeight(Boolean) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


GetOuterWidth Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..GetOuterWidth Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetOuterWidth()()()() | (Inherited from jQueryObject.)
Public method | GetOuterWidth(Boolean) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Has Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Has Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Has(String) | (Inherited from jQueryObject.)
Public method | Has(Element) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Height Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Height Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Height(Int32) | (Inherited from jQueryObject.)
Public method | Height(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Hide Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Hide Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Hide()()()() | (Inherited from jQueryObject.)
Public method | Hide(Int32) | (Inherited from jQueryObject.)
Public method | Hide(EffectDuration) | (Inherited from jQueryObject.)
Public method | Hide(Int32, Action) | (Inherited from jQueryObject.)
Public method | Hide(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | Hide(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Hide(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Html Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Html Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Html(String) | (Inherited from jQueryObject.)
Public method | Html(jQueryObject) | (Inherited from jQueryObject.)
Public method | Html(StringFunction) | (Inherited from jQueryObject.)
Public method | Html(StringReplaceFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Index Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Index Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Index()()()() | (Inherited from jQueryObject.)
Public method | Index(Element) | (Inherited from jQueryObject.)
Public method | Index(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


InsertAfter Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..InsertAfter Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertAfter(Element) | (Inherited from jQueryObject.)
Public method | InsertAfter(String) | (Inherited from jQueryObject.)
Public method | InsertAfter(jQueryObject) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


InsertBefore Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..InsertBefore Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertBefore(Element) | (Inherited from jQueryObject.)
Public method | InsertBefore(String) | (Inherited from jQueryObject.)
Public method | InsertBefore(jQueryObject) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Is Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Is Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Is(BooleanFunction) | (Inherited from jQueryObject.)
Public method | Is(Element) | (Inherited from jQueryObject.)
Public method | Is(jQueryObject) | (Inherited from jQueryObject.)
Public method | Is(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Keydown Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Keydown Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Keydown()()()() | (Inherited from jQueryObject.)
Public method | Keydown(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keydown(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Keypress Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Keypress Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Keypress()()()() | (Inherited from jQueryObject.)
Public method | Keypress(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keypress(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Keyup Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Keyup Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Keyup()()()() | (Inherited from jQueryObject.)
Public method | Keyup(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Keyup(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Live Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Live Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Live(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Live(String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Load Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Load Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Load(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Load(String) | (Inherited from jQueryObject.)
Public method | Load(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Load(String, Object) | (Inherited from jQueryObject.)
Public method | Load(String, Object, AjaxCallback<(Of <<'(Object>)>>)) | (Inherited from jQueryObject.)
Public method | Load(String, Object, AjaxRequestCallback<(Of <<'(Object>)>>)) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


MouseDown Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..MouseDown Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseDown(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseDown(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


MouseEnter Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..MouseEnter Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseEnter(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseEnter(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


MouseLeave Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..MouseLeave Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseLeave(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseLeave(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


MouseMove Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..MouseMove Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseMove(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseMove(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


MouseOut Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..MouseOut Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseOut(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseOut(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


MouseOver Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..MouseOver Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseOver(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseOver(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


MouseUp Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..MouseUp Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseUp(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | MouseUp(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Next Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Next Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | (Inherited from jQueryObject.)
Public method | Next(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NextAll Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..NextAll Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextAll()()()() | (Inherited from jQueryObject.)
Public method | NextAll(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Not Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Not Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Not(Element) | (Inherited from jQueryObject.)
Public method | Not(array<Element>[]()[][]) | (Inherited from jQueryObject.)
Public method | Not(String) | (Inherited from jQueryObject.)
Public method | Not(ElementFilterCallback) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Offset Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Offset Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Offset(jQueryPosition) | (Inherited from jQueryObject.)
Public method | Offset(PositionFunction) | (Inherited from jQueryObject.)
Public method | Offset(PositionReplaceFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


One Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..One Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | One(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | One(String, Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Parent Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Parent Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | (Inherited from jQueryObject.)
Public method | Parent(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Parents Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Parents Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parents()()()() | (Inherited from jQueryObject.)
Public method | Parents(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Prepend Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Prepend Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Prepend(String) | (Inherited from jQueryObject.)
Public method | Prepend(Element) | (Inherited from jQueryObject.)
Public method | Prepend(array<Element>[]()[][]) | (Inherited from jQueryObject.)
Public method | Prepend(jQueryObject) | (Inherited from jQueryObject.)
Public method | Prepend(StringFunction) | (Inherited from jQueryObject.)
Public method | Prepend(StringReplaceFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PrependTo Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..PrependTo Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PrependTo(String) | (Inherited from jQueryObject.)
Public method | PrependTo(Element) | (Inherited from jQueryObject.)
Public method | PrependTo(jQueryObject) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Prev Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Prev Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Prev()()()() | (Inherited from jQueryObject.)
Public method | Prev(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PrevAll Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..PrevAll Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PrevAll()()()() | (Inherited from jQueryObject.)
Public method | PrevAll(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Promise Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Promise Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Promise()()()() | (Inherited from jQueryObject.)
Public method | Promise(String) | (Inherited from jQueryObject.)
Public method | Promise(String, Object) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Remove Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Remove Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove()()()() | (Inherited from jQueryObject.)
Public method | Remove(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


RemoveClass Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..RemoveClass Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveClass()()()() | (Inherited from jQueryObject.)
Public method | RemoveClass(String) | (Inherited from jQueryObject.)
Public method | RemoveClass(StringFunction) | (Inherited from jQueryObject.)
Public method | RemoveClass(StringReplaceFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


RemoveData Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..RemoveData Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveData()()()() | (Inherited from jQueryObject.)
Public method | RemoveData(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ReplaceWith Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..ReplaceWith Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReplaceWith(String) | (Inherited from jQueryObject.)
Public method | ReplaceWith(Element) | (Inherited from jQueryObject.)
Public method | ReplaceWith(jQueryObject) | (Inherited from jQueryObject.)
Public method | ReplaceWith(StringFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Resize Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Resize Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Resize(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Resize(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Scroll Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Scroll Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scroll(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Scroll(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Select Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Select Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | (Inherited from jQueryObject.)
Public method | Select(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Select(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Show Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Show Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | (Inherited from jQueryObject.)
Public method | Show(Int32) | (Inherited from jQueryObject.)
Public method | Show(EffectDuration) | (Inherited from jQueryObject.)
Public method | Show(Int32, Action) | (Inherited from jQueryObject.)
Public method | Show(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | Show(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Show(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Siblings Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Siblings Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Siblings()()()() | (Inherited from jQueryObject.)
Public method | Siblings(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Slice Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Slice Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Slice(Int32) | (Inherited from jQueryObject.)
Public method | Slice(Int32, Int32) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SlideDown Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..SlideDown Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SlideDown()()()() | (Inherited from jQueryObject.)
Public method | SlideDown(Int32) | (Inherited from jQueryObject.)
Public method | SlideDown(EffectDuration) | (Inherited from jQueryObject.)
Public method | SlideDown(Int32, Action) | (Inherited from jQueryObject.)
Public method | SlideDown(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | SlideDown(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | SlideDown(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SlideToggle Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..SlideToggle Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SlideToggle()()()() | (Inherited from jQueryObject.)
Public method | SlideToggle(Int32) | (Inherited from jQueryObject.)
Public method | SlideToggle(EffectDuration) | (Inherited from jQueryObject.)
Public method | SlideToggle(Int32, Action) | (Inherited from jQueryObject.)
Public method | SlideToggle(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | SlideToggle(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SlideUp Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..SlideUp Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SlideUp()()()() | (Inherited from jQueryObject.)
Public method | SlideUp(Int32) | (Inherited from jQueryObject.)
Public method | SlideUp(EffectDuration) | (Inherited from jQueryObject.)
Public method | SlideUp(Int32, Action) | (Inherited from jQueryObject.)
Public method | SlideUp(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | SlideUp(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | SlideUp(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Stop Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Stop Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Stop()()()() | (Inherited from jQueryObject.)
Public method | Stop(Boolean) | (Inherited from jQueryObject.)
Public method | Stop(Boolean, Boolean) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Submit Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Submit Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Submit()()()() | (Inherited from jQueryObject.)
Public method | Submit(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Submit(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SwitchClass Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..SwitchClass Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SwitchClass(String, Boolean) | (Inherited from jQueryObject.)
Public method | SwitchClass(StringFunction, Boolean) | (Inherited from jQueryObject.)
Public method | SwitchClass(StringReplaceFunction, Boolean) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Text Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Text Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Text(String) | (Inherited from jQueryObject.)
Public method | Text(StringFunction) | (Inherited from jQueryObject.)
Public method | Text(StringReplaceFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Toggle Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Toggle Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Toggle()()()() | (Inherited from jQueryObject.)
Public method | Toggle(Boolean) | (Inherited from jQueryObject.)
Public method | Toggle(Int32) | (Inherited from jQueryObject.)
Public method | Toggle(EffectDuration) | (Inherited from jQueryObject.)
Public method | Toggle(Int32, Action) | (Inherited from jQueryObject.)
Public method | Toggle(EffectDuration, Action) | (Inherited from jQueryObject.)
Public method | Toggle(Int32, EffectEasing, Action) | (Inherited from jQueryObject.)
Public method | Toggle(EffectDuration, EffectEasing, Action) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ToggleClass Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..ToggleClass Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToggleClass(String) | (Inherited from jQueryObject.)
Public method | ToggleClass(StringFunction) | (Inherited from jQueryObject.)
Public method | ToggleClass(StringReplaceFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


treeview Method

[image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..treeview Method
DocumentMapjQueryObject Class See Also Send Feedback
Initializes bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public jQueryObject treeview(
    jQueryTreeViewOption option
)
Visual Basic
Public Function treeview ( _
    option As jQueryTreeViewOption _
) As jQueryObject
Visual C++
public:
jQueryObject^ treeview(
    jQueryTreeViewOption^ option
)

Parameters

option
Type: PerpetuumSoft.Reporting.WebViewer.Client.View..::..jQueryTreeViewOption
Options for creation of bookmarks tree.

Return Value

Bookmarks tree object.

See Also

DocumentMapjQueryObject Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Trigger Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Trigger Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Trigger(String) | (Inherited from jQueryObject.)
Public method | Trigger(String, array<Object>[]()[][]) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


TriggerHandler Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..TriggerHandler Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerHandler(String) | (Inherited from jQueryObject.)
Public method | TriggerHandler(String, array<Object>[]()[][]) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Unbind Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Unbind Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Unbind(String) | (Inherited from jQueryObject.)
Public method | Unbind(jQueryEvent) | (Inherited from jQueryObject.)
Public method | Unbind(String, jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Unbind(String, Boolean) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Undelegate Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Undelegate Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Undelegate(String) | (Inherited from jQueryObject.)
Public method | Undelegate(String, String) | (Inherited from jQueryObject.)
Public method | Undelegate(String, String, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Unload Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Unload Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Unload(jQueryEventHandler) | (Inherited from jQueryObject.)
Public method | Unload(Dictionary, jQueryEventHandler) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Value Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Value Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Value(String) | (Inherited from jQueryObject.)
Public method | Value(StringFunction) | (Inherited from jQueryObject.)
Public method | Value(StringReplaceFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Width Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Width Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Width(Int32) | (Inherited from jQueryObject.)
Public method | Width(String) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


Wrap Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..Wrap Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Wrap(String) | (Inherited from jQueryObject.)
Public method | Wrap(Element) | (Inherited from jQueryObject.)
Public method | Wrap(jQueryObject) | (Inherited from jQueryObject.)
Public method | Wrap(StringFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


WrapAll Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..WrapAll Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WrapAll(String) | (Inherited from jQueryObject.)
Public method | WrapAll(Element) | (Inherited from jQueryObject.)
Public method | WrapAll(jQueryObject) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


WrapInner Method

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject..::..WrapInner Method
DocumentMapjQueryObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WrapInner(String) | (Inherited from jQueryObject.)
Public method | WrapInner(Element) | (Inherited from jQueryObject.)
Public method | WrapInner(jQueryObject) | (Inherited from jQueryObject.)
Public method | WrapInner(StringFunction) | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
DocumentMapjQueryObject Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DocumentMapjQueryObject Properties

[image] [image]

SharpShooter Reports.Web
DocumentMapjQueryObject Properties
DocumentMapjQueryObject Class See Also Send Feedback

The DocumentMapjQueryObject type exposes the following members.

Properties

 | Name | Description
Public property | Context | (Inherited from jQueryObject.)
Public property | Item | (Inherited from jQueryObject.)
Public property | Length | (Inherited from jQueryObject.)
Public property | Selector | (Inherited from jQueryObject.)

See Also

DocumentMapjQueryObject Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DocumentMapView Class

[image]

SharpShooter Reports.Web
DocumentMapView Class
Members See Also Send Feedback
Manages creation and display of bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DocumentMapView
Visual Basic
Public Class DocumentMapView
Visual C++
public ref class DocumentMapView

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client.View..::..DocumentMapView

See Also

DocumentMapView Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DocumentMapView Members

[image] [image]

SharpShooter Reports.Web
DocumentMapView Members
DocumentMapView Class Constructors Methods Fields See Also Send Feedback

The DocumentMapView type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentMapView | Creates the PerpetuumSoft.Reporting.WebViewer.Client.View.DocumentMapView class instance.

Methods

 | Name | Description
Public method | ClearContent | Clears content of an element which displays bookmarks tree.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetContent | Converts bookmarks tree from the Xml format into the format for display in the browser and outputs onto web page element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ElementClickEvent | Occurs when a user clicked an element in bookmarks tree.

See Also

DocumentMapView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DocumentMapView Constructor

[image]

SharpShooter Reports.Web
DocumentMapView Constructor
DocumentMapView Class See Also Send Feedback
Creates the PerpetuumSoft.Reporting.WebViewer.Client.View.DocumentMapView class instance.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentMapView(
    Element viewportElement
)
Visual Basic
Public Sub New ( _
    viewportElement As Element _
)
Visual C++
public:
DocumentMapView(
    Element^ viewportElement
)

Parameters

viewportElement
Type: Element
The web page element which is used for output of bookmarks tree.

See Also

DocumentMapView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DocumentMapView Fields

[image] [image]

SharpShooter Reports.Web
DocumentMapView Fields
DocumentMapView Class See Also Send Feedback

The DocumentMapView type exposes the following members.

Fields

 | Name | Description
Public field | ElementClickEvent | Occurs when a user clicked an element in bookmarks tree.

See Also

DocumentMapView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ElementClickEvent Field

[image]

SharpShooter Reports.Web
DocumentMapView..::..ElementClickEvent Field
DocumentMapView Class See Also Send Feedback
Occurs when a user clicked an element in bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentMapElementClickCallback ElementClickEvent
Visual Basic
Public ElementClickEvent As DocumentMapElementClickCallback
Visual C++
public:
DocumentMapElementClickCallback^ ElementClickEvent

See Also

DocumentMapView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DocumentMapView Methods

[image] [image]

SharpShooter Reports.Web
DocumentMapView Methods
DocumentMapView Class See Also Send Feedback

The DocumentMapView type exposes the following members.

Methods

 | Name | Description
Public method | ClearContent | Clears content of an element which displays bookmarks tree.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetContent | Converts bookmarks tree from the Xml format into the format for display in the browser and outputs onto web page element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentMapView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ClearContent Method

[image]

SharpShooter Reports.Web
DocumentMapView..::..ClearContent Method
DocumentMapView Class See Also Send Feedback
Clears content of an element which displays bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ClearContent()
Visual Basic
Public Sub ClearContent
Visual C++
public:
void ClearContent()

See Also

DocumentMapView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetContent Method

[image]

SharpShooter Reports.Web
DocumentMapView..::..SetContent Method
DocumentMapView Class See Also Send Feedback
Converts bookmarks tree from the Xml format into the format for display in the browser and outputs onto web page element.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetContent(
    string xmlDocumentMap
)
Visual Basic
Public Sub SetContent ( _
    xmlDocumentMap As String _
)
Visual C++
public:
void SetContent(
    String^ xmlDocumentMap
)

Parameters

xmlDocumentMap
Type: System..::..String
Bookmarks tree in the Xml format.

See Also

DocumentMapView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


jQueryTreeViewOption Class

[image]

SharpShooter Reports.Web
jQueryTreeViewOption Class
Members See Also Send Feedback
Defines properties needed for display of bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class jQueryTreeViewOption
Visual Basic
Public Class jQueryTreeViewOption
Visual C++
public ref class jQueryTreeViewOption

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client.View..::..jQueryTreeViewOption

See Also

jQueryTreeViewOption Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


jQueryTreeViewOption Members

[image] [image]

SharpShooter Reports.Web
jQueryTreeViewOption Members
jQueryTreeViewOption Class Constructors Methods Fields See Also Send Feedback

The jQueryTreeViewOption type exposes the following members.

Constructors

 | Name | Description
Public method | jQueryTreeViewOption | Initializes a new instance of the jQueryTreeViewOption class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | clickAction | Defines event which occurs when user clicks an element in bookmarks tree.

See Also

jQueryTreeViewOption Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


jQueryTreeViewOption Constructor

[image]

SharpShooter Reports.Web
jQueryTreeViewOption Constructor
jQueryTreeViewOption Class See Also Send Feedback
Initializes a new instance of the jQueryTreeViewOption class

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public jQueryTreeViewOption()
Visual Basic
Public Sub New
Visual C++
public:
jQueryTreeViewOption()

See Also

jQueryTreeViewOption Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


jQueryTreeViewOption Fields

[image] [image]

SharpShooter Reports.Web
jQueryTreeViewOption Fields
jQueryTreeViewOption Class See Also Send Feedback

The jQueryTreeViewOption type exposes the following members.

Fields

 | Name | Description
Public field | clickAction | Defines event which occurs when user clicks an element in bookmarks tree.

See Also

jQueryTreeViewOption Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


clickAction Field

[image]

SharpShooter Reports.Web
jQueryTreeViewOption..::..clickAction Field
jQueryTreeViewOption Class See Also Send Feedback
Defines event which occurs when user clicks an element in bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Action<Element> clickAction
Visual Basic
Public clickAction As Action(Of Element)
Visual C++
public:
Action<Element^>^ clickAction

See Also

jQueryTreeViewOption Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


jQueryTreeViewOption Methods

[image] [image]

SharpShooter Reports.Web
jQueryTreeViewOption Methods
jQueryTreeViewOption Class See Also Send Feedback

The jQueryTreeViewOption type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

jQueryTreeViewOption Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


LoadingIndicator Class

[image]

SharpShooter Reports.Web
LoadingIndicator Class
Members See Also Send Feedback
Used for creation of throbber.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class LoadingIndicator
Visual Basic
Public NotInheritable Class LoadingIndicator
Visual C++
public ref class LoadingIndicator abstract sealed

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client.View..::..LoadingIndicator

See Also

LoadingIndicator Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


LoadingIndicator Members

[image] [image]

SharpShooter Reports.Web
LoadingIndicator Members
LoadingIndicator Class Methods See Also Send Feedback

The LoadingIndicator type exposes the following members.

Methods

Name | Description
CreateDocumentLoadingElement | Creates web page element which displays the process of document loading.
CreatePageLoadingElement | Creates web page element which displays the process of document page loading.

See Also

LoadingIndicator Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


LoadingIndicator Methods

[image] [image]

SharpShooter Reports.Web
LoadingIndicator Methods
LoadingIndicator Class See Also Send Feedback

The LoadingIndicator type exposes the following members.

Methods

Name | Description
CreateDocumentLoadingElement | Creates web page element which displays the process of document loading.
CreatePageLoadingElement | Creates web page element which displays the process of document page loading.

See Also

LoadingIndicator Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


CreateDocumentLoadingElement Method

[image]

SharpShooter Reports.Web
LoadingIndicator..::..CreateDocumentLoadingElement Method
LoadingIndicator Class See Also Send Feedback
Creates web page element which displays the process of document loading.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Element CreateDocumentLoadingElement()
Visual Basic
Public Shared Function CreateDocumentLoadingElement As Element
Visual C++
public:
static Element^ CreateDocumentLoadingElement()

Return Value

A web page element which displays the process of document loading.

See Also

LoadingIndicator Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


CreatePageLoadingElement Method

[image]

SharpShooter Reports.Web
LoadingIndicator..::..CreatePageLoadingElement Method
LoadingIndicator Class See Also Send Feedback
Creates web page element which displays the process of document page loading.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Element CreatePageLoadingElement()
Visual Basic
Public Shared Function CreatePageLoadingElement As Element
Visual C++
public:
static Element^ CreatePageLoadingElement()

Return Value

A web page element which displays the process of document page loading.

See Also

LoadingIndicator Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PageView Class

[image]

SharpShooter Reports.Web
PageView Class
Members See Also Send Feedback
The class which controls report pages display.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PageView : PageViewBase
Visual Basic
Public Class PageView _
    Inherits PageViewBase
Visual C++
public ref class PageView : public PageViewBase

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client.View..::..PageViewBase
PerpetuumSoft.Reporting.WebViewer.Client.View..::..PageView

See Also

PageView Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PageView Members

[image] [image]

SharpShooter Reports.Web
PageView Members
PageView Class Constructors Methods Fields See Also Send Feedback

The PageView type exposes the following members.

Constructors

 | Name | Description
Public method | PageView | Creates the PerpetuumSoft.Reporting.WebViewer.Client.View.PageView class instance.

Methods

 | Name | Description
Public method | DeletePageContent | Deletes the page content. (Overrides PageViewBase..::..DeletePageContent(Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentPageNumber | Returns a number of the current page. (Overrides PageViewBase..::..GetCurrentPageNumber()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeView | Creates page layout in the element for display. (Overrides PageViewBase..::..InitializeView(Element, List<(Of <<'(ElementSizeModel>)>>)).)
Public method | IsFirstPage | Checks if the current page is the first one. (Overrides PageViewBase..::..IsFirstPage()()()().)
Public method | IsLastPage | Checks if the current page is the last one. (Overrides PageViewBase..::..IsLastPage()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NavigateToFirstPage | Navigates to the first report page and sets it as current. (Overrides PageViewBase..::..NavigateToFirstPage()()()().)
Public method | NavigateToLastPage | Navigates to the last report page and sets it as current. (Overrides PageViewBase..::..NavigateToLastPage()()()().)
Public method | NavigateToPage | Navigates to the specified page and sets it as current page. (Overrides PageViewBase..::..NavigateToPage(Int32).)
Public method | NavigateToPageElement | Navigates to the specified page in the specified coordinates and sets it as current. (Overrides PageViewBase..::..NavigateToPageElement(Int32, Single, Single).)
Public method | SetLoadingIndicator | Sets an element which is displayed during the loading. (Overrides PageViewBase..::..SetLoadingIndicator(Element).)
Public method | SetPageContent | Sets page's content. (Overrides PageViewBase..::..SetPageContent(Int32, String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _errorProvider | An object of the ErrorProvider class which provides access to errors which occurs in the component work. (Inherited from PageViewBase.)
Public field | BookmarkClickEvent | Occurs when a link in bookmark is clicked. (Inherited from PageViewBase.)
Public field | CurrentPageNumberChangedEvent | Occurs when a number of the current page is changed. (Inherited from PageViewBase.)
Public field | DisplayedPageChangedEvent | Occurs when page visibility is changed. (Inherited from PageViewBase.)
Public field | HyperlinkClickEvent | Occurs when a link is clicked. (Inherited from PageViewBase.)

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PageView Constructor

[image]

SharpShooter Reports.Web
PageView Constructor
PageView Class See Also Send Feedback
Creates the PerpetuumSoft.Reporting.WebViewer.Client.View.PageView class instance.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageView(
    ErrorProvider errorProvider
)
Visual Basic
Public Sub New ( _
    errorProvider As ErrorProvider _
)
Visual C++
public:
PageView(
    ErrorProvider^ errorProvider
)

Parameters

errorProvider
Type: PerpetuumSoft.Reporting.WebViewer.Client..::..ErrorProvider
The ErrorProvider class object which provides access to an error occurred in the component work.

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PageView Fields

[image] [image]

SharpShooter Reports.Web
PageView Fields
PageView Class See Also Send Feedback

The PageView type exposes the following members.

Fields

 | Name | Description
Protected field | _errorProvider | An object of the ErrorProvider class which provides access to errors which occurs in the component work. (Inherited from PageViewBase.)
Public field | BookmarkClickEvent | Occurs when a link in bookmark is clicked. (Inherited from PageViewBase.)
Public field | CurrentPageNumberChangedEvent | Occurs when a number of the current page is changed. (Inherited from PageViewBase.)
Public field | DisplayedPageChangedEvent | Occurs when page visibility is changed. (Inherited from PageViewBase.)
Public field | HyperlinkClickEvent | Occurs when a link is clicked. (Inherited from PageViewBase.)

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PageView Methods

[image] [image]

SharpShooter Reports.Web
PageView Methods
PageView Class See Also Send Feedback

The PageView type exposes the following members.

Methods

 | Name | Description
Public method | DeletePageContent | Deletes the page content. (Overrides PageViewBase..::..DeletePageContent(Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentPageNumber | Returns a number of the current page. (Overrides PageViewBase..::..GetCurrentPageNumber()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeView | Creates page layout in the element for display. (Overrides PageViewBase..::..InitializeView(Element, List<(Of <<'(ElementSizeModel>)>>)).)
Public method | IsFirstPage | Checks if the current page is the first one. (Overrides PageViewBase..::..IsFirstPage()()()().)
Public method | IsLastPage | Checks if the current page is the last one. (Overrides PageViewBase..::..IsLastPage()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NavigateToFirstPage | Navigates to the first report page and sets it as current. (Overrides PageViewBase..::..NavigateToFirstPage()()()().)
Public method | NavigateToLastPage | Navigates to the last report page and sets it as current. (Overrides PageViewBase..::..NavigateToLastPage()()()().)
Public method | NavigateToPage | Navigates to the specified page and sets it as current page. (Overrides PageViewBase..::..NavigateToPage(Int32).)
Public method | NavigateToPageElement | Navigates to the specified page in the specified coordinates and sets it as current. (Overrides PageViewBase..::..NavigateToPageElement(Int32, Single, Single).)
Public method | SetLoadingIndicator | Sets an element which is displayed during the loading. (Overrides PageViewBase..::..SetLoadingIndicator(Element).)
Public method | SetPageContent | Sets page's content. (Overrides PageViewBase..::..SetPageContent(Int32, String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DeletePageContent Method

[image]

SharpShooter Reports.Web
PageView..::..DeletePageContent Method
PageView Class See Also Send Feedback
Deletes the page content.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void DeletePageContent(
    int pageNumber
)
Visual Basic
Public Overrides Sub DeletePageContent ( _
    pageNumber As Integer _
)
Visual C++
public:
virtual void DeletePageContent(
    int pageNumber
) override

Parameters

pageNumber
Type: System..::..Int32
Page number.

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


GetCurrentPageNumber Method

[image]

SharpShooter Reports.Web
PageView..::..GetCurrentPageNumber Method
PageView Class See Also Send Feedback
Returns a number of the current page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int GetCurrentPageNumber()
Visual Basic
Public Overrides Function GetCurrentPageNumber As Integer
Visual C++
public:
virtual int GetCurrentPageNumber() override

Return Value

Number of a current page.

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


InitializeView Method

[image]

SharpShooter Reports.Web
PageView..::..InitializeView Method
PageView Class See Also Send Feedback
Creates page layout in the element for display.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void InitializeView(
    Element viewportElement,
    List<ElementSizeModel> pageSizes
)
Visual Basic
Public Overrides Sub InitializeView ( _
    viewportElement As Element, _
    pageSizes As List(Of ElementSizeModel) _
)
Visual C++
public:
virtual void InitializeView(
    Element^ viewportElement,
    List<ElementSizeModel^>^ pageSizes
) override

Parameters

viewportElement
Type: Element
An element in which report pages will be displayed.
pageSizes
Type: System.Collections.Generic..::..List <(Of <(<' ElementSizeModel >)>)>
List of pages' sizes.

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


IsFirstPage Method

[image]

SharpShooter Reports.Web
PageView..::..IsFirstPage Method
PageView Class See Also Send Feedback
Checks if the current page is the first one.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool IsFirstPage()
Visual Basic
Public Overrides Function IsFirstPage As Boolean
Visual C++
public:
virtual bool IsFirstPage() override

Return Value

True if the current page is the first one otherwise - false.

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


IsLastPage Method

[image]

SharpShooter Reports.Web
PageView..::..IsLastPage Method
PageView Class See Also Send Feedback
Checks if the current page is the last one.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool IsLastPage()
Visual Basic
Public Overrides Function IsLastPage As Boolean
Visual C++
public:
virtual bool IsLastPage() override

Return Value

True if the current page is the last one otherwise - false.

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToFirstPage Method

[image]

SharpShooter Reports.Web
PageView..::..NavigateToFirstPage Method
PageView Class See Also Send Feedback
Navigates to the first report page and sets it as current.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void NavigateToFirstPage()
Visual Basic
Public Overrides Sub NavigateToFirstPage
Visual C++
public:
virtual void NavigateToFirstPage() override

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToLastPage Method

[image]

SharpShooter Reports.Web
PageView..::..NavigateToLastPage Method
PageView Class See Also Send Feedback
Navigates to the last report page and sets it as current.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void NavigateToLastPage()
Visual Basic
Public Overrides Sub NavigateToLastPage
Visual C++
public:
virtual void NavigateToLastPage() override

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToPage Method

[image]

SharpShooter Reports.Web
PageView..::..NavigateToPage Method
PageView Class See Also Send Feedback
Navigates to the specified page and sets it as current page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void NavigateToPage(
    int pageNumber
)
Visual Basic
Public Overrides Sub NavigateToPage ( _
    pageNumber As Integer _
)
Visual C++
public:
virtual void NavigateToPage(
    int pageNumber
) override

Parameters

pageNumber
Type: System..::..Int32
Page number.

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToPageElement Method

[image]

SharpShooter Reports.Web
PageView..::..NavigateToPageElement Method
PageView Class See Also Send Feedback
Navigates to the specified page in the specified coordinates and sets it as current.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void NavigateToPageElement(
    int pageNumber,
    float x,
    float y
)
Visual Basic
Public Overrides Sub NavigateToPageElement ( _
    pageNumber As Integer, _
    x As Single, _
    y As Single _
)
Visual C++
public:
virtual void NavigateToPageElement(
    int pageNumber,
    float x,
    float y
) override

Parameters

pageNumber
Type: System..::..Int32
Page number.
x
Type: System..::..Single
Horizontal shifting of elements on the page.
y
Type: System..::..Single
Vertical shifting of elements of the page.

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetLoadingIndicator Method

[image]

SharpShooter Reports.Web
PageView..::..SetLoadingIndicator Method
PageView Class See Also Send Feedback
Sets an element which is displayed during the loading.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void SetLoadingIndicator(
    Element indicatorElement
)
Visual Basic
Public Overrides Sub SetLoadingIndicator ( _
    indicatorElement As Element _
)
Visual C++
public:
virtual void SetLoadingIndicator(
    Element^ indicatorElement
) override

Parameters

indicatorElement
Type: Element
Html element.

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetPageContent Method

[image]

SharpShooter Reports.Web
PageView..::..SetPageContent Method
PageView Class See Also Send Feedback
Sets page's content.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void SetPageContent(
    int pageNumber,
    string pageContent
)
Visual Basic
Public Overrides Sub SetPageContent ( _
    pageNumber As Integer, _
    pageContent As String _
)
Visual C++
public:
virtual void SetPageContent(
    int pageNumber,
    String^ pageContent
) override

Parameters

pageNumber
Type: System..::..Int32
Page number.
pageContent
Type: System..::..String
Page content.

See Also

PageView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PageViewBase Class

[image]

SharpShooter Reports.Web
PageViewBase Class
Members See Also Send Feedback
Abstract basic class of pages display.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class PageViewBase
Visual Basic
Public MustInherit Class PageViewBase
Visual C++
public ref class PageViewBase abstract

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client.View..::..PageViewBase
PerpetuumSoft.Reporting.WebViewer.Client.View..::..PageView

See Also

PageViewBase Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PageViewBase Members

[image] [image]

SharpShooter Reports.Web
PageViewBase Members
PageViewBase Class Constructors Methods Fields See Also Send Feedback

The PageViewBase type exposes the following members.

Constructors

 | Name | Description
Protected method | PageViewBase | Initializes a new instance of the PageViewBase class

Methods

 | Name | Description
Public method | DeletePageContent | Deletes the page content.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentPageNumber | Returns a number of the current page.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeView | Creates page layout in the element for display.
Public method | IsFirstPage | Checks if the current page is the first one.
Public method | IsLastPage | Checks if the current page is the last one.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NavigateToFirstPage | Navigates to the first report page and sets it as current.
Public method | NavigateToLastPage | Navigates to the last report page and sets it as current.
Public method | NavigateToPage | Navigates to the specified page and sets it as current page.
Public method | NavigateToPageElement | Navigates to the specified page in the specified coordinates and sets it as current.
Public method | SetLoadingIndicator | Sets an element which is displayed during the loading.
Public method | SetPageContent | Sets page's content.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _errorProvider | An object of the ErrorProvider class which provides access to errors which occurs in the component work.
Public field | BookmarkClickEvent | Occurs when a link in bookmark is clicked.
Public field | CurrentPageNumberChangedEvent | Occurs when a number of the current page is changed.
Public field | DisplayedPageChangedEvent | Occurs when page visibility is changed.
Public field | HyperlinkClickEvent | Occurs when a link is clicked.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PageViewBase Constructor

[image]

SharpShooter Reports.Web
PageViewBase Constructor
PageViewBase Class See Also Send Feedback
Initializes a new instance of the PageViewBase class

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected PageViewBase()
Visual Basic
Protected Sub New
Visual C++
protected:
PageViewBase()

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PageViewBase Fields

[image] [image]

SharpShooter Reports.Web
PageViewBase Fields
PageViewBase Class See Also Send Feedback

The PageViewBase type exposes the following members.

Fields

 | Name | Description
Protected field | _errorProvider | An object of the ErrorProvider class which provides access to errors which occurs in the component work.
Public field | BookmarkClickEvent | Occurs when a link in bookmark is clicked.
Public field | CurrentPageNumberChangedEvent | Occurs when a number of the current page is changed.
Public field | DisplayedPageChangedEvent | Occurs when page visibility is changed.
Public field | HyperlinkClickEvent | Occurs when a link is clicked.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


_errorProvider Field

[image]

SharpShooter Reports.Web
PageViewBase..::.._errorProvider Field
PageViewBase Class See Also Send Feedback
An object of the ErrorProvider class which provides access to errors which occurs in the component work.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ErrorProvider _errorProvider
Visual Basic
Protected _errorProvider As ErrorProvider
Visual C++
protected:
ErrorProvider^ _errorProvider

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


BookmarkClickEvent Field

[image]

SharpShooter Reports.Web
PageViewBase..::..BookmarkClickEvent Field
PageViewBase Class See Also Send Feedback
Occurs when a link in bookmark is clicked.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HyperlinkCallback BookmarkClickEvent
Visual Basic
Public BookmarkClickEvent As HyperlinkCallback
Visual C++
public:
HyperlinkCallback^ BookmarkClickEvent

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


CurrentPageNumberChangedEvent Field

[image]

SharpShooter Reports.Web
PageViewBase..::..CurrentPageNumberChangedEvent Field
PageViewBase Class See Also Send Feedback
Occurs when a number of the current page is changed.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageCallback CurrentPageNumberChangedEvent
Visual Basic
Public CurrentPageNumberChangedEvent As PageCallback
Visual C++
public:
PageCallback^ CurrentPageNumberChangedEvent

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DisplayedPageChangedEvent Field

[image]

SharpShooter Reports.Web
PageViewBase..::..DisplayedPageChangedEvent Field
PageViewBase Class See Also Send Feedback
Occurs when page visibility is changed.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageCallback DisplayedPageChangedEvent
Visual Basic
Public DisplayedPageChangedEvent As PageCallback
Visual C++
public:
PageCallback^ DisplayedPageChangedEvent

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


HyperlinkClickEvent Field

[image]

SharpShooter Reports.Web
PageViewBase..::..HyperlinkClickEvent Field
PageViewBase Class See Also Send Feedback
Occurs when a link is clicked.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public jQueryEventHandler HyperlinkClickEvent
Visual Basic
Public HyperlinkClickEvent As jQueryEventHandler
Visual C++
public:
jQueryEventHandler^ HyperlinkClickEvent

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PageViewBase Methods

[image] [image]

SharpShooter Reports.Web
PageViewBase Methods
PageViewBase Class See Also Send Feedback

The PageViewBase type exposes the following members.

Methods

 | Name | Description
Public method | DeletePageContent | Deletes the page content.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentPageNumber | Returns a number of the current page.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeView | Creates page layout in the element for display.
Public method | IsFirstPage | Checks if the current page is the first one.
Public method | IsLastPage | Checks if the current page is the last one.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NavigateToFirstPage | Navigates to the first report page and sets it as current.
Public method | NavigateToLastPage | Navigates to the last report page and sets it as current.
Public method | NavigateToPage | Navigates to the specified page and sets it as current page.
Public method | NavigateToPageElement | Navigates to the specified page in the specified coordinates and sets it as current.
Public method | SetLoadingIndicator | Sets an element which is displayed during the loading.
Public method | SetPageContent | Sets page's content.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DeletePageContent Method

[image]

SharpShooter Reports.Web
PageViewBase..::..DeletePageContent Method
PageViewBase Class See Also Send Feedback
Deletes the page content.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void DeletePageContent(
    int pageNumber
)
Visual Basic
Public MustOverride Sub DeletePageContent ( _
    pageNumber As Integer _
)
Visual C++
public:
virtual void DeletePageContent(
    int pageNumber
) abstract

Parameters

pageNumber
Type: System..::..Int32
Page number.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


GetCurrentPageNumber Method

[image]

SharpShooter Reports.Web
PageViewBase..::..GetCurrentPageNumber Method
PageViewBase Class See Also Send Feedback
Returns a number of the current page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract int GetCurrentPageNumber()
Visual Basic
Public MustOverride Function GetCurrentPageNumber As Integer
Visual C++
public:
virtual int GetCurrentPageNumber() abstract

Return Value

Number of a current page.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


InitializeView Method

[image]

SharpShooter Reports.Web
PageViewBase..::..InitializeView Method
PageViewBase Class See Also Send Feedback
Creates page layout in the element for display.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void InitializeView(
    Element viewportElement,
    List<ElementSizeModel> pageSizes
)
Visual Basic
Public MustOverride Sub InitializeView ( _
    viewportElement As Element, _
    pageSizes As List(Of ElementSizeModel) _
)
Visual C++
public:
virtual void InitializeView(
    Element^ viewportElement,
    List<ElementSizeModel^>^ pageSizes
) abstract

Parameters

viewportElement
Type: Element
An element in which report pages will be displayed.
pageSizes
Type: System.Collections.Generic..::..List <(Of <(<' ElementSizeModel >)>)>
List of pages' sizes.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


IsFirstPage Method

[image]

SharpShooter Reports.Web
PageViewBase..::..IsFirstPage Method
PageViewBase Class See Also Send Feedback
Checks if the current page is the first one.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract bool IsFirstPage()
Visual Basic
Public MustOverride Function IsFirstPage As Boolean
Visual C++
public:
virtual bool IsFirstPage() abstract

Return Value

True if the current page is the first one otherwise - false.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


IsLastPage Method

[image]

SharpShooter Reports.Web
PageViewBase..::..IsLastPage Method
PageViewBase Class See Also Send Feedback
Checks if the current page is the last one.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract bool IsLastPage()
Visual Basic
Public MustOverride Function IsLastPage As Boolean
Visual C++
public:
virtual bool IsLastPage() abstract

Return Value

True if the current page is the last one otherwise - false.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToFirstPage Method

[image]

SharpShooter Reports.Web
PageViewBase..::..NavigateToFirstPage Method
PageViewBase Class See Also Send Feedback
Navigates to the first report page and sets it as current.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void NavigateToFirstPage()
Visual Basic
Public MustOverride Sub NavigateToFirstPage
Visual C++
public:
virtual void NavigateToFirstPage() abstract

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToLastPage Method

[image]

SharpShooter Reports.Web
PageViewBase..::..NavigateToLastPage Method
PageViewBase Class See Also Send Feedback
Navigates to the last report page and sets it as current.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void NavigateToLastPage()
Visual Basic
Public MustOverride Sub NavigateToLastPage
Visual C++
public:
virtual void NavigateToLastPage() abstract

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToPage Method

[image]

SharpShooter Reports.Web
PageViewBase..::..NavigateToPage Method
PageViewBase Class See Also Send Feedback
Navigates to the specified page and sets it as current page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void NavigateToPage(
    int pageNumber
)
Visual Basic
Public MustOverride Sub NavigateToPage ( _
    pageNumber As Integer _
)
Visual C++
public:
virtual void NavigateToPage(
    int pageNumber
) abstract

Parameters

pageNumber
Type: System..::..Int32
Page number.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToPageElement Method

[image]

SharpShooter Reports.Web
PageViewBase..::..NavigateToPageElement Method
PageViewBase Class See Also Send Feedback
Navigates to the specified page in the specified coordinates and sets it as current.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void NavigateToPageElement(
    int pageNumber,
    float x,
    float y
)
Visual Basic
Public MustOverride Sub NavigateToPageElement ( _
    pageNumber As Integer, _
    x As Single, _
    y As Single _
)
Visual C++
public:
virtual void NavigateToPageElement(
    int pageNumber,
    float x,
    float y
) abstract

Parameters

pageNumber
Type: System..::..Int32
Page number.
x
Type: System..::..Single
Horizontal shifting of elements on the page.
y
Type: System..::..Single
Vertical shifting of elements of the page.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetLoadingIndicator Method

[image]

SharpShooter Reports.Web
PageViewBase..::..SetLoadingIndicator Method
PageViewBase Class See Also Send Feedback
Sets an element which is displayed during the loading.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void SetLoadingIndicator(
    Element indicatorElement
)
Visual Basic
Public MustOverride Sub SetLoadingIndicator ( _
    indicatorElement As Element _
)
Visual C++
public:
virtual void SetLoadingIndicator(
    Element^ indicatorElement
) abstract

Parameters

indicatorElement
Type: Element
Html element.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetPageContent Method

[image]

SharpShooter Reports.Web
PageViewBase..::..SetPageContent Method
PageViewBase Class See Also Send Feedback
Sets page's content.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void SetPageContent(
    int pageNumber,
    string pageContent
)
Visual Basic
Public MustOverride Sub SetPageContent ( _
    pageNumber As Integer, _
    pageContent As String _
)
Visual C++
public:
virtual void SetPageContent(
    int pageNumber,
    String^ pageContent
) abstract

Parameters

pageNumber
Type: System..::..Int32
Page number.
pageContent
Type: System..::..String
Page content.

See Also

PageViewBase Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ThumbnailsView Class

[image]

SharpShooter Reports.Web
ThumbnailsView Class
Members See Also Send Feedback
Manages creation and display of thumbnails.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ThumbnailsView
Visual Basic
Public Class ThumbnailsView
Visual C++
public ref class ThumbnailsView

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client.View..::..ThumbnailsView

See Also

ThumbnailsView Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ThumbnailsView Members

[image] [image]

SharpShooter Reports.Web
ThumbnailsView Members
ThumbnailsView Class Constructors Methods Fields See Also Send Feedback

The ThumbnailsView type exposes the following members.

Constructors

 | Name | Description
Public method | ThumbnailsView | Creates the PerpetuumSoft.Reporting.WebViewer.Client.View.ThumbnailsView class instance.

Methods

 | Name | Description
Public method | ClearContent | ThumbnailsView.ClearContent
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetContent | Sets and outputs thumbnails into the specified element.
Public method | SetInvisibleThumbnailCacheSize | Sets the number of thumbnails, which will be loaded before and after the visible thumbnails.
Public method | SetSelected | Sets selected element in thumbnails.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ElementClickEvent | Occurs when a user clicks thumbnail.

See Also

ThumbnailsView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ThumbnailsView Constructor

[image]

SharpShooter Reports.Web
ThumbnailsView Constructor
ThumbnailsView Class See Also Send Feedback
Creates the PerpetuumSoft.Reporting.WebViewer.Client.View.ThumbnailsView class instance.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThumbnailsView(
    Element viewportElement
)
Visual Basic
Public Sub New ( _
    viewportElement As Element _
)
Visual C++
public:
ThumbnailsView(
    Element^ viewportElement
)

Parameters

viewportElement
Type: Element
The web page element which will be used for output of thumbnails.

See Also

ThumbnailsView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ThumbnailsView Fields

[image] [image]

SharpShooter Reports.Web
ThumbnailsView Fields
ThumbnailsView Class See Also Send Feedback

The ThumbnailsView type exposes the following members.

Fields

 | Name | Description
Public field | ElementClickEvent | Occurs when a user clicks thumbnail.

See Also

ThumbnailsView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ElementClickEvent Field

[image]

SharpShooter Reports.Web
ThumbnailsView..::..ElementClickEvent Field
ThumbnailsView Class See Also Send Feedback
Occurs when a user clicks thumbnail.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageCallback ElementClickEvent
Visual Basic
Public ElementClickEvent As PageCallback
Visual C++
public:
PageCallback^ ElementClickEvent

See Also

ThumbnailsView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ThumbnailsView Methods

[image] [image]

SharpShooter Reports.Web
ThumbnailsView Methods
ThumbnailsView Class See Also Send Feedback

The ThumbnailsView type exposes the following members.

Methods

 | Name | Description
Public method | ClearContent | ThumbnailsView.ClearContent
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetContent | Sets and outputs thumbnails into the specified element.
Public method | SetInvisibleThumbnailCacheSize | Sets the number of thumbnails, which will be loaded before and after the visible thumbnails.
Public method | SetSelected | Sets selected element in thumbnails.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThumbnailsView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ClearContent Method

[image]

SharpShooter Reports.Web
ThumbnailsView..::..ClearContent Method
ThumbnailsView Class See Also Send Feedback
ThumbnailsView.ClearContent

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ClearContent()
Visual Basic
Public Sub ClearContent
Visual C++
public:
void ClearContent()

See Also

ThumbnailsView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetContent Method

[image]

SharpShooter Reports.Web
ThumbnailsView..::..SetContent Method
ThumbnailsView Class See Also Send Feedback
Sets and outputs thumbnails into the specified element.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetContent(
    List<string> thumbnailLinks
)
Visual Basic
Public Sub SetContent ( _
    thumbnailLinks As List(Of String) _
)
Visual C++
public:
void SetContent(
    List<String^>^ thumbnailLinks
)

Parameters

thumbnailLinks
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
List of links for thumbnails.

See Also

ThumbnailsView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetInvisibleThumbnailCacheSize Method

[image]

SharpShooter Reports.Web
ThumbnailsView..::..SetInvisibleThumbnailCacheSize Method
ThumbnailsView Class See Also Send Feedback
Sets the number of thumbnails, which will be loaded before and after the visible thumbnails.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetInvisibleThumbnailCacheSize(
    int invisibleCacheSize
)
Visual Basic
Public Sub SetInvisibleThumbnailCacheSize ( _
    invisibleCacheSize As Integer _
)
Visual C++
public:
void SetInvisibleThumbnailCacheSize(
    int invisibleCacheSize
)

Parameters

invisibleCacheSize
Type: System..::..Int32

[Missing <param name="invisibleCacheSize"/> documentation for "M:PerpetuumSoft.Reporting.WebViewer.Client.View.ThumbnailsView.SetInvisibleThumbnailCacheSize(System.Int32)"]

See Also

ThumbnailsView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetSelected Method

[image]

SharpShooter Reports.Web
ThumbnailsView..::..SetSelected Method
ThumbnailsView Class See Also Send Feedback
Sets selected element in thumbnails.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetSelected(
    int pageNumber
)
Visual Basic
Public Sub SetSelected ( _
    pageNumber As Integer _
)
Visual C++
public:
void SetSelected(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
A number of a page which thumbnail should be selected.

See Also

ThumbnailsView Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ViewManager Class

[image]

SharpShooter Reports.Web
ViewManager Class
Members See Also Send Feedback
The class which manages the display of pages.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ViewManager
Visual Basic
Public Class ViewManager
Visual C++
public ref class ViewManager

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Client.View..::..ViewManager

See Also

ViewManager Members
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ViewManager Members

[image] [image]

SharpShooter Reports.Web
ViewManager Members
ViewManager Class Constructors Methods Fields See Also Send Feedback

The ViewManager type exposes the following members.

Constructors

 | Name | Description
Public method | ViewManager | Initializes an object of the PerpetuumSoft.Reporting.WebViewer.Client.View.ViewManager class.

Methods

 | Name | Description
Public method | DeletePageContent | Deletes the page content.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentPageNumber | Returns a number of the current page.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeView | Creates page layout in the element for display.
Public method | IsFirstPage | Checks if the current page is the first one.
Public method | IsLastPage | Checks if the current page is the last one.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NavigateToFirstPage | Navigates to the first report page and sets it as current.
Public method | NavigateToLastPage | Navigates to the last report page and sets it as current.
Public method | NavigateToPage | Navigates to the specified page and sets it as current page.
Public method | NavigateToPageElement | Navigates to the specified page in the specified coordinates and sets it as current.
Public method | SetLoadingIndicator | Sets an element which is displayed during the loading.
Public method | SetPageContent | Sets page's content.
Public method | SetPageView | Sets report pages view model.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | BookmarkClickEvent | Occurs when a link in bookmark is clicked.
Public field | CurrentPageNumberChangedEvent | Occurs when a number of the current page is changed.
Public field | DisplayedPageChangedEvent | Occurs when page visibility is changed.
Public field | HyperlinkClickEvent | Occurs when a link is clicked.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ViewManager Constructor

[image]

SharpShooter Reports.Web
ViewManager Constructor
ViewManager Class See Also Send Feedback
Initializes an object of the PerpetuumSoft.Reporting.WebViewer.Client.View.ViewManager class.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ViewManager(
    Element viewportElement
)
Visual Basic
Public Sub New ( _
    viewportElement As Element _
)
Visual C++
public:
ViewManager(
    Element^ viewportElement
)

Parameters

viewportElement
Type: Element
An element in which report pages will be displayed.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ViewManager Fields

[image] [image]

SharpShooter Reports.Web
ViewManager Fields
ViewManager Class See Also Send Feedback

The ViewManager type exposes the following members.

Fields

 | Name | Description
Public field | BookmarkClickEvent | Occurs when a link in bookmark is clicked.
Public field | CurrentPageNumberChangedEvent | Occurs when a number of the current page is changed.
Public field | DisplayedPageChangedEvent | Occurs when page visibility is changed.
Public field | HyperlinkClickEvent | Occurs when a link is clicked.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


BookmarkClickEvent Field

[image]

SharpShooter Reports.Web
ViewManager..::..BookmarkClickEvent Field
ViewManager Class See Also Send Feedback
Occurs when a link in bookmark is clicked.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HyperlinkCallback BookmarkClickEvent
Visual Basic
Public BookmarkClickEvent As HyperlinkCallback
Visual C++
public:
HyperlinkCallback^ BookmarkClickEvent

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


CurrentPageNumberChangedEvent Field

[image]

SharpShooter Reports.Web
ViewManager..::..CurrentPageNumberChangedEvent Field
ViewManager Class See Also Send Feedback
Occurs when a number of the current page is changed.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageCallback CurrentPageNumberChangedEvent
Visual Basic
Public CurrentPageNumberChangedEvent As PageCallback
Visual C++
public:
PageCallback^ CurrentPageNumberChangedEvent

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DisplayedPageChangedEvent Field

[image]

SharpShooter Reports.Web
ViewManager..::..DisplayedPageChangedEvent Field
ViewManager Class See Also Send Feedback
Occurs when page visibility is changed.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageCallback DisplayedPageChangedEvent
Visual Basic
Public DisplayedPageChangedEvent As PageCallback
Visual C++
public:
PageCallback^ DisplayedPageChangedEvent

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


HyperlinkClickEvent Field

[image]

SharpShooter Reports.Web
ViewManager..::..HyperlinkClickEvent Field
ViewManager Class See Also Send Feedback
Occurs when a link is clicked.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HyperlinkCallback HyperlinkClickEvent
Visual Basic
Public HyperlinkClickEvent As HyperlinkCallback
Visual C++
public:
HyperlinkCallback^ HyperlinkClickEvent

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


ViewManager Methods

[image] [image]

SharpShooter Reports.Web
ViewManager Methods
ViewManager Class See Also Send Feedback

The ViewManager type exposes the following members.

Methods

 | Name | Description
Public method | DeletePageContent | Deletes the page content.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentPageNumber | Returns a number of the current page.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeView | Creates page layout in the element for display.
Public method | IsFirstPage | Checks if the current page is the first one.
Public method | IsLastPage | Checks if the current page is the last one.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NavigateToFirstPage | Navigates to the first report page and sets it as current.
Public method | NavigateToLastPage | Navigates to the last report page and sets it as current.
Public method | NavigateToPage | Navigates to the specified page and sets it as current page.
Public method | NavigateToPageElement | Navigates to the specified page in the specified coordinates and sets it as current.
Public method | SetLoadingIndicator | Sets an element which is displayed during the loading.
Public method | SetPageContent | Sets page's content.
Public method | SetPageView | Sets report pages view model.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


DeletePageContent Method

[image]

SharpShooter Reports.Web
ViewManager..::..DeletePageContent Method
ViewManager Class See Also Send Feedback
Deletes the page content.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void DeletePageContent(
    int pageNumber
)
Visual Basic
Public Sub DeletePageContent ( _
    pageNumber As Integer _
)
Visual C++
public:
void DeletePageContent(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
Page number.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


GetCurrentPageNumber Method

[image]

SharpShooter Reports.Web
ViewManager..::..GetCurrentPageNumber Method
ViewManager Class See Also Send Feedback
Returns a number of the current page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int GetCurrentPageNumber()
Visual Basic
Public Function GetCurrentPageNumber As Integer
Visual C++
public:
int GetCurrentPageNumber()

Return Value

Number of a current page.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


InitializeView Method

[image]

SharpShooter Reports.Web
ViewManager..::..InitializeView Method
ViewManager Class See Also Send Feedback
Creates page layout in the element for display.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitializeView(
    List<ElementSizeModel> pages
)
Visual Basic
Public Sub InitializeView ( _
    pages As List(Of ElementSizeModel) _
)
Visual C++
public:
void InitializeView(
    List<ElementSizeModel^>^ pages
)

Parameters

pages
Type: System.Collections.Generic..::..List <(Of <(<' ElementSizeModel >)>)>
Data about pages' sizes.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


IsFirstPage Method

[image]

SharpShooter Reports.Web
ViewManager..::..IsFirstPage Method
ViewManager Class See Also Send Feedback
Checks if the current page is the first one.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsFirstPage()
Visual Basic
Public Function IsFirstPage As Boolean
Visual C++
public:
bool IsFirstPage()

Return Value

True if the current page is the first one otherwise - false.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


IsLastPage Method

[image]

SharpShooter Reports.Web
ViewManager..::..IsLastPage Method
ViewManager Class See Also Send Feedback
Checks if the current page is the last one.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsLastPage()
Visual Basic
Public Function IsLastPage As Boolean
Visual C++
public:
bool IsLastPage()

Return Value

True if the current page is the last one otherwise - false.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToFirstPage Method

[image]

SharpShooter Reports.Web
ViewManager..::..NavigateToFirstPage Method
ViewManager Class See Also Send Feedback
Navigates to the first report page and sets it as current.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void NavigateToFirstPage()
Visual Basic
Public Sub NavigateToFirstPage
Visual C++
public:
void NavigateToFirstPage()

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToLastPage Method

[image]

SharpShooter Reports.Web
ViewManager..::..NavigateToLastPage Method
ViewManager Class See Also Send Feedback
Navigates to the last report page and sets it as current.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void NavigateToLastPage()
Visual Basic
Public Sub NavigateToLastPage
Visual C++
public:
void NavigateToLastPage()

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToPage Method

[image]

SharpShooter Reports.Web
ViewManager..::..NavigateToPage Method
ViewManager Class See Also Send Feedback
Navigates to the specified page and sets it as current page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void NavigateToPage(
    int pageNumber
)
Visual Basic
Public Sub NavigateToPage ( _
    pageNumber As Integer _
)
Visual C++
public:
void NavigateToPage(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
Page number.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


NavigateToPageElement Method

[image]

SharpShooter Reports.Web
ViewManager..::..NavigateToPageElement Method
ViewManager Class See Also Send Feedback
Navigates to the specified page in the specified coordinates and sets it as current.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void NavigateToPageElement(
    int pageNumber,
    float x,
    float y
)
Visual Basic
Public Sub NavigateToPageElement ( _
    pageNumber As Integer, _
    x As Single, _
    y As Single _
)
Visual C++
public:
void NavigateToPageElement(
    int pageNumber,
    float x,
    float y
)

Parameters

pageNumber
Type: System..::..Int32
Page number.
x
Type: System..::..Single
Horizontal shifting of elements on the page.
y
Type: System..::..Single
Vertical shifting of elements of the page.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetLoadingIndicator Method

[image]

SharpShooter Reports.Web
ViewManager..::..SetLoadingIndicator Method
ViewManager Class See Also Send Feedback
Sets an element which is displayed during the loading.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetLoadingIndicator(
    Element indicatorElement
)
Visual Basic
Public Sub SetLoadingIndicator ( _
    indicatorElement As Element _
)
Visual C++
public:
void SetLoadingIndicator(
    Element^ indicatorElement
)

Parameters

indicatorElement
Type: Element
Html element.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetPageContent Method

[image]

SharpShooter Reports.Web
ViewManager..::..SetPageContent Method
ViewManager Class See Also Send Feedback
Sets page's content.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetPageContent(
    int pageNumber,
    string pageContent
)
Visual Basic
Public Sub SetPageContent ( _
    pageNumber As Integer, _
    pageContent As String _
)
Visual C++
public:
void SetPageContent(
    int pageNumber,
    String^ pageContent
)

Parameters

pageNumber
Type: System..::..Int32
Page number.
pageContent
Type: System..::..String
Page content.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


SetPageView Method

[image]

SharpShooter Reports.Web
ViewManager..::..SetPageView Method
ViewManager Class See Also Send Feedback
Sets report pages view model.

Namespace: PerpetuumSoft.Reporting.WebViewer.Client.View
Assembly: PerpetuumSoft.Reporting.WebViewer.Client (in PerpetuumSoft.Reporting.WebViewer.Client.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetPageView(
    PageViewBase pageView
)
Visual Basic
Public Sub SetPageView ( _
    pageView As PageViewBase _
)
Visual C++
public:
void SetPageView(
    PageViewBase^ pageView
)

Parameters

pageView
Type: PerpetuumSoft.Reporting.WebViewer.Client.View..::..PageViewBase
Pages view model.

See Also

ViewManager Class
PerpetuumSoft.Reporting.WebViewer.Client.View Namespace


PerpetuumSoft.Reporting.WebViewer.Model Namespace

[image]

SharpShooter Reports.Web
PerpetuumSoft.Reporting.WebViewer.Model Namespace
Send Feedback
Represents data model.

Classes

 | Class | Description
Public class | BaseResponseModel | Base class represents a data which to send to the client.
Public class | BookmarkInfo | Represents information about location of a bookmark on a page
Public class | DocumentIdModel | Represent a document identifier information.
Public class | DocumentInfoModel | Represent a document data.
Public class | DocumentMapInfoModel | Represent a document map.
Public class | ElementSizeModel | Represent size of a report elements and a page size.
Public class | ErrorInfoModel | Represent a error data.
Public class | FullRequest | Contains data for report rendering.
Public class | LoadDocumentInfoRequest | Contains client request body with a report name and a parameter list.
Public class | LoadDocumentInfoResponse | Contains server response body with a document data.
Public class | LoadDocumentMapInfoFullRequest | Contains data for report rendering and getting data about bookmarks tree.
Public class | LoadDocumentMapInfoRequest | Contains client request body with a document identifier.
Public class | LoadDocumentMapInfoResponse | Contains server response body with a document map data.
Public class | LoadPageInfoFullRequest | Contains data for report rendering and getting data about a page.
Public class | LoadPageInfoRequest | Contains client request body with a document identifier and a page number.
Public class | LoadPageInfoResponse | Contains server response body with a page data.
Public class | LoadReportParametersRequest | Contains client request body with a report name.
Public class | LoadReportParametersResponse | Contains server response body with a parameters list from report.
Public class | LoadThumbnailsInfoFullRequest | Contains data for report rendering and getting data about thumbnails link collection.
Public class | LoadThumbnailsInfoRequest | Contains client request body with a document identifier and thumbnails size.
Public class | LoadThumbnailsInfoResponse | Contains server response body with thumbnail data.
Public class | PageInfoModel | Represent a page data.
Public class | ParameterModel | Represent a parameter data.
Public class | ReportParametersModel | Contains client request body with a parameter list from a report.
Public class | ThumbnailsInfoModel | Represent a thumbnail data.
Public class | ThumbnailSizeModel | Represent a thumbnails size.

Enumerations

 | Enumeration | Description
Public enumeration | ExceptionType | Represent a error type.


BaseResponseModel Class

[image]

SharpShooter Reports.Web
BaseResponseModel Class
Members See Also Send Feedback
Base class represents a data which to send to the client.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BaseResponseModel
Visual Basic
Public Class BaseResponseModel
Visual C++
public ref class BaseResponseModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..BaseResponseModel
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentInfoResponse
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentMapInfoResponse
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadPageInfoResponse
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadReportParametersResponse
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadThumbnailsInfoResponse

See Also

BaseResponseModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


BaseResponseModel Members

[image] [image]

SharpShooter Reports.Web
BaseResponseModel Members
BaseResponseModel Class Constructors Methods Fields See Also Send Feedback

The BaseResponseModel type exposes the following members.

Constructors

 | Name | Description
Public method | BaseResponseModel | Initializes a new instance of the BaseResponseModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Error |

See Also

BaseResponseModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


BaseResponseModel Constructor

[image]

SharpShooter Reports.Web
BaseResponseModel Constructor
BaseResponseModel Class See Also Send Feedback
Initializes a new instance of the BaseResponseModel class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BaseResponseModel()
Visual Basic
Public Sub New
Visual C++
public:
BaseResponseModel()

See Also

BaseResponseModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


BaseResponseModel Fields

[image] [image]

SharpShooter Reports.Web
BaseResponseModel Fields
BaseResponseModel Class See Also Send Feedback

The BaseResponseModel type exposes the following members.

Fields

 | Name | Description
Public field | Error |

See Also

BaseResponseModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Error Field

[image]

SharpShooter Reports.Web
BaseResponseModel..::..Error Field
BaseResponseModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.BaseResponseModel.Error"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ErrorInfoModel Error
Visual Basic
Public Error As ErrorInfoModel
Visual C++
public:
ErrorInfoModel^ Error

See Also

BaseResponseModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


BaseResponseModel Methods

[image] [image]

SharpShooter Reports.Web
BaseResponseModel Methods
BaseResponseModel Class See Also Send Feedback

The BaseResponseModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseResponseModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


BookmarkInfo Class

[image]

SharpShooter Reports.Web
BookmarkInfo Class
Members See Also Send Feedback
Represents information about location of a bookmark on a page

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BookmarkInfo
Visual Basic
Public Class BookmarkInfo
Visual C++
public ref class BookmarkInfo

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..BookmarkInfo

See Also

BookmarkInfo Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


BookmarkInfo Members

[image] [image]

SharpShooter Reports.Web
BookmarkInfo Members
BookmarkInfo Class Constructors Methods Fields See Also Send Feedback

The BookmarkInfo type exposes the following members.

Constructors

 | Name | Description
Public method | BookmarkInfo | Initializes a new instance of the BookmarkInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | PageNumber | Gets or sets a page number.
Public field | X | Gets or sets a horizontal position.
Public field | Y | Gets or sets a vertical position.

See Also

BookmarkInfo Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


BookmarkInfo Constructor

[image]

SharpShooter Reports.Web
BookmarkInfo Constructor
BookmarkInfo Class See Also Send Feedback
Initializes a new instance of the BookmarkInfo class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BookmarkInfo()
Visual Basic
Public Sub New
Visual C++
public:
BookmarkInfo()

See Also

BookmarkInfo Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


BookmarkInfo Fields

[image] [image]

SharpShooter Reports.Web
BookmarkInfo Fields
BookmarkInfo Class See Also Send Feedback

The BookmarkInfo type exposes the following members.

Fields

 | Name | Description
Public field | PageNumber | Gets or sets a page number.
Public field | X | Gets or sets a horizontal position.
Public field | Y | Gets or sets a vertical position.

See Also

BookmarkInfo Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


PageNumber Field

[image]

SharpShooter Reports.Web
BookmarkInfo..::..PageNumber Field
BookmarkInfo Class See Also Send Feedback
Gets or sets a page number.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int PageNumber
Visual Basic
Public PageNumber As Integer
Visual C++
public:
int PageNumber

See Also

BookmarkInfo Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


X Field

[image]

SharpShooter Reports.Web
BookmarkInfo..::..X Field
BookmarkInfo Class See Also Send Feedback
Gets or sets a horizontal position.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float X
Visual Basic
Public X As Single
Visual C++
public:
float X

See Also

BookmarkInfo Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Y Field

[image]

SharpShooter Reports.Web
BookmarkInfo..::..Y Field
BookmarkInfo Class See Also Send Feedback
Gets or sets a vertical position.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float Y
Visual Basic
Public Y As Single
Visual C++
public:
float Y

See Also

BookmarkInfo Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


BookmarkInfo Methods

[image] [image]

SharpShooter Reports.Web
BookmarkInfo Methods
BookmarkInfo Class See Also Send Feedback

The BookmarkInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BookmarkInfo Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentIdModel Class

[image]

SharpShooter Reports.Web
DocumentIdModel Class
Members See Also Send Feedback
Represent a document identifier information.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DocumentIdModel
Visual Basic
Public Class DocumentIdModel
Visual C++
public ref class DocumentIdModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentIdModel
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentInfoModel
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentMapInfoModel
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentMapInfoRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadPageInfoRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadThumbnailsInfoRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..PageInfoModel
PerpetuumSoft.Reporting.WebViewer.Model..::..ThumbnailsInfoModel

See Also

DocumentIdModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentIdModel Members

[image] [image]

SharpShooter Reports.Web
DocumentIdModel Members
DocumentIdModel Class Constructors Methods Fields See Also Send Feedback

The DocumentIdModel type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentIdModel | Initializes a new instance of the DocumentIdModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentId |

See Also

DocumentIdModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentIdModel Constructor

[image]

SharpShooter Reports.Web
DocumentIdModel Constructor
DocumentIdModel Class See Also Send Feedback
Initializes a new instance of the DocumentIdModel class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentIdModel()
Visual Basic
Public Sub New
Visual C++
public:
DocumentIdModel()

See Also

DocumentIdModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentIdModel Fields

[image] [image]

SharpShooter Reports.Web
DocumentIdModel Fields
DocumentIdModel Class See Also Send Feedback

The DocumentIdModel type exposes the following members.

Fields

 | Name | Description
Public field | DocumentId |

See Also

DocumentIdModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentId Field

[image]

SharpShooter Reports.Web
DocumentIdModel..::..DocumentId Field
DocumentIdModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.DocumentIdModel.DocumentId"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DocumentId
Visual Basic
Public DocumentId As String
Visual C++
public:
String^ DocumentId

See Also

DocumentIdModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentIdModel Methods

[image] [image]

SharpShooter Reports.Web
DocumentIdModel Methods
DocumentIdModel Class See Also Send Feedback

The DocumentIdModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentIdModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentInfoModel Class

[image]

SharpShooter Reports.Web
DocumentInfoModel Class
Members See Also Send Feedback
Represent a document data.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DocumentInfoModel : DocumentIdModel
Visual Basic
Public Class DocumentInfoModel _
    Inherits DocumentIdModel
Visual C++
public ref class DocumentInfoModel : public DocumentIdModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentIdModel
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentInfoModel

See Also

DocumentInfoModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentInfoModel Members

[image] [image]

SharpShooter Reports.Web
DocumentInfoModel Members
DocumentInfoModel Class Constructors Methods Fields See Also Send Feedback

The DocumentInfoModel type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentInfoModel | Initializes a new instance of the PerpetuumSoft.Reporting.WebViewer.Model.DocumentInfoModel class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | HasDocumentMap |
Public field | Pages |
Public field | Title |

See Also

DocumentInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentInfoModel Constructor

[image]

SharpShooter Reports.Web
DocumentInfoModel Constructor
DocumentInfoModel Class See Also Send Feedback
Initializes a new instance of the PerpetuumSoft.Reporting.WebViewer.Model.DocumentInfoModel class.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentInfoModel()
Visual Basic
Public Sub New
Visual C++
public:
DocumentInfoModel()

See Also

DocumentInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentInfoModel Fields

[image] [image]

SharpShooter Reports.Web
DocumentInfoModel Fields
DocumentInfoModel Class See Also Send Feedback

The DocumentInfoModel type exposes the following members.

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | HasDocumentMap |
Public field | Pages |
Public field | Title |

See Also

DocumentInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


HasDocumentMap Field

[image]

SharpShooter Reports.Web
DocumentInfoModel..::..HasDocumentMap Field
DocumentInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.DocumentInfoModel.HasDocumentMap"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool HasDocumentMap
Visual Basic
Public HasDocumentMap As Boolean
Visual C++
public:
bool HasDocumentMap

See Also

DocumentInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Pages Field

[image]

SharpShooter Reports.Web
DocumentInfoModel..::..Pages Field
DocumentInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.DocumentInfoModel.Pages"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<ElementSizeModel> Pages
Visual Basic
Public Pages As List(Of ElementSizeModel)
Visual C++
public:
List<ElementSizeModel^>^ Pages

See Also

DocumentInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Title Field

[image]

SharpShooter Reports.Web
DocumentInfoModel..::..Title Field
DocumentInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.DocumentInfoModel.Title"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Title
Visual Basic
Public Title As String
Visual C++
public:
String^ Title

See Also

DocumentInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentInfoModel Methods

[image] [image]

SharpShooter Reports.Web
DocumentInfoModel Methods
DocumentInfoModel Class See Also Send Feedback

The DocumentInfoModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentMapInfoModel Class

[image]

SharpShooter Reports.Web
DocumentMapInfoModel Class
Members See Also Send Feedback
Represent a document map.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DocumentMapInfoModel : DocumentIdModel
Visual Basic
Public Class DocumentMapInfoModel _
    Inherits DocumentIdModel
Visual C++
public ref class DocumentMapInfoModel : public DocumentIdModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentIdModel
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentMapInfoModel

See Also

DocumentMapInfoModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentMapInfoModel Members

[image] [image]

SharpShooter Reports.Web
DocumentMapInfoModel Members
DocumentMapInfoModel Class Constructors Methods Fields See Also Send Feedback

The DocumentMapInfoModel type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentMapInfoModel | Initializes a new instance of the DocumentMapInfoModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | DocumentMap |

See Also

DocumentMapInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentMapInfoModel Constructor

[image]

SharpShooter Reports.Web
DocumentMapInfoModel Constructor
DocumentMapInfoModel Class See Also Send Feedback
Initializes a new instance of the DocumentMapInfoModel class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentMapInfoModel()
Visual Basic
Public Sub New
Visual C++
public:
DocumentMapInfoModel()

See Also

DocumentMapInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentMapInfoModel Fields

[image] [image]

SharpShooter Reports.Web
DocumentMapInfoModel Fields
DocumentMapInfoModel Class See Also Send Feedback

The DocumentMapInfoModel type exposes the following members.

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | DocumentMap |

See Also

DocumentMapInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentMap Field

[image]

SharpShooter Reports.Web
DocumentMapInfoModel..::..DocumentMap Field
DocumentMapInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.DocumentMapInfoModel.DocumentMap"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DocumentMap
Visual Basic
Public DocumentMap As String
Visual C++
public:
String^ DocumentMap

See Also

DocumentMapInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentMapInfoModel Methods

[image] [image]

SharpShooter Reports.Web
DocumentMapInfoModel Methods
DocumentMapInfoModel Class See Also Send Feedback

The DocumentMapInfoModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentMapInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ElementSizeModel Class

[image]

SharpShooter Reports.Web
ElementSizeModel Class
Members See Also Send Feedback
Represent size of a report elements and a page size.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ElementSizeModel
Visual Basic
Public Class ElementSizeModel
Visual C++
public ref class ElementSizeModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..ElementSizeModel

See Also

ElementSizeModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ElementSizeModel Members

[image] [image]

SharpShooter Reports.Web
ElementSizeModel Members
ElementSizeModel Class Constructors Methods Fields See Also Send Feedback

The ElementSizeModel type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSizeModel | Initializes a new instance of PerpetuumSoft.Reporting.WebViewer.Model.ElementSizeModel class from the specified dimensions.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Height |
Public field | Width |

See Also

ElementSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ElementSizeModel Constructor

[image]

SharpShooter Reports.Web
ElementSizeModel Constructor
ElementSizeModel Class See Also Send Feedback
Initializes a new instance of PerpetuumSoft.Reporting.WebViewer.Model.ElementSizeModel class from the specified dimensions.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ElementSizeModel(
    float width,
    float height
)
Visual Basic
Public Sub New ( _
    width As Single, _
    height As Single _
)
Visual C++
public:
ElementSizeModel(
    float width,
    float height
)

Parameters

width
Type: System..::..Single
The width component of the new PerpetuumSoft.Reporting.WebViewer.Model.ElementSizeModel class.
height
Type: System..::..Single
The height component of the new PerpetuumSoft.Reporting.WebViewer.Model.ElementSizeModel class.

See Also

ElementSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ElementSizeModel Fields

[image] [image]

SharpShooter Reports.Web
ElementSizeModel Fields
ElementSizeModel Class See Also Send Feedback

The ElementSizeModel type exposes the following members.

Fields

 | Name | Description
Public field | Height |
Public field | Width |

See Also

ElementSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Height Field

[image]

SharpShooter Reports.Web
ElementSizeModel..::..Height Field
ElementSizeModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ElementSizeModel.Height"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float Height
Visual Basic
Public Height As Single
Visual C++
public:
float Height

See Also

ElementSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Width Field

[image]

SharpShooter Reports.Web
ElementSizeModel..::..Width Field
ElementSizeModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ElementSizeModel.Width"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float Width
Visual Basic
Public Width As Single
Visual C++
public:
float Width

See Also

ElementSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ElementSizeModel Methods

[image] [image]

SharpShooter Reports.Web
ElementSizeModel Methods
ElementSizeModel Class See Also Send Feedback

The ElementSizeModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ErrorInfoModel Class

[image]

SharpShooter Reports.Web
ErrorInfoModel Class
Members See Also Send Feedback
Represent a error data.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ErrorInfoModel
Visual Basic
Public Class ErrorInfoModel
Visual C++
public ref class ErrorInfoModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..ErrorInfoModel

See Also

ErrorInfoModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ErrorInfoModel Members

[image] [image]

SharpShooter Reports.Web
ErrorInfoModel Members
ErrorInfoModel Class Constructors Methods Fields See Also Send Feedback

The ErrorInfoModel type exposes the following members.

Constructors

 | Name | Description
Public method | ErrorInfoModel | Initializes a new instance of the ErrorInfoModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ErrorInformation |
Public field | ErrorType |
Public field | Message |

See Also

ErrorInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ErrorInfoModel Constructor

[image]

SharpShooter Reports.Web
ErrorInfoModel Constructor
ErrorInfoModel Class See Also Send Feedback
Initializes a new instance of the ErrorInfoModel class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ErrorInfoModel()
Visual Basic
Public Sub New
Visual C++
public:
ErrorInfoModel()

See Also

ErrorInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ErrorInfoModel Fields

[image] [image]

SharpShooter Reports.Web
ErrorInfoModel Fields
ErrorInfoModel Class See Also Send Feedback

The ErrorInfoModel type exposes the following members.

Fields

 | Name | Description
Public field | ErrorInformation |
Public field | ErrorType |
Public field | Message |

See Also

ErrorInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ErrorInformation Field

[image]

SharpShooter Reports.Web
ErrorInfoModel..::..ErrorInformation Field
ErrorInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ErrorInfoModel.ErrorInformation"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ErrorInformation
Visual Basic
Public ErrorInformation As String
Visual C++
public:
String^ ErrorInformation

See Also

ErrorInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ErrorType Field

[image]

SharpShooter Reports.Web
ErrorInfoModel..::..ErrorType Field
ErrorInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ErrorInfoModel.ErrorType"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ExceptionType ErrorType
Visual Basic
Public ErrorType As ExceptionType
Visual C++
public:
ExceptionType ErrorType

See Also

ErrorInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Message Field

[image]

SharpShooter Reports.Web
ErrorInfoModel..::..Message Field
ErrorInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ErrorInfoModel.Message"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Message
Visual Basic
Public Message As String
Visual C++
public:
String^ Message

See Also

ErrorInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ErrorInfoModel Methods

[image] [image]

SharpShooter Reports.Web
ErrorInfoModel Methods
ErrorInfoModel Class See Also Send Feedback

The ErrorInfoModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ErrorInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ExceptionType Enumeration

[image]

SharpShooter Reports.Web
ExceptionType Enumeration
See Also Send Feedback
Represent a error type.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ExceptionType
Visual Basic
Public Enumeration ExceptionType
Visual C++
public enum class ExceptionType

Members

Member name | Description
OutOfCache |
EmptyRequest |
InvalidDocumentId |
EmptyReportName |
ReportNotFound |
TemplateIsNull |
ControlIndexOutOfRange |
PageNumberOutOfRange |
ExportFormatIsNotDefined |
ReportManagerNotDefined |
ReportSlotNotFount |
SizeNullError |
SizePositiveError |
IncorrectExportFormat |
ReportServiceNull |

See Also

PerpetuumSoft.Reporting.WebViewer.Model Namespace


FullRequest Class

[image]

SharpShooter Reports.Web
FullRequest Class
Members See Also Send Feedback
Contains data for report rendering.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FullRequest
Visual Basic
Public Class FullRequest
Visual C++
public ref class FullRequest

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..FullRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentMapInfoFullRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadPageInfoFullRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadThumbnailsInfoFullRequest

See Also

FullRequest Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


FullRequest Members

[image] [image]

SharpShooter Reports.Web
FullRequest Members
FullRequest Class Constructors Methods Fields See Also Send Feedback

The FullRequest type exposes the following members.

Constructors

 | Name | Description
Public method | FullRequest | Initializes a new instance of the FullRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentInfoRequest |

See Also

FullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


FullRequest Constructor

[image]

SharpShooter Reports.Web
FullRequest Constructor
FullRequest Class See Also Send Feedback
Initializes a new instance of the FullRequest class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FullRequest()
Visual Basic
Public Sub New
Visual C++
public:
FullRequest()

See Also

FullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


FullRequest Fields

[image] [image]

SharpShooter Reports.Web
FullRequest Fields
FullRequest Class See Also Send Feedback

The FullRequest type exposes the following members.

Fields

 | Name | Description
Public field | DocumentInfoRequest |

See Also

FullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentInfoRequest Field

[image]

SharpShooter Reports.Web
FullRequest..::..DocumentInfoRequest Field
FullRequest Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.FullRequest.DocumentInfoRequest"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadDocumentInfoRequest DocumentInfoRequest
Visual Basic
Public DocumentInfoRequest As LoadDocumentInfoRequest
Visual C++
public:
LoadDocumentInfoRequest^ DocumentInfoRequest

See Also

FullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


FullRequest Methods

[image] [image]

SharpShooter Reports.Web
FullRequest Methods
FullRequest Class See Also Send Feedback

The FullRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentInfoRequest Class

[image]

SharpShooter Reports.Web
LoadDocumentInfoRequest Class
Members See Also Send Feedback
Contains client request body with a report name and a parameter list.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadDocumentInfoRequest : LoadReportParametersRequest
Visual Basic
Public Class LoadDocumentInfoRequest _
    Inherits LoadReportParametersRequest
Visual C++
public ref class LoadDocumentInfoRequest : public LoadReportParametersRequest

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadReportParametersRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentInfoRequest

See Also

LoadDocumentInfoRequest Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentInfoRequest Members

[image] [image]

SharpShooter Reports.Web
LoadDocumentInfoRequest Members
LoadDocumentInfoRequest Class Constructors Methods Fields See Also Send Feedback

The LoadDocumentInfoRequest type exposes the following members.

Constructors

 | Name | Description
Public method | LoadDocumentInfoRequest | Initializes a new instance of PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentInfoRequest class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Parameters |
Public field | ReportName | (Inherited from LoadReportParametersRequest.)

See Also

LoadDocumentInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentInfoRequest Constructor

[image]

SharpShooter Reports.Web
LoadDocumentInfoRequest Constructor
LoadDocumentInfoRequest Class See Also Send Feedback
Initializes a new instance of PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentInfoRequest class.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadDocumentInfoRequest()
Visual Basic
Public Sub New
Visual C++
public:
LoadDocumentInfoRequest()

See Also

LoadDocumentInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentInfoRequest Fields

[image] [image]

SharpShooter Reports.Web
LoadDocumentInfoRequest Fields
LoadDocumentInfoRequest Class See Also Send Feedback

The LoadDocumentInfoRequest type exposes the following members.

Fields

 | Name | Description
Public field | Parameters |
Public field | ReportName | (Inherited from LoadReportParametersRequest.)

See Also

LoadDocumentInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Parameters Field

[image]

SharpShooter Reports.Web
LoadDocumentInfoRequest..::..Parameters Field
LoadDocumentInfoRequest Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentInfoRequest.Parameters"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<ParameterModel> Parameters
Visual Basic
Public Parameters As List(Of ParameterModel)
Visual C++
public:
List<ParameterModel^>^ Parameters

See Also

LoadDocumentInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentInfoRequest Methods

[image] [image]

SharpShooter Reports.Web
LoadDocumentInfoRequest Methods
LoadDocumentInfoRequest Class See Also Send Feedback

The LoadDocumentInfoRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadDocumentInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentInfoResponse Class

[image]

SharpShooter Reports.Web
LoadDocumentInfoResponse Class
Members See Also Send Feedback
Contains server response body with a document data.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadDocumentInfoResponse : BaseResponseModel
Visual Basic
Public Class LoadDocumentInfoResponse _
    Inherits BaseResponseModel
Visual C++
public ref class LoadDocumentInfoResponse : public BaseResponseModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..BaseResponseModel
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentInfoResponse

See Also

LoadDocumentInfoResponse Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentInfoResponse Members

[image] [image]

SharpShooter Reports.Web
LoadDocumentInfoResponse Members
LoadDocumentInfoResponse Class Constructors Methods Fields See Also Send Feedback

The LoadDocumentInfoResponse type exposes the following members.

Constructors

 | Name | Description
Public method | LoadDocumentInfoResponse | Initializes a new instance of the LoadDocumentInfoResponse class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Error | (Inherited from BaseResponseModel.)
Public field | Result |

See Also

LoadDocumentInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentInfoResponse Constructor

[image]

SharpShooter Reports.Web
LoadDocumentInfoResponse Constructor
LoadDocumentInfoResponse Class See Also Send Feedback
Initializes a new instance of the LoadDocumentInfoResponse class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadDocumentInfoResponse()
Visual Basic
Public Sub New
Visual C++
public:
LoadDocumentInfoResponse()

See Also

LoadDocumentInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentInfoResponse Fields

[image] [image]

SharpShooter Reports.Web
LoadDocumentInfoResponse Fields
LoadDocumentInfoResponse Class See Also Send Feedback

The LoadDocumentInfoResponse type exposes the following members.

Fields

 | Name | Description
Public field | Error | (Inherited from BaseResponseModel.)
Public field | Result |

See Also

LoadDocumentInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Result Field

[image]

SharpShooter Reports.Web
LoadDocumentInfoResponse..::..Result Field
LoadDocumentInfoResponse Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentInfoResponse.Result"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentInfoModel Result
Visual Basic
Public Result As DocumentInfoModel
Visual C++
public:
DocumentInfoModel^ Result

See Also

LoadDocumentInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentInfoResponse Methods

[image] [image]

SharpShooter Reports.Web
LoadDocumentInfoResponse Methods
LoadDocumentInfoResponse Class See Also Send Feedback

The LoadDocumentInfoResponse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadDocumentInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoFullRequest Class

[image]

SharpShooter Reports.Web
LoadDocumentMapInfoFullRequest Class
Members See Also Send Feedback
Contains data for report rendering and getting data about bookmarks tree.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadDocumentMapInfoFullRequest : FullRequest
Visual Basic
Public Class LoadDocumentMapInfoFullRequest _
    Inherits FullRequest
Visual C++
public ref class LoadDocumentMapInfoFullRequest : public FullRequest

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..FullRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentMapInfoFullRequest

See Also

LoadDocumentMapInfoFullRequest Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoFullRequest Members

[image] [image]

SharpShooter Reports.Web
LoadDocumentMapInfoFullRequest Members
LoadDocumentMapInfoFullRequest Class Constructors Methods Fields See Also Send Feedback

The LoadDocumentMapInfoFullRequest type exposes the following members.

Constructors

 | Name | Description
Public method | LoadDocumentMapInfoFullRequest | Initializes a new instance of the LoadDocumentMapInfoFullRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentInfoRequest | (Inherited from FullRequest.)
Public field | DocumentMapInfoRequest |

See Also

LoadDocumentMapInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoFullRequest Constructor

[image]

SharpShooter Reports.Web
LoadDocumentMapInfoFullRequest Constructor
LoadDocumentMapInfoFullRequest Class See Also Send Feedback
Initializes a new instance of the LoadDocumentMapInfoFullRequest class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadDocumentMapInfoFullRequest()
Visual Basic
Public Sub New
Visual C++
public:
LoadDocumentMapInfoFullRequest()

See Also

LoadDocumentMapInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoFullRequest Fields

[image] [image]

SharpShooter Reports.Web
LoadDocumentMapInfoFullRequest Fields
LoadDocumentMapInfoFullRequest Class See Also Send Feedback

The LoadDocumentMapInfoFullRequest type exposes the following members.

Fields

 | Name | Description
Public field | DocumentInfoRequest | (Inherited from FullRequest.)
Public field | DocumentMapInfoRequest |

See Also

LoadDocumentMapInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DocumentMapInfoRequest Field

[image]

SharpShooter Reports.Web
LoadDocumentMapInfoFullRequest..::..DocumentMapInfoRequest Field
LoadDocumentMapInfoFullRequest Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentMapInfoFullRequest.DocumentMapInfoRequest"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadDocumentMapInfoRequest DocumentMapInfoRequest
Visual Basic
Public DocumentMapInfoRequest As LoadDocumentMapInfoRequest
Visual C++
public:
LoadDocumentMapInfoRequest^ DocumentMapInfoRequest

See Also

LoadDocumentMapInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoFullRequest Methods

[image] [image]

SharpShooter Reports.Web
LoadDocumentMapInfoFullRequest Methods
LoadDocumentMapInfoFullRequest Class See Also Send Feedback

The LoadDocumentMapInfoFullRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadDocumentMapInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoRequest Class

[image]

SharpShooter Reports.Web
LoadDocumentMapInfoRequest Class
Members See Also Send Feedback
Contains client request body with a document identifier.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadDocumentMapInfoRequest : DocumentIdModel
Visual Basic
Public Class LoadDocumentMapInfoRequest _
    Inherits DocumentIdModel
Visual C++
public ref class LoadDocumentMapInfoRequest : public DocumentIdModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentIdModel
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentMapInfoRequest

See Also

LoadDocumentMapInfoRequest Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoRequest Members

[image] [image]

SharpShooter Reports.Web
LoadDocumentMapInfoRequest Members
LoadDocumentMapInfoRequest Class Constructors Methods Fields See Also Send Feedback

The LoadDocumentMapInfoRequest type exposes the following members.

Constructors

 | Name | Description
Public method | LoadDocumentMapInfoRequest | Initializes a new instance of the LoadDocumentMapInfoRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)

See Also

LoadDocumentMapInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoRequest Constructor

[image]

SharpShooter Reports.Web
LoadDocumentMapInfoRequest Constructor
LoadDocumentMapInfoRequest Class See Also Send Feedback
Initializes a new instance of the LoadDocumentMapInfoRequest class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadDocumentMapInfoRequest()
Visual Basic
Public Sub New
Visual C++
public:
LoadDocumentMapInfoRequest()

See Also

LoadDocumentMapInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoRequest Fields

[image] [image]

SharpShooter Reports.Web
LoadDocumentMapInfoRequest Fields
LoadDocumentMapInfoRequest Class See Also Send Feedback

The LoadDocumentMapInfoRequest type exposes the following members.

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)

See Also

LoadDocumentMapInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoRequest Methods

[image] [image]

SharpShooter Reports.Web
LoadDocumentMapInfoRequest Methods
LoadDocumentMapInfoRequest Class See Also Send Feedback

The LoadDocumentMapInfoRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadDocumentMapInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoResponse Class

[image]

SharpShooter Reports.Web
LoadDocumentMapInfoResponse Class
Members See Also Send Feedback
Contains server response body with a document map data.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadDocumentMapInfoResponse : BaseResponseModel
Visual Basic
Public Class LoadDocumentMapInfoResponse _
    Inherits BaseResponseModel
Visual C++
public ref class LoadDocumentMapInfoResponse : public BaseResponseModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..BaseResponseModel
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentMapInfoResponse

See Also

LoadDocumentMapInfoResponse Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoResponse Members

[image] [image]

SharpShooter Reports.Web
LoadDocumentMapInfoResponse Members
LoadDocumentMapInfoResponse Class Constructors Methods Fields See Also Send Feedback

The LoadDocumentMapInfoResponse type exposes the following members.

Constructors

 | Name | Description
Public method | LoadDocumentMapInfoResponse | Initializes a new instance of the LoadDocumentMapInfoResponse class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Error | (Inherited from BaseResponseModel.)
Public field | Result |

See Also

LoadDocumentMapInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoResponse Constructor

[image]

SharpShooter Reports.Web
LoadDocumentMapInfoResponse Constructor
LoadDocumentMapInfoResponse Class See Also Send Feedback
Initializes a new instance of the LoadDocumentMapInfoResponse class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadDocumentMapInfoResponse()
Visual Basic
Public Sub New
Visual C++
public:
LoadDocumentMapInfoResponse()

See Also

LoadDocumentMapInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoResponse Fields

[image] [image]

SharpShooter Reports.Web
LoadDocumentMapInfoResponse Fields
LoadDocumentMapInfoResponse Class See Also Send Feedback

The LoadDocumentMapInfoResponse type exposes the following members.

Fields

 | Name | Description
Public field | Error | (Inherited from BaseResponseModel.)
Public field | Result |

See Also

LoadDocumentMapInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Result Field

[image]

SharpShooter Reports.Web
LoadDocumentMapInfoResponse..::..Result Field
LoadDocumentMapInfoResponse Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadDocumentMapInfoResponse.Result"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentMapInfoModel Result
Visual Basic
Public Result As DocumentMapInfoModel
Visual C++
public:
DocumentMapInfoModel^ Result

See Also

LoadDocumentMapInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadDocumentMapInfoResponse Methods

[image] [image]

SharpShooter Reports.Web
LoadDocumentMapInfoResponse Methods
LoadDocumentMapInfoResponse Class See Also Send Feedback

The LoadDocumentMapInfoResponse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadDocumentMapInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoFullRequest Class

[image]

SharpShooter Reports.Web
LoadPageInfoFullRequest Class
Members See Also Send Feedback
Contains data for report rendering and getting data about a page.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadPageInfoFullRequest : FullRequest
Visual Basic
Public Class LoadPageInfoFullRequest _
    Inherits FullRequest
Visual C++
public ref class LoadPageInfoFullRequest : public FullRequest

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..FullRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadPageInfoFullRequest

See Also

LoadPageInfoFullRequest Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoFullRequest Members

[image] [image]

SharpShooter Reports.Web
LoadPageInfoFullRequest Members
LoadPageInfoFullRequest Class Constructors Methods Fields See Also Send Feedback

The LoadPageInfoFullRequest type exposes the following members.

Constructors

 | Name | Description
Public method | LoadPageInfoFullRequest | Initializes a new instance of the LoadPageInfoFullRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentInfoRequest | (Inherited from FullRequest.)
Public field | PageInfoRequest |

See Also

LoadPageInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoFullRequest Constructor

[image]

SharpShooter Reports.Web
LoadPageInfoFullRequest Constructor
LoadPageInfoFullRequest Class See Also Send Feedback
Initializes a new instance of the LoadPageInfoFullRequest class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadPageInfoFullRequest()
Visual Basic
Public Sub New
Visual C++
public:
LoadPageInfoFullRequest()

See Also

LoadPageInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoFullRequest Fields

[image] [image]

SharpShooter Reports.Web
LoadPageInfoFullRequest Fields
LoadPageInfoFullRequest Class See Also Send Feedback

The LoadPageInfoFullRequest type exposes the following members.

Fields

 | Name | Description
Public field | DocumentInfoRequest | (Inherited from FullRequest.)
Public field | PageInfoRequest |

See Also

LoadPageInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


PageInfoRequest Field

[image]

SharpShooter Reports.Web
LoadPageInfoFullRequest..::..PageInfoRequest Field
LoadPageInfoFullRequest Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadPageInfoFullRequest.PageInfoRequest"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadPageInfoRequest PageInfoRequest
Visual Basic
Public PageInfoRequest As LoadPageInfoRequest
Visual C++
public:
LoadPageInfoRequest^ PageInfoRequest

See Also

LoadPageInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoFullRequest Methods

[image] [image]

SharpShooter Reports.Web
LoadPageInfoFullRequest Methods
LoadPageInfoFullRequest Class See Also Send Feedback

The LoadPageInfoFullRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadPageInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoRequest Class

[image]

SharpShooter Reports.Web
LoadPageInfoRequest Class
Members See Also Send Feedback
Contains client request body with a document identifier and a page number.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadPageInfoRequest : DocumentIdModel
Visual Basic
Public Class LoadPageInfoRequest _
    Inherits DocumentIdModel
Visual C++
public ref class LoadPageInfoRequest : public DocumentIdModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentIdModel
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadPageInfoRequest

See Also

LoadPageInfoRequest Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoRequest Members

[image] [image]

SharpShooter Reports.Web
LoadPageInfoRequest Members
LoadPageInfoRequest Class Constructors Methods Fields See Also Send Feedback

The LoadPageInfoRequest type exposes the following members.

Constructors

 | Name | Description
Public method | LoadPageInfoRequest | Initializes a new instance of the LoadPageInfoRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | PageNumber |

See Also

LoadPageInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoRequest Constructor

[image]

SharpShooter Reports.Web
LoadPageInfoRequest Constructor
LoadPageInfoRequest Class See Also Send Feedback
Initializes a new instance of the LoadPageInfoRequest class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadPageInfoRequest()
Visual Basic
Public Sub New
Visual C++
public:
LoadPageInfoRequest()

See Also

LoadPageInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoRequest Fields

[image] [image]

SharpShooter Reports.Web
LoadPageInfoRequest Fields
LoadPageInfoRequest Class See Also Send Feedback

The LoadPageInfoRequest type exposes the following members.

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | PageNumber |

See Also

LoadPageInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


PageNumber Field

[image]

SharpShooter Reports.Web
LoadPageInfoRequest..::..PageNumber Field
LoadPageInfoRequest Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadPageInfoRequest.PageNumber"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int PageNumber
Visual Basic
Public PageNumber As Integer
Visual C++
public:
int PageNumber

See Also

LoadPageInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoRequest Methods

[image] [image]

SharpShooter Reports.Web
LoadPageInfoRequest Methods
LoadPageInfoRequest Class See Also Send Feedback

The LoadPageInfoRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadPageInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoResponse Class

[image]

SharpShooter Reports.Web
LoadPageInfoResponse Class
Members See Also Send Feedback
Contains server response body with a page data.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadPageInfoResponse : BaseResponseModel
Visual Basic
Public Class LoadPageInfoResponse _
    Inherits BaseResponseModel
Visual C++
public ref class LoadPageInfoResponse : public BaseResponseModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..BaseResponseModel
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadPageInfoResponse

See Also

LoadPageInfoResponse Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoResponse Members

[image] [image]

SharpShooter Reports.Web
LoadPageInfoResponse Members
LoadPageInfoResponse Class Constructors Methods Fields See Also Send Feedback

The LoadPageInfoResponse type exposes the following members.

Constructors

 | Name | Description
Public method | LoadPageInfoResponse | Initializes a new instance of the LoadPageInfoResponse class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Error | (Inherited from BaseResponseModel.)
Public field | Result |

See Also

LoadPageInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoResponse Constructor

[image]

SharpShooter Reports.Web
LoadPageInfoResponse Constructor
LoadPageInfoResponse Class See Also Send Feedback
Initializes a new instance of the LoadPageInfoResponse class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadPageInfoResponse()
Visual Basic
Public Sub New
Visual C++
public:
LoadPageInfoResponse()

See Also

LoadPageInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoResponse Fields

[image] [image]

SharpShooter Reports.Web
LoadPageInfoResponse Fields
LoadPageInfoResponse Class See Also Send Feedback

The LoadPageInfoResponse type exposes the following members.

Fields

 | Name | Description
Public field | Error | (Inherited from BaseResponseModel.)
Public field | Result |

See Also

LoadPageInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Result Field

[image]

SharpShooter Reports.Web
LoadPageInfoResponse..::..Result Field
LoadPageInfoResponse Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadPageInfoResponse.Result"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageInfoModel Result
Visual Basic
Public Result As PageInfoModel
Visual C++
public:
PageInfoModel^ Result

See Also

LoadPageInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadPageInfoResponse Methods

[image] [image]

SharpShooter Reports.Web
LoadPageInfoResponse Methods
LoadPageInfoResponse Class See Also Send Feedback

The LoadPageInfoResponse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadPageInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadReportParametersRequest Class

[image]

SharpShooter Reports.Web
LoadReportParametersRequest Class
Members See Also Send Feedback
Contains client request body with a report name.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadReportParametersRequest
Visual Basic
Public Class LoadReportParametersRequest
Visual C++
public ref class LoadReportParametersRequest

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadReportParametersRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadDocumentInfoRequest

See Also

LoadReportParametersRequest Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadReportParametersRequest Members

[image] [image]

SharpShooter Reports.Web
LoadReportParametersRequest Members
LoadReportParametersRequest Class Constructors Methods Fields See Also Send Feedback

The LoadReportParametersRequest type exposes the following members.

Constructors

 | Name | Description
Public method | LoadReportParametersRequest | Initializes a new instance of the LoadReportParametersRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ReportName |

See Also

LoadReportParametersRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadReportParametersRequest Constructor

[image]

SharpShooter Reports.Web
LoadReportParametersRequest Constructor
LoadReportParametersRequest Class See Also Send Feedback
Initializes a new instance of the LoadReportParametersRequest class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadReportParametersRequest()
Visual Basic
Public Sub New
Visual C++
public:
LoadReportParametersRequest()

See Also

LoadReportParametersRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadReportParametersRequest Fields

[image] [image]

SharpShooter Reports.Web
LoadReportParametersRequest Fields
LoadReportParametersRequest Class See Also Send Feedback

The LoadReportParametersRequest type exposes the following members.

Fields

 | Name | Description
Public field | ReportName |

See Also

LoadReportParametersRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ReportName Field

[image]

SharpShooter Reports.Web
LoadReportParametersRequest..::..ReportName Field
LoadReportParametersRequest Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadReportParametersRequest.ReportName"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ReportName
Visual Basic
Public ReportName As String
Visual C++
public:
String^ ReportName

See Also

LoadReportParametersRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadReportParametersRequest Methods

[image] [image]

SharpShooter Reports.Web
LoadReportParametersRequest Methods
LoadReportParametersRequest Class See Also Send Feedback

The LoadReportParametersRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadReportParametersRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadReportParametersResponse Class

[image]

SharpShooter Reports.Web
LoadReportParametersResponse Class
Members See Also Send Feedback
Contains server response body with a parameters list from report.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadReportParametersResponse : BaseResponseModel
Visual Basic
Public Class LoadReportParametersResponse _
    Inherits BaseResponseModel
Visual C++
public ref class LoadReportParametersResponse : public BaseResponseModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..BaseResponseModel
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadReportParametersResponse

See Also

LoadReportParametersResponse Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadReportParametersResponse Members

[image] [image]

SharpShooter Reports.Web
LoadReportParametersResponse Members
LoadReportParametersResponse Class Constructors Methods Fields See Also Send Feedback

The LoadReportParametersResponse type exposes the following members.

Constructors

 | Name | Description
Public method | LoadReportParametersResponse | Initializes a new instance of the LoadReportParametersResponse class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Error | (Inherited from BaseResponseModel.)
Public field | Result |

See Also

LoadReportParametersResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadReportParametersResponse Constructor

[image]

SharpShooter Reports.Web
LoadReportParametersResponse Constructor
LoadReportParametersResponse Class See Also Send Feedback
Initializes a new instance of the LoadReportParametersResponse class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadReportParametersResponse()
Visual Basic
Public Sub New
Visual C++
public:
LoadReportParametersResponse()

See Also

LoadReportParametersResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadReportParametersResponse Fields

[image] [image]

SharpShooter Reports.Web
LoadReportParametersResponse Fields
LoadReportParametersResponse Class See Also Send Feedback

The LoadReportParametersResponse type exposes the following members.

Fields

 | Name | Description
Public field | Error | (Inherited from BaseResponseModel.)
Public field | Result |

See Also

LoadReportParametersResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Result Field

[image]

SharpShooter Reports.Web
LoadReportParametersResponse..::..Result Field
LoadReportParametersResponse Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadReportParametersResponse.Result"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportParametersModel Result
Visual Basic
Public Result As ReportParametersModel
Visual C++
public:
ReportParametersModel^ Result

See Also

LoadReportParametersResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadReportParametersResponse Methods

[image] [image]

SharpShooter Reports.Web
LoadReportParametersResponse Methods
LoadReportParametersResponse Class See Also Send Feedback

The LoadReportParametersResponse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadReportParametersResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoFullRequest Class

[image]

SharpShooter Reports.Web
LoadThumbnailsInfoFullRequest Class
Members See Also Send Feedback
Contains data for report rendering and getting data about thumbnails link collection.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadThumbnailsInfoFullRequest : FullRequest
Visual Basic
Public Class LoadThumbnailsInfoFullRequest _
    Inherits FullRequest
Visual C++
public ref class LoadThumbnailsInfoFullRequest : public FullRequest

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..FullRequest
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadThumbnailsInfoFullRequest

See Also

LoadThumbnailsInfoFullRequest Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoFullRequest Members

[image] [image]

SharpShooter Reports.Web
LoadThumbnailsInfoFullRequest Members
LoadThumbnailsInfoFullRequest Class Constructors Methods Fields See Also Send Feedback

The LoadThumbnailsInfoFullRequest type exposes the following members.

Constructors

 | Name | Description
Public method | LoadThumbnailsInfoFullRequest | Initializes a new instance of the LoadThumbnailsInfoFullRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentInfoRequest | (Inherited from FullRequest.)
Public field | ThumbnailsInfoRequest |

See Also

LoadThumbnailsInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoFullRequest Constructor

[image]

SharpShooter Reports.Web
LoadThumbnailsInfoFullRequest Constructor
LoadThumbnailsInfoFullRequest Class See Also Send Feedback
Initializes a new instance of the LoadThumbnailsInfoFullRequest class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadThumbnailsInfoFullRequest()
Visual Basic
Public Sub New
Visual C++
public:
LoadThumbnailsInfoFullRequest()

See Also

LoadThumbnailsInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoFullRequest Fields

[image] [image]

SharpShooter Reports.Web
LoadThumbnailsInfoFullRequest Fields
LoadThumbnailsInfoFullRequest Class See Also Send Feedback

The LoadThumbnailsInfoFullRequest type exposes the following members.

Fields

 | Name | Description
Public field | DocumentInfoRequest | (Inherited from FullRequest.)
Public field | ThumbnailsInfoRequest |

See Also

LoadThumbnailsInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailsInfoRequest Field

[image]

SharpShooter Reports.Web
LoadThumbnailsInfoFullRequest..::..ThumbnailsInfoRequest Field
LoadThumbnailsInfoFullRequest Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadThumbnailsInfoFullRequest.ThumbnailsInfoRequest"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadThumbnailsInfoRequest ThumbnailsInfoRequest
Visual Basic
Public ThumbnailsInfoRequest As LoadThumbnailsInfoRequest
Visual C++
public:
LoadThumbnailsInfoRequest^ ThumbnailsInfoRequest

See Also

LoadThumbnailsInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoFullRequest Methods

[image] [image]

SharpShooter Reports.Web
LoadThumbnailsInfoFullRequest Methods
LoadThumbnailsInfoFullRequest Class See Also Send Feedback

The LoadThumbnailsInfoFullRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadThumbnailsInfoFullRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoRequest Class

[image]

SharpShooter Reports.Web
LoadThumbnailsInfoRequest Class
Members See Also Send Feedback
Contains client request body with a document identifier and thumbnails size.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadThumbnailsInfoRequest : DocumentIdModel
Visual Basic
Public Class LoadThumbnailsInfoRequest _
    Inherits DocumentIdModel
Visual C++
public ref class LoadThumbnailsInfoRequest : public DocumentIdModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentIdModel
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadThumbnailsInfoRequest

See Also

LoadThumbnailsInfoRequest Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoRequest Members

[image] [image]

SharpShooter Reports.Web
LoadThumbnailsInfoRequest Members
LoadThumbnailsInfoRequest Class Constructors Methods Fields See Also Send Feedback

The LoadThumbnailsInfoRequest type exposes the following members.

Constructors

 | Name | Description
Public method | LoadThumbnailsInfoRequest | Initializes a new instance of the LoadThumbnailsInfoRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | ThumbnailSize |

See Also

LoadThumbnailsInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoRequest Constructor

[image]

SharpShooter Reports.Web
LoadThumbnailsInfoRequest Constructor
LoadThumbnailsInfoRequest Class See Also Send Feedback
Initializes a new instance of the LoadThumbnailsInfoRequest class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadThumbnailsInfoRequest()
Visual Basic
Public Sub New
Visual C++
public:
LoadThumbnailsInfoRequest()

See Also

LoadThumbnailsInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoRequest Fields

[image] [image]

SharpShooter Reports.Web
LoadThumbnailsInfoRequest Fields
LoadThumbnailsInfoRequest Class See Also Send Feedback

The LoadThumbnailsInfoRequest type exposes the following members.

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | ThumbnailSize |

See Also

LoadThumbnailsInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailSize Field

[image]

SharpShooter Reports.Web
LoadThumbnailsInfoRequest..::..ThumbnailSize Field
LoadThumbnailsInfoRequest Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadThumbnailsInfoRequest.ThumbnailSize"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThumbnailSizeModel ThumbnailSize
Visual Basic
Public ThumbnailSize As ThumbnailSizeModel
Visual C++
public:
ThumbnailSizeModel^ ThumbnailSize

See Also

LoadThumbnailsInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoRequest Methods

[image] [image]

SharpShooter Reports.Web
LoadThumbnailsInfoRequest Methods
LoadThumbnailsInfoRequest Class See Also Send Feedback

The LoadThumbnailsInfoRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadThumbnailsInfoRequest Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoResponse Class

[image]

SharpShooter Reports.Web
LoadThumbnailsInfoResponse Class
Members See Also Send Feedback
Contains server response body with thumbnail data.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadThumbnailsInfoResponse : BaseResponseModel
Visual Basic
Public Class LoadThumbnailsInfoResponse _
    Inherits BaseResponseModel
Visual C++
public ref class LoadThumbnailsInfoResponse : public BaseResponseModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..BaseResponseModel
PerpetuumSoft.Reporting.WebViewer.Model..::..LoadThumbnailsInfoResponse

See Also

LoadThumbnailsInfoResponse Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoResponse Members

[image] [image]

SharpShooter Reports.Web
LoadThumbnailsInfoResponse Members
LoadThumbnailsInfoResponse Class Constructors Methods Fields See Also Send Feedback

The LoadThumbnailsInfoResponse type exposes the following members.

Constructors

 | Name | Description
Public method | LoadThumbnailsInfoResponse | Initializes a new instance of the LoadThumbnailsInfoResponse class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Error | (Inherited from BaseResponseModel.)
Public field | Result |

See Also

LoadThumbnailsInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoResponse Constructor

[image]

SharpShooter Reports.Web
LoadThumbnailsInfoResponse Constructor
LoadThumbnailsInfoResponse Class See Also Send Feedback
Initializes a new instance of the LoadThumbnailsInfoResponse class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadThumbnailsInfoResponse()
Visual Basic
Public Sub New
Visual C++
public:
LoadThumbnailsInfoResponse()

See Also

LoadThumbnailsInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoResponse Fields

[image] [image]

SharpShooter Reports.Web
LoadThumbnailsInfoResponse Fields
LoadThumbnailsInfoResponse Class See Also Send Feedback

The LoadThumbnailsInfoResponse type exposes the following members.

Fields

 | Name | Description
Public field | Error | (Inherited from BaseResponseModel.)
Public field | Result |

See Also

LoadThumbnailsInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Result Field

[image]

SharpShooter Reports.Web
LoadThumbnailsInfoResponse..::..Result Field
LoadThumbnailsInfoResponse Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.LoadThumbnailsInfoResponse.Result"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThumbnailsInfoModel Result
Visual Basic
Public Result As ThumbnailsInfoModel
Visual C++
public:
ThumbnailsInfoModel^ Result

See Also

LoadThumbnailsInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


LoadThumbnailsInfoResponse Methods

[image] [image]

SharpShooter Reports.Web
LoadThumbnailsInfoResponse Methods
LoadThumbnailsInfoResponse Class See Also Send Feedback

The LoadThumbnailsInfoResponse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadThumbnailsInfoResponse Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


PageInfoModel Class

[image]

SharpShooter Reports.Web
PageInfoModel Class
Members See Also Send Feedback
Represent a page data.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PageInfoModel : DocumentIdModel
Visual Basic
Public Class PageInfoModel _
    Inherits DocumentIdModel
Visual C++
public ref class PageInfoModel : public DocumentIdModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentIdModel
PerpetuumSoft.Reporting.WebViewer.Model..::..PageInfoModel

See Also

PageInfoModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


PageInfoModel Members

[image] [image]

SharpShooter Reports.Web
PageInfoModel Members
PageInfoModel Class Constructors Methods Fields See Also Send Feedback

The PageInfoModel type exposes the following members.

Constructors

 | Name | Description
Public method | PageInfoModel | Initializes a new instance of the PageInfoModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | Loaded |
Public field | Loading |
Public field | PageContent |
Public field | PageNumber |

See Also

PageInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


PageInfoModel Constructor

[image]

SharpShooter Reports.Web
PageInfoModel Constructor
PageInfoModel Class See Also Send Feedback
Initializes a new instance of the PageInfoModel class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageInfoModel()
Visual Basic
Public Sub New
Visual C++
public:
PageInfoModel()

See Also

PageInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


PageInfoModel Fields

[image] [image]

SharpShooter Reports.Web
PageInfoModel Fields
PageInfoModel Class See Also Send Feedback

The PageInfoModel type exposes the following members.

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | Loaded |
Public field | Loading |
Public field | PageContent |
Public field | PageNumber |

See Also

PageInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Loaded Field

[image]

SharpShooter Reports.Web
PageInfoModel..::..Loaded Field
PageInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.PageInfoModel.Loaded"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Loaded
Visual Basic
Public Loaded As Boolean
Visual C++
public:
bool Loaded

See Also

PageInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Loading Field

[image]

SharpShooter Reports.Web
PageInfoModel..::..Loading Field
PageInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.PageInfoModel.Loading"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Loading
Visual Basic
Public Loading As Boolean
Visual C++
public:
bool Loading

See Also

PageInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


PageContent Field

[image]

SharpShooter Reports.Web
PageInfoModel..::..PageContent Field
PageInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.PageInfoModel.PageContent"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PageContent
Visual Basic
Public PageContent As String
Visual C++
public:
String^ PageContent

See Also

PageInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


PageNumber Field

[image]

SharpShooter Reports.Web
PageInfoModel..::..PageNumber Field
PageInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.PageInfoModel.PageNumber"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int PageNumber
Visual Basic
Public PageNumber As Integer
Visual C++
public:
int PageNumber

See Also

PageInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


PageInfoModel Methods

[image] [image]

SharpShooter Reports.Web
PageInfoModel Methods
PageInfoModel Class See Also Send Feedback

The PageInfoModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ParameterModel Class

[image]

SharpShooter Reports.Web
ParameterModel Class
Members See Also Send Feedback
Represent a parameter data.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ParameterModel
Visual Basic
Public Class ParameterModel
Visual C++
public ref class ParameterModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..ParameterModel

See Also

ParameterModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ParameterModel Members

[image] [image]

SharpShooter Reports.Web
ParameterModel Members
ParameterModel Class Constructors Methods Fields See Also Send Feedback

The ParameterModel type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterModel | Initializes a new instance of the ParameterModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DefaultValue |
Public field | Name |
Public field | Type |
Public field | Value |

See Also

ParameterModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ParameterModel Constructor

[image]

SharpShooter Reports.Web
ParameterModel Constructor
ParameterModel Class See Also Send Feedback
Initializes a new instance of the ParameterModel class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ParameterModel()
Visual Basic
Public Sub New
Visual C++
public:
ParameterModel()

See Also

ParameterModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ParameterModel Fields

[image] [image]

SharpShooter Reports.Web
ParameterModel Fields
ParameterModel Class See Also Send Feedback

The ParameterModel type exposes the following members.

Fields

 | Name | Description
Public field | DefaultValue |
Public field | Name |
Public field | Type |
Public field | Value |

See Also

ParameterModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


DefaultValue Field

[image]

SharpShooter Reports.Web
ParameterModel..::..DefaultValue Field
ParameterModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ParameterModel.DefaultValue"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DefaultValue
Visual Basic
Public DefaultValue As String
Visual C++
public:
String^ DefaultValue

See Also

ParameterModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Name Field

[image]

SharpShooter Reports.Web
ParameterModel..::..Name Field
ParameterModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ParameterModel.Name"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name
Visual Basic
Public Name As String
Visual C++
public:
String^ Name

See Also

ParameterModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Type Field

[image]

SharpShooter Reports.Web
ParameterModel..::..Type Field
ParameterModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ParameterModel.Type"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Type
Visual Basic
Public Type As String
Visual C++
public:
String^ Type

See Also

ParameterModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Value Field

[image]

SharpShooter Reports.Web
ParameterModel..::..Value Field
ParameterModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ParameterModel.Value"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Value
Visual Basic
Public Value As String
Visual C++
public:
String^ Value

See Also

ParameterModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ParameterModel Methods

[image] [image]

SharpShooter Reports.Web
ParameterModel Methods
ParameterModel Class See Also Send Feedback

The ParameterModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ReportParametersModel Class

[image]

SharpShooter Reports.Web
ReportParametersModel Class
Members See Also Send Feedback
Contains client request body with a parameter list from a report.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ReportParametersModel
Visual Basic
Public Class ReportParametersModel
Visual C++
public ref class ReportParametersModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..ReportParametersModel

See Also

ReportParametersModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ReportParametersModel Members

[image] [image]

SharpShooter Reports.Web
ReportParametersModel Members
ReportParametersModel Class Constructors Methods Fields See Also Send Feedback

The ReportParametersModel type exposes the following members.

Constructors

 | Name | Description
Public method | ReportParametersModel | Initializes a new instance of the ReportParametersModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ReportParameters |

See Also

ReportParametersModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ReportParametersModel Constructor

[image]

SharpShooter Reports.Web
ReportParametersModel Constructor
ReportParametersModel Class See Also Send Feedback
Initializes a new instance of the ReportParametersModel class

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportParametersModel()
Visual Basic
Public Sub New
Visual C++
public:
ReportParametersModel()

See Also

ReportParametersModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ReportParametersModel Fields

[image] [image]

SharpShooter Reports.Web
ReportParametersModel Fields
ReportParametersModel Class See Also Send Feedback

The ReportParametersModel type exposes the following members.

Fields

 | Name | Description
Public field | ReportParameters |

See Also

ReportParametersModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ReportParameters Field

[image]

SharpShooter Reports.Web
ReportParametersModel..::..ReportParameters Field
ReportParametersModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ReportParametersModel.ReportParameters"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<ParameterModel> ReportParameters
Visual Basic
Public ReportParameters As List(Of ParameterModel)
Visual C++
public:
List<ParameterModel^>^ ReportParameters

See Also

ReportParametersModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ReportParametersModel Methods

[image] [image]

SharpShooter Reports.Web
ReportParametersModel Methods
ReportParametersModel Class See Also Send Feedback

The ReportParametersModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportParametersModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailsInfoModel Class

[image]

SharpShooter Reports.Web
ThumbnailsInfoModel Class
Members See Also Send Feedback
Represent a thumbnail data.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ThumbnailsInfoModel : DocumentIdModel
Visual Basic
Public Class ThumbnailsInfoModel _
    Inherits DocumentIdModel
Visual C++
public ref class ThumbnailsInfoModel : public DocumentIdModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..DocumentIdModel
PerpetuumSoft.Reporting.WebViewer.Model..::..ThumbnailsInfoModel

See Also

ThumbnailsInfoModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailsInfoModel Members

[image] [image]

SharpShooter Reports.Web
ThumbnailsInfoModel Members
ThumbnailsInfoModel Class Constructors Methods Fields See Also Send Feedback

The ThumbnailsInfoModel type exposes the following members.

Constructors

 | Name | Description
Public method | ThumbnailsInfoModel | Initializes a new instance of the PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailsInfoModel class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | ThumbnailSize |
Public field | ThumbnailsLink |

See Also

ThumbnailsInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailsInfoModel Constructor

[image]

SharpShooter Reports.Web
ThumbnailsInfoModel Constructor
ThumbnailsInfoModel Class See Also Send Feedback
Initializes a new instance of the PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailsInfoModel class.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThumbnailsInfoModel()
Visual Basic
Public Sub New
Visual C++
public:
ThumbnailsInfoModel()

See Also

ThumbnailsInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailsInfoModel Fields

[image] [image]

SharpShooter Reports.Web
ThumbnailsInfoModel Fields
ThumbnailsInfoModel Class See Also Send Feedback

The ThumbnailsInfoModel type exposes the following members.

Fields

 | Name | Description
Public field | DocumentId | (Inherited from DocumentIdModel.)
Public field | ThumbnailSize |
Public field | ThumbnailsLink |

See Also

ThumbnailsInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailSize Field

[image]

SharpShooter Reports.Web
ThumbnailsInfoModel..::..ThumbnailSize Field
ThumbnailsInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailsInfoModel.ThumbnailSize"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThumbnailSizeModel ThumbnailSize
Visual Basic
Public ThumbnailSize As ThumbnailSizeModel
Visual C++
public:
ThumbnailSizeModel^ ThumbnailSize

See Also

ThumbnailsInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailsLink Field

[image]

SharpShooter Reports.Web
ThumbnailsInfoModel..::..ThumbnailsLink Field
ThumbnailsInfoModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailsInfoModel.ThumbnailsLink"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> ThumbnailsLink
Visual Basic
Public ThumbnailsLink As List(Of String)
Visual C++
public:
List<String^>^ ThumbnailsLink

See Also

ThumbnailsInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailsInfoModel Methods

[image] [image]

SharpShooter Reports.Web
ThumbnailsInfoModel Methods
ThumbnailsInfoModel Class See Also Send Feedback

The ThumbnailsInfoModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThumbnailsInfoModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailSizeModel Class

[image]

SharpShooter Reports.Web
ThumbnailSizeModel Class
Members See Also Send Feedback
Represent a thumbnails size.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ThumbnailSizeModel
Visual Basic
Public Class ThumbnailSizeModel
Visual C++
public ref class ThumbnailSizeModel

Inheritance Hierarchy

System..::..Object
PerpetuumSoft.Reporting.WebViewer.Model..::..ThumbnailSizeModel

See Also

ThumbnailSizeModel Members
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailSizeModel Members

[image] [image]

SharpShooter Reports.Web
ThumbnailSizeModel Members
ThumbnailSizeModel Class Constructors Methods Fields See Also Send Feedback

The ThumbnailSizeModel type exposes the following members.

Constructors

 | Name | Description
Public method | ThumbnailSizeModel | Initializes a new instance of PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailSizeModel class from the specified dimensions.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Height |
Public field | Width |

See Also

ThumbnailSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailSizeModel Constructor

[image]

SharpShooter Reports.Web
ThumbnailSizeModel Constructor
ThumbnailSizeModel Class See Also Send Feedback
Initializes a new instance of PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailSizeModel class from the specified dimensions.

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThumbnailSizeModel(
    int width,
    int height
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
ThumbnailSizeModel(
    int width,
    int height
)

Parameters

width
Type: System..::..Int32
The width component of the new PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailSizeModel class.
height
Type: System..::..Int32
The height component of the new PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailSizeModel class.

See Also

ThumbnailSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailSizeModel Fields

[image] [image]

SharpShooter Reports.Web
ThumbnailSizeModel Fields
ThumbnailSizeModel Class See Also Send Feedback

The ThumbnailSizeModel type exposes the following members.

Fields

 | Name | Description
Public field | Height |
Public field | Width |

See Also

ThumbnailSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Height Field

[image]

SharpShooter Reports.Web
ThumbnailSizeModel..::..Height Field
ThumbnailSizeModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailSizeModel.Height"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Height
Visual Basic
Public Height As Integer
Visual C++
public:
int Height

See Also

ThumbnailSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


Width Field

[image]

SharpShooter Reports.Web
ThumbnailSizeModel..::..Width Field
ThumbnailSizeModel Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.Reporting.WebViewer.Model.ThumbnailSizeModel.Width"]

Namespace: PerpetuumSoft.Reporting.WebViewer.Model
Assembly: PerpetuumSoft.Reporting.WebViewer.Client.Model (in PerpetuumSoft.Reporting.WebViewer.Client.Model.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Width
Visual Basic
Public Width As Integer
Visual C++
public:
int Width

See Also

ThumbnailSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace


ThumbnailSizeModel Methods

[image] [image]

SharpShooter Reports.Web
ThumbnailSizeModel Methods
ThumbnailSizeModel Class See Also Send Feedback

The ThumbnailSizeModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThumbnailSizeModel Class
PerpetuumSoft.Reporting.WebViewer.Model Namespace